summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-11-01 09:45:29 +0000
committerTorsten Veller <tove@gentoo.org>2008-11-01 09:45:29 +0000
commit615cdd234aa6fa468c4778e73307bd997656dfd1 (patch)
tree554e78588a9e28596e9abb36569393653ba5e2e1 /dev-lang/perl
parentC::R 5.800_pre2 is now hard masked (diff)
downloadperl-overlay-615cdd234aa6fa468c4778e73307bd997656dfd1.tar.gz
perl-overlay-615cdd234aa6fa468c4778e73307bd997656dfd1.tar.bz2
perl-overlay-615cdd234aa6fa468c4778e73307bd997656dfd1.zip
Some fixes: keywords, depend, cosmetics
Diffstat (limited to 'dev-lang/perl')
-rw-r--r--dev-lang/perl/Manifest2
-rw-r--r--dev-lang/perl/perl-5.10.0.ebuild100
2 files changed, 41 insertions, 61 deletions
diff --git a/dev-lang/perl/Manifest b/dev-lang/perl/Manifest
index 065d89d6f..e78202025 100644
--- a/dev-lang/perl/Manifest
+++ b/dev-lang/perl/Manifest
@@ -3,4 +3,4 @@ AUX perl-h2ph-ansi-header.patch 446 RMD160 8baf89df0d3f916a8c4f437444fa1af01f5fa
AUX perl-picdl.patch 250 RMD160 2a9cb2fe5debb0db2d3fd063f52f459ee4f4946f SHA1 3000bd0130ed20e0ff5d9fb0147240e3909473a7 SHA256 fdbe94e869457b7e62bdc76b82a13ecd6e500c223d609b1767285190efd63cfa
AUX perl-prelink-lpthread.patch 476 RMD160 f3252258e5f7a0f82b5f9ea49598ea9f4b0b44b6 SHA1 4202c290c578dfec58d5dbebf7f8f780a483f908 SHA256 289d0bdd08105e7fdf1c2d683d76a0cdcd009998f3ecd84f3a75cf79ab84e7a0
DIST perl-5.10.0.tar.gz 15595020 RMD160 c6614fc99a162790a703f91085b24a60af903ba2 SHA1 adf73606dd5248af7ccdd735bcaa0e628ea75b3c SHA256 94464a0d374fa63226eee56e0bb3d35564f9d8391a1a8d9f0055805ec25f3b2e
-EBUILD perl-5.10.0.ebuild 18358 RMD160 573c029cb9780c892e22f4b07c2caa7d5b6a9fb2 SHA1 e7c6dd3504ba5a32f4df8c0a519e3ad0c1a96fcc SHA256 c6b3738509f69ac7240acd2eff18f94ac014a607366cb3dac1e1c522287b6511
+EBUILD perl-5.10.0.ebuild 18385 RMD160 7e42ce8dd84d0eac2d5edbc892f57a719dae1f2a SHA1 b18c9c1dbf3b0c7f9b6b1c295636ac10a28ea475 SHA256 a36085763240e658e03266f80772aab8ffd8c9dbf80fdfc565bcb7a308d59177
diff --git a/dev-lang/perl/perl-5.10.0.ebuild b/dev-lang/perl/perl-5.10.0.ebuild
index 6f2eff7a6..79f0c59d0 100644
--- a/dev-lang/perl/perl-5.10.0.ebuild
+++ b/dev-lang/perl/perl-5.10.0.ebuild
@@ -18,7 +18,7 @@ LIBPERL="libperl$(get_libname ${PERLSLOT}.${SHORT_PV})"
LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="berkdb debug doc gdbm ithreads perlsuid build"
PERL_OLDVERSEN=""
@@ -35,15 +35,14 @@ RDEPEND="~sys-devel/libperl-${PV}
PDEPEND=">=app-admin/perl-cleaner-1.03
!build? (
- >=perl-core/PodParser-1.32
- >=perl-core/Test-Harness-2.56
+ >=perl-core/PodParser-1.35
+ >=perl-core/Test-Harness-2.64
)"
pkg_setup() {
# I think this should rather be displayed if you *have* 'ithreads'
# in USE if it could break things ...
- if use ithreads
- then
+ if use ithreads ; then
ewarn "PLEASE NOTE: You are compiling ${MY_P} with"
ewarn "interpreter-level threading enabled."
ewarn "Threading is not supported by all applications "
@@ -52,8 +51,7 @@ pkg_setup() {
epause 5
fi
- if [ ! -f "${ROOT}/usr/$(get_libdir)/${LIBPERL}" ]
- then
+ if [[ ! -f "${ROOT}/usr/$(get_libdir)/${LIBPERL}" ]] ; then
# Make sure we have libperl installed ...
eerror "Cannot find ${ROOT}/usr/$(get_libdir)/${LIBPERL}! Make sure that you"
eerror "have sys-libs/libperl installed properly ..."
@@ -116,7 +114,6 @@ src_unpack() {
# has_version '>=sys-kernel/linux-headers' && \
# has_version '>=sys-devel/gcc-4.1' \
# && epatch "${FILESDIR}"/${P}-SysV_makefile.patch
-
}
myconf() {
@@ -152,8 +149,7 @@ src_configure() {
*) osname="linux" ;;
esac
- if use ithreads
- then
+ if use ithreads ; then
einfo "using ithreads"
mythreading="-multi"
myconf -Dusethreads
@@ -172,48 +168,41 @@ src_configure() {
mygdbm='U'
mydb='U'
- if use gdbm
- then
+ if use gdbm ; then
mygdbm='D'
myndbm='D'
fi
- if use berkdb
- then
+ if use berkdb ; then
mydb='D'
has_version '=sys-libs/db-1*' && myndbm='D'
fi
myconf "-${myndbm}i_ndbm" "-${mygdbm}i_gdbm" "-${mydb}i_db"
- if use mips
- then
+ if use mips ; then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf -Dd_u32align
fi
- if use perlsuid
- then
+ if use perlsuid ; then
myconf -Dd_dosuid
ewarn "You have enabled Perl's suid compile. Please"
ewarn "read http://perldoc.com/perl5.8.2/INSTALL.html#suidperl"
epause 3
fi
- if use debug
- then
+ if use debug ; then
CFLAGS="${CFLAGS} -g"
myconf -DDEBUGGING
fi
- if use sparc
- then
+ if use sparc ; then
myconf -Ud_longdbl
fi
- if use alpha && "$(tc-getCC)" == "ccc"
- then
+ if use alpha && [[ "$(tc-getCC)" = "ccc" ]] ; then
ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
myconf -Ui_db -Ui_ndbm
fi
@@ -256,7 +245,6 @@ src_configure() {
}
src_compile() {
-
# would like to bracket this with a test for the existence of a
# dotfile, but can't clean it automatically now.
@@ -271,7 +259,6 @@ src_test() {
}
src_install() {
-
export LC_ALL="C"
# Need to do this, else apps do not link to dynamic version of
@@ -298,7 +285,6 @@ src_install() {
cp -f utils/h2ph utils/h2ph_patched
epatch "${FILESDIR}"/${PN}-h2ph-ansi-header.patch
-
LD_LIBRARY_PATH=. ./perl -Ilib utils/h2ph_patched \
-a -d "${D}"/usr/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading} <<EOF
asm/termios.h
@@ -312,11 +298,11 @@ wait.h
EOF
# This is to fix a missing c flag for backwards compat
- for i in `find "${D}"/usr/$(get_libdir)/perl5 -iname "Config.pm"`;do
- sed -e "s:ccflags=':ccflags='-DPERL5 :" \
- -e "s:cppflags=':cppflags='-DPERL5 :" \
- "${i}" > "${i}".new &&\
- mv "${i}".new "${i}" || die "Sed failed"
+ for i in $(find "${D}"/usr/$(get_libdir)/perl5 -iname "Config.pm" ) ; do
+ sed -i \
+ -e "s:ccflags=':ccflags='-DPERL5 :" \
+ -e "s:cppflags=':cppflags='-DPERL5 :" \
+ "${i}" || die "Sed failed"
done
# A poor fix for the miniperl issues
@@ -326,10 +312,9 @@ EOF
fperms 0755 /usr/bin/xsubpp
# This removes ${D} from Config.pm and .packlist
- for i in `find "${D}" -iname "Config.pm"` `find "${D}" -iname ".packlist"`;do
+ for i in $(find "${D}" -iname "Config.pm" -o -iname ".packlist" ) ; do
einfo "Removing ${D} from ${i}..."
- sed -e "s:${D}::" "${i}" > "${i}".new &&\
- mv "${i}".new "${i}" || die "Sed failed"
+ dosed "${i}" || die "Sed failed"
done
# Note: find out from psm why we would need/want this.
@@ -338,8 +323,7 @@ EOF
dodoc Changes* Artistic Copying README Todo* AUTHORS
- if use doc
- then
+ if use doc ; then
# HTML Documentation
# We expect errors, warnings, and such with the following.
@@ -351,7 +335,7 @@ EOF
--htmldir="${D}/usr/share/doc/${PF}/html" \
--libpods='perlfunc:perlguts:perlvar:perlrun:perlop'
fi
- cd `find "${D}" -name Path.pm|sed -e 's/Path.pm//'`
+ #cd `find "${D}" -name Path.pm | sed -e 's/Path.pm//'`
# CAN patch in bug 79685
#epatch "${FILESDIR}"/${P}-CAN-2005-0448-rmtree.patch
@@ -368,16 +352,14 @@ EOF
src_remove_extra_files
fi
- # TODO: Ugly. renaming the files for SLOTting
- cd "${D}"/usr/bin
- for bin in "a2p c2ph config_data corelist cpan cpan2dist cpanp cpanp-run-perl dprofpp enc2xs find2perl h2ph h2xs instmodsh libnetcfg perlbug perldoc perlivp piconv pl2pm pod2html pod2latex pod2man pod2text pod2usage podchecker podselect prove psed pstruct ptar ptardiff s2p shasum splain xsubpp"; do
- mv $bin ${bin}.${MY_PV}
- done
-
+# # TODO: Ugly. renaming the files for SLOTting
+# cd "${D}"/usr/bin
+# for bin in "a2p c2ph config_data corelist cpan cpan2dist cpanp cpanp-run-perl dprofpp enc2xs find2perl h2ph h2xs instmodsh libnetcfg perlbug perldoc perlivp piconv pl2pm pod2html pod2latex pod2man pod2text pod2usage podchecker podselect prove psed pstruct ptar ptardiff s2p shasum splain xsubpp"; do
+# mv $bin ${bin}.${MY_PV}
+# done
}
-src_remove_extra_files()
-{
+src_remove_extra_files() {
local prefix="./usr" # ./ is important
local bindir="${prefix}/bin"
local perlroot="${prefix}/$(get_libdir)/perl5" # perl installs per-arch dirs
@@ -550,7 +532,6 @@ src_remove_extra_files()
${prV}/warnings.pm
${prV}/warnings/register.pm"
-
if use perlsuid ; then
MINIMAL_PERL_INSTALL="${MINIMAL_PERL_INSTALL}
${bindir}/suidperl
@@ -561,21 +542,20 @@ src_remove_extra_files()
# Remove cruft
einfo "Removing files that are not in the minimal install"
echo "${MINIMAL_PERL_INSTALL}"
- for f in $(find . -type f); do
+ for f in $(find . -type f ) ; do
has "${f}" ${MINIMAL_PERL_INSTALL} || rm -f "${f}"
done
# Remove empty directories
- find . -depth -type d | xargs -r rmdir &> /dev/null
+ find . -depth -type d -print0 | xargs -0 -r rmdir &> /dev/null
popd > /dev/null
}
pkg_postinst() {
INC=$(perl -e 'for $line (@INC) { next if $line eq "."; next if $line =~ m/'${MY_PV}'|etc|local|perl$/; print "$line\n" }')
- if [ "${ROOT}" = "/" ]
- then
+ if [[ "${ROOT}" = "/" ]] ; then
ebegin "Removing old .ph files"
for DIR in ${INC}; do
- if [ -d "${ROOT}/${DIR}" ]; then
+ if [[ -d "${ROOT}/${DIR}" ]]; then
for file in $(find "${ROOT}/${DIR}" -name "*.ph" -type f); do
rm "${ROOT}/${file}"
einfo "<< ${file}"
@@ -584,25 +564,26 @@ pkg_postinst() {
done
# Silently remove the now empty dirs
for DIR in ${INC}; do
- if [ -d "${ROOT}/${DIR}" ]; then
- find "${ROOT}/${DIR}" -depth -type d | xargs -r rmdir &> /dev/null
- fi
+ if [[ -d "${ROOT}/${DIR}" ]]; then
+ find "${ROOT}/${DIR}" -depth -type d -print0 | xargs -0 -r rmdir &> /dev/null
+ fi
done
ebegin "Generating ConfigLocal.pm (ignore any error)"
enc2xs -C
ebegin "Converting C header files to the corresponding Perl format"
- cd /usr/include;
+ cd /usr/include
h2ph *
h2ph -r sys/* arpa/* netinet/* bits/* security/* asm/* gnu/* linux/* gentoo*
- cd /usr/include/linux
- h2ph *
+ # TODO: vv isn't it done above already ^^^^^
+ #cd /usr/include/linux
+ #h2ph *
fi
# This has been moved into a function because rumor has it that a future release
# of portage will allow us to check what version was just removed - which means
# we will be able to invoke this only as needed :)
# Tried doing this via -z, but $INC is too big...
- if [ "${INC}x" != "x" ]; then
+ if [[ "${INC}x" != "x" ]]; then
cleaner_msg
epause 5
fi
@@ -627,5 +608,4 @@ cleaner_msg() {
eerror "the problem, please check http://bugs.gentoo.org/"
eerror "for more information or to report a bug."
eerror ""
- eerror ""
}