summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2011-04-12 12:29:47 +1200
committerKent Fredric <kentfredric@gmail.com>2011-04-12 12:29:47 +1200
commit9fac0047f8b689312bdbf50ddfdd100a55035619 (patch)
treec168822aec27f4e9892b88af03c4a52ea630fe2c /dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.190.0.ebuild
parent[addzero] Apache-Htpasswd (diff)
downloadperl-overlay-9fac0047f8b689312bdbf50ddfdd100a55035619.tar.gz
perl-overlay-9fac0047f8b689312bdbf50ddfdd100a55035619.tar.bz2
perl-overlay-9fac0047f8b689312bdbf50ddfdd100a55035619.zip
[addzero,fixdep(addzero)] CGI-Application-Plugin-Authentication, -> Apache-Htpasswd
(Portage version: 2.2.0_alpha29/git/Linux x86_64, signed Manifest commit with key 0A0CB301)
Diffstat (limited to 'dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.190.0.ebuild')
-rw-r--r--dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.190.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.190.0.ebuild b/dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.190.0.ebuild
new file mode 100644
index 000000000..e9e2818fc
--- /dev/null
+++ b/dev-perl/CGI-Application-Plugin-Authentication/CGI-Application-Plugin-Authentication-0.190.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=3
+MODULE_AUTHOR=SILASMONK
+MODULE_VERSION="0.19"
+inherit perl-module
+
+DESCRIPTION="Authentication framework for CGI::Application"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="recommended"
+RDEPEND="
+ >=dev-perl/CGI-Application-4
+ >=virtual/perl-CGI-3.16
+ dev-perl/Digest-SHA1
+ dev-perl/UNIVERSAL-require
+ virtual/perl-Attribute-Handlers
+ virtual/perl-Class-ISA
+ virtual/perl-MIME-Base64
+ virtual/perl-Scalar-List-Utils
+ recommended? (
+ >=dev-perl/Apache-Htpasswd-1.800.0
+ >=dev-perl/Color-Calc-0.120.0
+ dev-perl/CGI-Application-Plugin-Session
+ virtual/perl-Digest-MD5
+ )
+
+"
+DEPEND="
+ >=dev-perl/Test-Warn-0.11
+ >=virtual/perl-Module-Build-0.36
+"
+# dev-perl/Task-Weaken
+DEPEND="${DEPEND}
+ dev-perl/Test-Exception
+ dev-perl/Test-MockObject
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Regression
+ dev-perl/Test-Taint
+ dev-perl/Test-Without-Module
+ >=virtual/perl-Test-Simple-0.93
+ ${RDEPEND}
+"
+SRC_TEST=do