summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2009-10-30 01:22:57 +1300
committerKent Fredric <kentfredric@gmail.com>2009-10-30 01:22:57 +1300
commitfea8ccf96efc74c364c4f623d03f5524a5bafcaa (patch)
treeafebab00186b8c6b971365ba0fbea579fbef68b2 /dev-perl/Catalyst-Plugin-Session-Store-DBIC/Catalyst-Plugin-Session-Store-DBIC-0.10.ebuild
parentERROR. Fixed (diff)
downloadperl-overlay-fea8ccf96efc74c364c4f623d03f5524a5bafcaa.tar.gz
perl-overlay-fea8ccf96efc74c364c4f623d03f5524a5bafcaa.tar.bz2
perl-overlay-fea8ccf96efc74c364c4f623d03f5524a5bafcaa.zip
EAPI=2, QA, Catalyst-Plugin-Session-Store-DBIC
(Portage version: 2.2_rc46/git/Linux x86_64) (Signed Manifest commit)
Diffstat (limited to 'dev-perl/Catalyst-Plugin-Session-Store-DBIC/Catalyst-Plugin-Session-Store-DBIC-0.10.ebuild')
-rw-r--r--dev-perl/Catalyst-Plugin-Session-Store-DBIC/Catalyst-Plugin-Session-Store-DBIC-0.10.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-perl/Catalyst-Plugin-Session-Store-DBIC/Catalyst-Plugin-Session-Store-DBIC-0.10.ebuild b/dev-perl/Catalyst-Plugin-Session-Store-DBIC/Catalyst-Plugin-Session-Store-DBIC-0.10.ebuild
index d8f79491d..294c09dd2 100644
--- a/dev-perl/Catalyst-Plugin-Session-Store-DBIC/Catalyst-Plugin-Session-Store-DBIC-0.10.ebuild
+++ b/dev-perl/Catalyst-Plugin-Session-Store-DBIC/Catalyst-Plugin-Session-Store-DBIC-0.10.ebuild
@@ -2,21 +2,33 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
MODULE_AUTHOR=FLORA
inherit perl-module
DESCRIPTION="File storage backend for session data"
-IUSE=""
+IUSE="test"
SLOT="0"
LICENSE="|| ( Artistic GPL-2 )"
KEYWORDS="~amd64 ~x86"
-DEPEND="
+RDEPEND="
>=dev-perl/Catalyst-Runtime-5.65
>=dev-perl/Catalyst-Plugin-Session-Store-Delegate-0.02
dev-perl/Class-Accessor
>=dev-perl/DBIx-Class-0.07000
+ virtual/perl-MIME-Base64
dev-perl/MRO-Compat
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-perl/Test-Warn
+ )
"
+SRC_TEST="do"