summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Beltrame <mb@cattlegrid.info>2010-04-29 23:49:24 +0200
committerMichele Beltrame <mb@cattlegrid.info>2010-04-29 23:49:24 +0200
commit07d625efd601b016d726bbd120f5e519e487cc2a (patch)
tree220951aa1c0c438bee4a64f0f7fa63d29dd4015d /dev-perl/Mixin-Linewise/Mixin-Linewise-0.003.ebuild
parentBump several Moose-related ebuilds (diff)
downloadperl-overlay-07d625efd601b016d726bbd120f5e519e487cc2a.tar.gz
perl-overlay-07d625efd601b016d726bbd120f5e519e487cc2a.tar.bz2
perl-overlay-07d625efd601b016d726bbd120f5e519e487cc2a.zip
Bumps
(Portage version: 2.1.8.3/git/Linux x86_64) (Unsigned Manifest commit)
Diffstat (limited to 'dev-perl/Mixin-Linewise/Mixin-Linewise-0.003.ebuild')
-rw-r--r--dev-perl/Mixin-Linewise/Mixin-Linewise-0.003.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Mixin-Linewise/Mixin-Linewise-0.003.ebuild b/dev-perl/Mixin-Linewise/Mixin-Linewise-0.003.ebuild
new file mode 100644
index 000000000..e7d7be892
--- /dev/null
+++ b/dev-perl/Mixin-Linewise/Mixin-Linewise-0.003.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=2
+MODULE_AUTHOR=RJBS
+inherit perl-module
+
+DESCRIPTION="write your linewise code for handles; this does the rest"
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+COMMON_DEPEND="
+ dev-perl/IO-String
+ >=dev-perl/Sub-Exporter-0.9
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ >=virtual/perl-Test-Simple-0.88
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+"
+SRC_TEST="do"