summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Abbott <dabbott@gentoo.org>2010-08-13 16:46:21 -0400
committerDavid Abbott <dabbott@gentoo.org>2010-08-13 16:46:21 -0400
commit4515b8c21ce025ebd410240bf7aa7a34f6fcfd6d (patch)
tree8c04463e7c75463c43ac6023fec458ce98cf2b5f /net-analyzer/nikto/nikto-2.1.2.ebuild
parent[new] Log-Any-Adapter-Dispatch-0.06 (diff)
downloadperl-overlay-4515b8c21ce025ebd410240bf7aa7a34f6fcfd6d.tar.gz
perl-overlay-4515b8c21ce025ebd410240bf7aa7a34f6fcfd6d.tar.bz2
perl-overlay-4515b8c21ce025ebd410240bf7aa7a34f6fcfd6d.zip
Bumped to 2.1.2 changed filename nikto to nikto.pl to line up with documentation
(Portage version: 2.2_rc67/git/Linux x86_64) (Signed Manifest commit)
Diffstat (limited to 'net-analyzer/nikto/nikto-2.1.2.ebuild')
-rw-r--r--net-analyzer/nikto/nikto-2.1.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/nikto/nikto-2.1.2.ebuild b/net-analyzer/nikto/nikto-2.1.2.ebuild
new file mode 100644
index 000000000..34ba76392
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Web Server vulnerability scanner."
+HOMEPAGE="http://www.cirt.net/code/nikto.shtml"
+SRC_URI="http://www.cirt.net/source/nikto/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND="dev-lang/perl
+ net-analyzer/nmap
+ ssl? (
+ dev-libs/openssl
+ dev-perl/Net-SSLeay
+ )
+ >=net-libs/libwhisker-2.5"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm plugins/LW2.pm || die "removing bundled lib LW2.pm failed"
+ epatch "${FILESDIR}"/${PF}-PL.patch || die "patch failed"
+}
+
+src_install() {
+
+ dodir /etc/nikto || die "dodir failed"
+ insinto /etc/nikto
+ doins "${FILESDIR}/nikto.conf" || die "doins failed"
+
+ dobin nikto.pl || die "dobin failed"
+ insinto /usr/bin
+ doins nikto.pl || die "doins failed"
+
+ dodir /usr/share/nikto || die "dodir failed"
+ insinto /usr/share/nikto
+ doins docs/nikto.dtd || die "dodoc failed"
+
+ dodir /var/lib/nikto || die "dodir failed"
+ insinto /var/lib/nikto
+ doins -r templates plugins || die "doins failed"
+
+ dodoc docs/*.txt || die "dodoc failed"
+ dohtml docs/nikto_manual.html || die "dohtml failed"
+ doman docs/nikto.1 || die "doman failed"
+}
+
+pkg_postinst() {
+ elog 'Default configuration file is "/etc/nikto/nikto.conf"'
+ elog 'To test "perl /usr/bin/nikto.pl -h 192.168.0.1"'
+ elog 'This will scan the IP 192.168.0.1 on TCP port 80'
+}