summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-11-01 09:45:40 +0000
committerTorsten Veller <tove@gentoo.org>2008-11-01 09:45:40 +0000
commit60db25af2e1bbd4532f9382fef9c17465648e6a4 (patch)
tree7f72af0e75553f1bd5c9d8b1596a5aa8d65a1420 /sys-devel
parentSome fixes: keywords, depend, cosmetics (diff)
downloadperl-overlay-60db25af2e1bbd4532f9382fef9c17465648e6a4.tar.gz
perl-overlay-60db25af2e1bbd4532f9382fef9c17465648e6a4.tar.bz2
perl-overlay-60db25af2e1bbd4532f9382fef9c17465648e6a4.zip
Some fixes
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/Manifest2
-rw-r--r--sys-devel/libperl/libperl-5.10.0.ebuild52
2 files changed, 20 insertions, 34 deletions
diff --git a/sys-devel/libperl/Manifest b/sys-devel/libperl/Manifest
index 7f19b6aaf..6ba5dfa38 100644
--- a/sys-devel/libperl/Manifest
+++ b/sys-devel/libperl/Manifest
@@ -1,4 +1,4 @@
AUX libperl-5.10.0-create-libperl-soname.patch 401 RMD160 85f971825840d060a03c41b3efab738db8209e6c SHA1 cfca756f70f85908bd108f849d9360a7ea363676 SHA256 118efc0c6c5e42188626e63660e84fb5ec83ab65596507c3454651abfeba5e6d
AUX libperl-noksh.patch 611 RMD160 6ddb9e7140c60e05042c3c488c97399a86f965fc SHA1 61bf5bb0955bd04a758d1381fa4260ed9fdbb1d1 SHA256 0861f7f54c184e99a0ffeebeab9420d969d2002f921bc3fb14841a1e24be1f5e
DIST perl-5.10.0.tar.gz 15595020 RMD160 c6614fc99a162790a703f91085b24a60af903ba2 SHA1 adf73606dd5248af7ccdd735bcaa0e628ea75b3c SHA256 94464a0d374fa63226eee56e0bb3d35564f9d8391a1a8d9f0055805ec25f3b2e
-EBUILD libperl-5.10.0.ebuild 9641 RMD160 d43cb9c184798ff3547cce8c4e34c7ae22add0fa SHA1 1238dbb8d8536810df9a4c45ecdcf97c878e15cc SHA256 7e904e724e3ed2d4ad695387d6864c52a315a3721750ee58a3cef5236f1a912c
+EBUILD libperl-5.10.0.ebuild 9628 RMD160 95020486d958a5cd774d53adb196929381d71635 SHA1 9a6d12926e5072974ec5e6a6725847eb8b61d64c SHA256 ef7f0df6183dff1c8a3b9d829b00cae1757c34bf8ab8bc8938971a57cd5a6a81
diff --git a/sys-devel/libperl/libperl-5.10.0.ebuild b/sys-devel/libperl/libperl-5.10.0.ebuild
index c808de283..db7933e23 100644
--- a/sys-devel/libperl/libperl-5.10.0.ebuild
+++ b/sys-devel/libperl/libperl-5.10.0.ebuild
@@ -68,7 +68,7 @@ HOMEPAGE="http://www.perl.org"
SLOT="${PERLSLOT}"
LIBPERL="libperl$(get_libname ${PERLSLOT}.${SHORT_PV})"
LICENSE="|| ( Artistic GPL-2 )"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
# rac 2004.08.06
@@ -93,10 +93,9 @@ PDEPEND="~dev-lang/perl-${PV}"
pkg_setup() {
# I think this should rather be displayed if you *have* 'ithreads'
# in USE if it could break things ...
- if use ithreads
- then
+ if use ithreads ; then
ewarn ""
- ewarn "PLEASE NOTE: You are compiling perl-5.9 with"
+ ewarn "PLEASE NOTE: You are compiling perl-5.10 with"
ewarn "interpreter-level threading enabled."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
@@ -107,7 +106,6 @@ pkg_setup() {
}
src_unpack() {
-
unpack ${A}
# Fix the build scripts to create libperl with a soname of ${SLOT}.
@@ -121,7 +119,7 @@ src_unpack() {
#
cd "${S}";
# TODO: I guess we need this patch
- #use userland_Darwin || epatch "${FILESDIR}"/${P}-create-libperl-soname.patch
+ use userland_Darwin || epatch "${FILESDIR}"/${P}-create-libperl-soname.patch
# Configure makes an unwarranted assumption that /bin/ksh is a
# good shell. This patch makes it revert to using /bin/sh unless
@@ -177,8 +175,7 @@ src_compile() {
*) osname="linux" ;;
esac
- if use ithreads
- then
+ if use ithreads ; then
einfo "using ithreads"
mythreading="-multi"
myconf -Dusethreads
@@ -197,40 +194,34 @@ src_compile() {
mygdbm='U'
mydb='U'
- if use gdbm
- then
+ if use gdbm ; then
mygdbm='D'
myndbm='D'
fi
- if use berkdb
- then
+ if use berkdb ; then
mydb='D'
has_version '=sys-libs/db-1*' && myndbm='D'
fi
myconf "-${myndbm}i_ndbm" "-${mygdbm}i_gdbm" "-${mydb}i_db"
- if use mips
- then
+ if use mips ; then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf -Dd_u32align
fi
- if use debug
- then
+ if use debug ; then
CFLAGS="${CFLAGS} -g"
myconf -DDEBUGGING
fi
- if use sparc
- then
+ if use sparc ; then
myconf -Ud_longdbl
fi
- if use alpha && "$(tc-getCC)" == "ccc"
- then
+ if use alpha && [[ "$(tc-getCC)" == "ccc" ]] ; then
ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
myconf -Ui_db -Ui_ndbm
fi
@@ -274,29 +265,26 @@ src_compile() {
src_install() {
export LC_ALL="C"
- dolib.so "${WORKDIR}"/${LIBPERL}
- dosym ${LIBPERL} /usr/$(get_libdir)/libperl$(get_libname ${PERLSLOT})
+ dolib.so "${WORKDIR}"/${LIBPERL}
+ dosym ${LIBPERL} /usr/$(get_libdir)/libperl$(get_libname ${PERLSLOT})
}
pkg_postinst() {
-
# Make sure we do not have stale/invalid libperl.so 's ...
- if [ -f "${ROOT}usr/$(get_libdir)/libperl$(get_libname)" -a ! -L "${ROOT}usr/$(get_libdir)/libperl$(get_libname)" ]
- then
- mv -f "${ROOT}"usr/$(get_libdir)/libperl$(get_libname) "${ROOT}"usr/$(get_libdir)/libperl$(get_libname).old
+ if [[ -f "${ROOT}usr/$(get_libdir)/libperl$(get_libname)" && \
+ ! -L "${ROOT}usr/$(get_libdir)/libperl$(get_libname)" ]] ; then
+ mv -f "${ROOT}"usr/$(get_libdir)/libperl$(get_libname){,.old}
fi
# Next bit is to try and setup the /usr/lib/libperl.so symlink
# properly ...
local libnumber="`ls -1 ${ROOT}usr/$(get_libdir)/libperl$(get_libname ?.*) | grep -v '\.old' | wc -l`"
- if [ "${libnumber}" -eq 1 ]
- then
+ if [[ "${libnumber}" -eq 1 ]] ; then
# Only this version of libperl is installed, so just link libperl.so
# to the *soname* version of it ...
ln -snf libperl$(get_libname ${PERLSLOT}) "${ROOT}"usr/$(get_libdir)/libperl$(get_libname)
else
- if [ -x "${ROOT}/usr/bin/perl" ]
- then
+ if [[ -x "${ROOT}/usr/bin/perl" ]] ; then
# OK, we have more than one version .. first try to figure out
# if there are already a perl installed, if so, link libperl.so
# to that *soname* version of libperl.so ...
@@ -310,8 +298,7 @@ pkg_postinst() {
# Nope, we are not so lucky ... try to figure out what version
# is the latest, and keep fingers crossed ...
- for x in `ls -1 "${ROOT}"usr/$(get_libdir)/libperl$(get_libname ?.*)`
- do
+ for x in `ls -1 "${ROOT}"usr/$(get_libdir)/libperl$(get_libname ?.*)` ; do
latest="${x}"
done
@@ -321,4 +308,3 @@ pkg_postinst() {
fi
fi
}
-