summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-10-04 20:17:56 +0000
committerTorsten Veller <tove@gentoo.org>2008-10-04 20:17:56 +0000
commit615dedda4fd1b3594f1a2cefabe4b51915b111f3 (patch)
tree13bbf77a4e4306844f945c8414d531640214dbc3 /sys-devel
parentBumpz (diff)
downloadperl-overlay-615dedda4fd1b3594f1a2cefabe4b51915b111f3.tar.gz
perl-overlay-615dedda4fd1b3594f1a2cefabe4b51915b111f3.tar.bz2
perl-overlay-615dedda4fd1b3594f1a2cefabe4b51915b111f3.zip
Remove dev-lang/perl cruft from src_install. Remove also 'dodoc Changes* Artistic Copying README Todo* AUTHORS' from libperl. It is still installed by dev-lang/perl.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/Manifest2
-rw-r--r--sys-devel/libperl/libperl-5.10.0.ebuild75
2 files changed, 1 insertions, 76 deletions
diff --git a/sys-devel/libperl/Manifest b/sys-devel/libperl/Manifest
index 3bcc9245f..d916cd70e 100644
--- a/sys-devel/libperl/Manifest
+++ b/sys-devel/libperl/Manifest
@@ -1,4 +1,4 @@
AUX libperl-5.10.0-create-libperl-soname.patch 401 RMD160 85f971825840d060a03c41b3efab738db8209e6c SHA1 cfca756f70f85908bd108f849d9360a7ea363676 SHA256 118efc0c6c5e42188626e63660e84fb5ec83ab65596507c3454651abfeba5e6d
AUX libperl-noksh.patch 611 RMD160 6ddb9e7140c60e05042c3c488c97399a86f965fc SHA1 61bf5bb0955bd04a758d1381fa4260ed9fdbb1d1 SHA256 0861f7f54c184e99a0ffeebeab9420d969d2002f921bc3fb14841a1e24be1f5e
DIST perl-5.10.0.tar.gz 15595020 RMD160 c6614fc99a162790a703f91085b24a60af903ba2 SHA1 adf73606dd5248af7ccdd735bcaa0e628ea75b3c SHA256 94464a0d374fa63226eee56e0bb3d35564f9d8391a1a8d9f0055805ec25f3b2e
-EBUILD libperl-5.10.0.ebuild 11950 RMD160 3ccad2afd63168094c3c3f89693d60580254e4db SHA1 7dcef6f4ec337f7923e8f5c84b292cac39e6d22d SHA256 b56fff582d47a2eab4d39ffbe9b228c861302a846c60b0174dee3eef6e6d1519
+EBUILD libperl-5.10.0.ebuild 9593 RMD160 39ba551888a4301c656eb8fd9dc527510f7e1c4b SHA1 2f749819daaae09eaf2e725b23e67dbb2f1e7bb2 SHA256 01cca81feb77ccdb11323d9607548908ea1839144b58b1c2538a6b24e9df99a8
diff --git a/sys-devel/libperl/libperl-5.10.0.ebuild b/sys-devel/libperl/libperl-5.10.0.ebuild
index 4f4ee9505..4c859ee67 100644
--- a/sys-devel/libperl/libperl-5.10.0.ebuild
+++ b/sys-devel/libperl/libperl-5.10.0.ebuild
@@ -272,85 +272,10 @@ src_compile() {
}
src_install() {
-
export LC_ALL="C"
- if [ "${PN}" = "libperl" ]
- then
dolib.so ${WORKDIR}/${LIBPERL}
dosym ${LIBPERL} /usr/$(get_libdir)/libperl$(get_libname ${PERLSLOT})
- else
- # Need to do this, else apps do not link to dynamic version of
- # the library ...
- local coredir="/usr/$(get_libdir)/perl5/${PV}/${myarch}${mythreading}/CORE"
- dodir ${coredir}
- dosym ../../../../../$(get_libdir)/${LIBPERL} ${coredir}/${LIBPERL}
- dosym ../../../../../$(get_libdir)/${LIBPERL} ${coredir}/libperl$(get_libname ${PERLSLOT})
- dosym ../../../../../$(get_libdir)/${LIBPERL} ${coredir}/libperl$(get_libname)
-
- # Fix for "stupid" modules and programs
- dodir /usr/$(get_libdir)/perl5/site_perl/${PV}/${myarch}${mythreading}
-
- make DESTDIR="${D}" \
- INSTALLMAN1DIR="${D}/usr/share/man/man1" \
- INSTALLMAN3DIR="${D}/usr/share/man/man3" \
- install || die "Unable to make install"
-
- cp -f utils/h2ph utils/h2ph_patched
-
- LD_LIBRARY_PATH=. ./perl -Ilib utils/h2ph_patched \
- -a -d ${D}/usr/$(get_libdir)/perl5/${PV}/${myarch}${mythreading} <<EOF
-asm/termios.h
-syscall.h
-syslimits.h
-syslog.h
-sys/ioctl.h
-sys/socket.h
-sys/time.h
-wait.h
-EOF
-
- # This is to fix a missing c flag for backwards compat
- for i in `find ${D}/usr/$(get_libdir)/perl5 -iname "Config.pm"`;do
- sed -e "s:ccflags=':ccflags='-DPERL5 :" \
- -e "s:cppflags=':cppflags='-DPERL5 :" \
- ${i} > ${i}.new &&\
- mv ${i}.new ${i} || die "Sed failed"
- done
-
- # A poor fix for the miniperl issues
- dosed 's:./miniperl:/usr/bin/perl:' /usr/$(get_libdir)/perl5/${PV}/ExtUtils/xsubpp
- fperms 0444 /usr/$(get_libdir)/perl5/${PV}/ExtUtils/xsubpp
- dosed 's:./miniperl:/usr/bin/perl:' /usr/bin/xsubpp
- fperms 0755 /usr/bin/xsubpp
-
- ./perl installman \
- --man1dir="${D}/usr/share/man/man1" --man1ext='1' \
- --man3dir="${D}/usr/share/man/man3" --man3ext='3'
-
- # This removes ${D} from Config.pm and .packlist
- for i in `find ${D} -iname "Config.pm"` `find ${D} -iname ".packlist"`;do
- einfo "Removing ${D} from ${i}..."
- sed -e "s:${D}::" ${i} > ${i}.new &&\
- mv ${i}.new ${i} || die "Sed failed"
- done
- fi
-
- dodoc Changes* Artistic Copying README Todo* AUTHORS
-
- if [ "${PN}" = "perl" ]
- then
- # HTML Documentation
- # We expect errors, warnings, and such with the following.
-
- dodir /usr/share/doc/${PF}/html
- ./perl installhtml \
- --podroot='.' \
- --podpath='lib:ext:pod:vms' \
- --recurse \
- --htmldir="${D}/usr/share/doc/${PF}/html" \
- --libpods='perlfunc:perlguts:perlvar:perlrun:perlop'
- fi
}
pkg_postinst() {