summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Catalyst-Plugin-Authentication/Catalyst-Plugin-Authentication-0.10012.ebuild')
-rw-r--r--dev-perl/Catalyst-Plugin-Authentication/Catalyst-Plugin-Authentication-0.10012.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Catalyst-Plugin-Authentication/Catalyst-Plugin-Authentication-0.10012.ebuild b/dev-perl/Catalyst-Plugin-Authentication/Catalyst-Plugin-Authentication-0.10012.ebuild
new file mode 100644
index 000000000..e525a3e0f
--- /dev/null
+++ b/dev-perl/Catalyst-Plugin-Authentication/Catalyst-Plugin-Authentication-0.10012.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=2
+MODULE_AUTHOR=BOBTFISH
+inherit perl-module
+
+DESCRIPTION="Infrastructure plugin for the Catalyst authentication framework"
+
+IUSE="test"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Catalyst-Runtime
+ dev-perl/Class-Inspector
+ >=dev-perl/Catalyst-Plugin-Session-0.10
+ dev-perl/MRO-Compat
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Exception
+ dev-perl/Test-MockObject
+ )
+"
+SRC_TEST="do"