summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.95.ebuild')
-rw-r--r--dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.95.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.95.ebuild b/dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.95.ebuild
new file mode 100644
index 000000000..7de722fba
--- /dev/null
+++ b/dev-perl/HTML-Template-Pro/HTML-Template-Pro-0.95.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+MODULE_AUTHOR=VIY
+inherit perl-module
+
+DESCRIPTION="Perl/XS module to use HTML Templates from CGI scripts"
+
+SLOT="0"
+LICENSE="|| ( Artistic LGPL-2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="pcre test"
+
+RDEPEND="
+ pcre? ( dev-libs/libpcre )
+ virtual/perl-File-Spec
+ dev-perl/JSON
+"
+DEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Simple )"
+
+SRC_TEST="do"
+
+src_configure() {
+ if use pcre ; then
+ myconf="PCRE=1"
+ else
+ myconf="PCRE=0"
+ fi
+ perl-module_src_configure
+}