summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Strict/Test-Strict-0.220.0.ebuild')
-rw-r--r--dev-perl/Test-Strict/Test-Strict-0.220.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Test-Strict/Test-Strict-0.220.0.ebuild b/dev-perl/Test-Strict/Test-Strict-0.220.0.ebuild
new file mode 100644
index 000000000..515086a57
--- /dev/null
+++ b/dev-perl/Test-Strict/Test-Strict-0.220.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=5
+MODULE_AUTHOR=SZABGAB
+MODULE_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION='Check syntax, presence of use strict; and test coverage'
+LICENSE=" || ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+perl_meta_configure() {
+ # ExtUtils::MakeMaker
+ echo virtual/perl-ExtUtils-MakeMaker
+}
+perl_meta_build() {
+ # ExtUtils::MakeMaker
+ echo virtual/perl-ExtUtils-MakeMaker
+}
+perl_meta_runtime() {
+ # Devel::Cover 0.43 ( 0.430.0 )
+ echo \>=dev-perl/Devel-Cover-0.430.0
+ # File::Find 0.01 ( 0.10.0 )
+ # echo \>=dev-lang/perl-0.10.0
+ # File::Spec 0.01 ( 0.10.0 )
+ echo \>=virtual/perl-File-Spec-0.10.0
+ # File::Temp 0.01 ( 0.10.0 )
+ echo \>=virtual/perl-File-Temp-0.10.0
+ # FindBin 0.01 ( 0.10.0 )
+ # echo \>=dev-lang/perl-0.10.0
+ # Test::Builder 0.01 ( 0.10.0 )
+ echo \>=virtual/perl-Test-Simple-0.10.0
+ # Test::Simple 0.47 ( 0.470.0 )
+ echo \>=virtual/perl-Test-Simple-0.47
+}
+DEPEND="
+ $(perl_meta_configure)
+ $(perl_meta_build)
+ $(perl_meta_runtime)
+"
+RDEPEND="
+ $(perl_meta_runtime)
+"
+SRC_TEST="do"