summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nikto/ChangeLog8
-rw-r--r--net-analyzer/nikto/files/nikto.conf.patch11
-rw-r--r--net-analyzer/nikto/nikto-2.1.1.ebuild (renamed from net-analyzer/nikto/nikto-2.1.0.ebuild)27
3 files changed, 39 insertions, 7 deletions
diff --git a/net-analyzer/nikto/ChangeLog b/net-analyzer/nikto/ChangeLog
index 06b4f9cd9..fc244b2af 100644
--- a/net-analyzer/nikto/ChangeLog
+++ b/net-analyzer/nikto/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-analyzer/nikto
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/ChangeLog,v 1.24 2009/03/20 16:02:06 dertobi123 Exp $
+*nikto-2.1.1 (20 Feb 2010)
+
+ 20 Feb 2010; David Abbott <dabbott@gentoo.org> -nikto-2.1.0.ebuild,
+ +nikto-2.1.1.ebuild, files/nikto.conf, +files/nikto.conf.patch:
+ updated to 2.1.1 numerous bug fixes bug 292312 thanks Marcin Miroslaw
+
*nikto-2.1.0 (19 Nov 2009)
19 Nov 2009; David Abbott <dabbott@gentoo.org> +nikto-2.1.0.ebuild,
diff --git a/net-analyzer/nikto/files/nikto.conf.patch b/net-analyzer/nikto/files/nikto.conf.patch
new file mode 100644
index 000000000..9b0c4d001
--- /dev/null
+++ b/net-analyzer/nikto/files/nikto.conf.patch
@@ -0,0 +1,11 @@
+--- nikto.pl.orig 2010-02-02 14:28:54.000000000 -0500
++++ nikto.pl 2010-02-18 16:20:21.000000000 -0500
+@@ -49,7 +49,7 @@
+ $NIKTO{'DIV'} = "-" x 75;
+ $NIKTO{'version'} = "2.1.1";
+ $NIKTO{'name'} = "Nikto";
+-$NIKTO{'configfile'} = "/etc/nikto.conf"; ### Change this line if your setup is having trouble finding it
++$NIKTO{'configfile'} = "/etc/nikto/nikto.conf"; ### Change this line if your setup is having trouble finding it
+
+ # read the --config option
+ {
diff --git a/net-analyzer/nikto/nikto-2.1.0.ebuild b/net-analyzer/nikto/nikto-2.1.1.ebuild
index 47a3dc38a..010c72e05 100644
--- a/net-analyzer/nikto/nikto-2.1.0.ebuild
+++ b/net-analyzer/nikto/nikto-2.1.1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/nikto-2.03.ebuild,v 1.1 2009/03/20 16:02:06 dertobi123 Exp $
+# $Header: $
EAPI=2
+inherit eutils
+
DESCRIPTION="Web Server vulnerability scanner."
HOMEPAGE="http://www.cirt.net/code/nikto.shtml"
SRC_URI="http://www.cirt.net/source/nikto/${P}.tar.bz2"
@@ -18,11 +20,20 @@ RDEPEND="dev-lang/perl
ssl? (
dev-libs/openssl
dev-perl/Net-SSLeay
- )"
+ )
+ >=net-libs/libwhisker-2.5"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ rm docs/._* || die "removing osx files failed"
+ epatch "${FILESDIR}"/${PN}.conf.patch || die "patch failed"
+}
src_install() {
- insinto /etc
+ dodir /etc/nikto || die "dodir failed"
+ insinto /etc/nikto
doins "${FILESDIR}/nikto.conf" || die "doins failed"
dobin nikto.pl || die "dobin failed"
@@ -30,7 +41,11 @@ src_install() {
dodir /usr/share/nikto || die "dodir failed"
insinto /usr/share/nikto
- doins -r plugins templates docs || die "doins failed"
+ doins docs/nikto.dtd || die "dodoc failed"
+
+ dodir /var/lib/nikto || die "dodir failed"
+ insinto /var/lib/nikto
+ doins -r templates plugins || die "doins failed"
dodoc docs/*.txt || die "dodoc failed"
dohtml docs/nikto_manual.html || die "dohtml failed"
@@ -38,5 +53,5 @@ src_install() {
}
pkg_postinst() {
- elog 'Default configuration file is "/etc/nikto.conf"'
+ elog 'Default configuration file is "/etc/nikto/nikto.conf"'
}