summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-03-19 00:41:21 +0000
committerZac Medico <zmedico@gentoo.org>2010-03-19 00:41:21 +0000
commitb5b412d68a96c16c78b0e5d0a6d31ef592ba5b15 (patch)
tree2149fdf4efffad1ab4855ecf77e79fe0f5067dcc /bin/repoman
parentBug #309907 - Fix update_config_files() to handle package.license. (diff)
downloadportage-idfetch-b5b412d68a96c16c78b0e5d0a6d31ef592ba5b15.tar.gz
portage-idfetch-b5b412d68a96c16c78b0e5d0a6d31ef592ba5b15.tar.bz2
portage-idfetch-b5b412d68a96c16c78b0e5d0a6d31ef592ba5b15.zip
Bug #310135 - Skip the changelog.ebuildadded for all distributed SCMs.
svn path=/main/trunk/; revision=15833
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman16
1 files changed, 10 insertions, 6 deletions
diff --git a/bin/repoman b/bin/repoman
index 26ca6e36..c96b1840 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -497,6 +497,12 @@ elif os.path.isdir(os.path.join(portdir_overlay, ".bzr")):
elif os.path.isdir(os.path.join(portdir_overlay, ".hg")):
vcs = "hg"
+# Note: We don't use ChangeLogs in distributed SCMs.
+# It will be generated on server side from scm log,
+# before package moves to the rsync server.
+# This is needed because we try to avoid merge collisions.
+check_changelog = vcs in ('CVS', 'SVN')
+
vcs_local_opts = repoman_settings.get("REPOMAN_VCS_LOCAL_OPTS", "").split()
vcs_global_opts = repoman_settings.get("REPOMAN_VCS_GLOBAL_OPTS")
if vcs_global_opts is None:
@@ -1275,11 +1281,8 @@ for x in scanlist:
relative_path + ': %s' % error_match.group(1))
del mydigests
- # Note: We don't use ChangeLogs in distributed SCMs.
- # It will be generated on server side from scm log,
- # before package moves to the rsync server.
- # This is needed because we try to avoid merge collisions.
- if vcs not in ("git", "hg") and "ChangeLog" not in checkdirlist:
+
+ if check_changelog and "ChangeLog" not in checkdirlist:
stats["changelog.missing"]+=1
fails["changelog.missing"].append(x+"/ChangeLog")
@@ -1337,7 +1340,8 @@ for x in scanlist:
if repolevel < 2:
ebuild_path = os.path.join(catdir, ebuild_path)
ebuild_path = os.path.join(".", ebuild_path)
- if not changelog_modified and ebuild_path in new_ebuilds:
+ if check_changelog and not changelog_modified \
+ and ebuild_path in new_ebuilds:
stats['changelog.ebuildadded'] += 1
fails['changelog.ebuildadded'].append(relative_path)