summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-02-22 01:14:08 +0000
committerZac Medico <zmedico@gentoo.org>2010-02-22 01:14:08 +0000
commitda4d877173458a35778c9db93e0a8762c5cb1a6e (patch)
treec0a32a6b22787f5cb0bc3cfdac217ea139b83234 /bin/repoman
parentMove the portage.FetchlistDict class to the portage.dbapi.porttree module. (diff)
downloadportage-idfetch-da4d877173458a35778c9db93e0a8762c5cb1a6e.tar.gz
portage-idfetch-da4d877173458a35778c9db93e0a8762c5cb1a6e.tar.bz2
portage-idfetch-da4d877173458a35778c9db93e0a8762c5cb1a6e.zip
Bug #299095 - Add a deprecation warning for check_license calls with EAPI >= 3
since it is superceded by LICENSE masking. svn path=/main/trunk/; revision=15418
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman2
1 files changed, 2 insertions, 0 deletions
diff --git a/bin/repoman b/bin/repoman
index a67fae8d..ba9feabc 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -288,6 +288,7 @@ qahelp={
"DESCRIPTION.missing":"Ebuilds that have a missing or empty DESCRIPTION variable",
"DESCRIPTION.toolong":"DESCRIPTION is over %d characters" % max_desc_len,
"EAPI.definition":"EAPI is defined after an inherit call (must be defined before)",
+ "EAPI.deprecated":"Ebuilds that use features that are deprecated in the current EAPI",
"EAPI.incompatible":"Ebuilds that use features that are only available with a different EAPI",
"EAPI.unsupported":"Ebuilds that have an unsupported EAPI version (you must upgrade portage)",
"SLOT.invalid":"Ebuilds that have a missing or invalid SLOT variable value",
@@ -368,6 +369,7 @@ qawarnings = set((
"DEPEND.badmaskedindev","RDEPEND.badmaskedindev","PDEPEND.badmaskedindev",
"DEPEND.badtilde", "RDEPEND.badtilde", "PDEPEND.badtilde",
"DESCRIPTION.toolong",
+"EAPI.deprecated",
"HOMEPAGE.virtual",
"LICENSE.virtual",
"KEYWORDS.dropped",