summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman11
1 files changed, 5 insertions, 6 deletions
diff --git a/bin/repoman b/bin/repoman
index 193cc1e8..95a44f0f 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1157,12 +1157,11 @@ for x in scanlist:
if l[-7:] == ".ebuild":
eadded.append(os.path.basename(l[:-7]))
except IOError:
- if options.mode == 'commit':
- if vcs == "cvs":
- stats["CVS/Entries.IO_error"] += 1
- fails["CVS/Entries.IO_error"].append(checkdir+"/CVS/Entries")
- else:
- raise
+ if vcs == "cvs":
+ stats["CVS/Entries.IO_error"] += 1
+ fails["CVS/Entries.IO_error"].append(checkdir+"/CVS/Entries")
+ else:
+ raise
continue
mf = Manifest(checkdir, repoman_settings["DISTDIR"])