summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-02-28 04:28:21 +0000
committerZac Medico <zmedico@gentoo.org>2010-02-28 04:28:21 +0000
commit3c44d8752ddb2aa4ae194de185a94aac131acba4 (patch)
tree65416774a404c1ffbbbfcc131168116865de04e2
parentMove the MtimeDB class to portage.util.mtimedb and deprecate the commit_mtimedb (diff)
downloadportage-multirepo-3c44d8752ddb2aa4ae194de185a94aac131acba4.tar.gz
portage-multirepo-3c44d8752ddb2aa4ae194de185a94aac131acba4.tar.bz2
portage-multirepo-3c44d8752ddb2aa4ae194de185a94aac131acba4.zip
Move deprecated_profile_check to portage.package.ebuild submodule.
svn path=/main/trunk/; revision=15491
-rw-r--r--pym/portage/__init__.py32
-rw-r--r--pym/portage/package/ebuild/deprecated_profile_check.py43
2 files changed, 45 insertions, 30 deletions
diff --git a/pym/portage/__init__.py b/pym/portage/__init__.py
index 5f1b05e7..ccfacebc 100644
--- a/pym/portage/__init__.py
+++ b/pym/portage/__init__.py
@@ -107,6 +107,8 @@ try:
'doebuild_environment,spawn,spawnebuild',
'portage.package.ebuild.config:autouse,best_from_dict,' + \
'check_config_instance,config',
+ 'portage.package.ebuild.deprecated_profile_check:' + \
+ 'deprecated_profile_check',
'portage.package.ebuild.digestcheck:digestcheck',
'portage.package.ebuild.digestgen:digestgen',
'portage.package.ebuild.fetch:fetch',
@@ -507,36 +509,6 @@ auxdbkeys = (
)
auxdbkeylen=len(auxdbkeys)
-def deprecated_profile_check(settings=None):
- config_root = "/"
- if settings is not None:
- config_root = settings["PORTAGE_CONFIGROOT"]
- deprecated_profile_file = os.path.join(config_root,
- DEPRECATED_PROFILE_FILE)
- if not os.access(deprecated_profile_file, os.R_OK):
- return False
- dcontent = codecs.open(_unicode_encode(deprecated_profile_file,
- encoding=_encodings['fs'], errors='strict'),
- mode='r', encoding=_encodings['content'], errors='replace').readlines()
- writemsg(colorize("BAD", _("\n!!! Your current profile is "
- "deprecated and not supported anymore.")) + "\n", noiselevel=-1)
- writemsg(colorize("BAD", _("!!! Use eselect profile to update your "
- "profile.")) + "\n", noiselevel=-1)
- if not dcontent:
- writemsg(colorize("BAD", _("!!! Please refer to the "
- "Gentoo Upgrading Guide.")) + "\n", noiselevel=-1)
- return True
- newprofile = dcontent[0]
- writemsg(colorize("BAD", _("!!! Please upgrade to the "
- "following profile if possible:")) + "\n", noiselevel=-1)
- writemsg(8*" " + colorize("GOOD", newprofile) + "\n", noiselevel=-1)
- if len(dcontent) > 1:
- writemsg(_("To upgrade do the following steps:\n"), noiselevel=-1)
- for myline in dcontent[1:]:
- writemsg(myline, noiselevel=-1)
- writemsg("\n\n", noiselevel=-1)
- return True
-
def portageexit():
if secpass > 1 and os.environ.get("SANDBOX_ON") != "1":
close_portdbapi_caches()
diff --git a/pym/portage/package/ebuild/deprecated_profile_check.py b/pym/portage/package/ebuild/deprecated_profile_check.py
new file mode 100644
index 00000000..b3f99f5f
--- /dev/null
+++ b/pym/portage/package/ebuild/deprecated_profile_check.py
@@ -0,0 +1,43 @@
+# Copyright 2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+__all__ = ['deprecated_profile_check']
+
+import codecs
+
+from portage import os, _encodings, _unicode_encode
+from portage.const import DEPRECATED_PROFILE_FILE
+from portage.localization import _
+from portage.output import colorize
+from portage.util import writemsg
+
+def deprecated_profile_check(settings=None):
+ config_root = "/"
+ if settings is not None:
+ config_root = settings["PORTAGE_CONFIGROOT"]
+ deprecated_profile_file = os.path.join(config_root,
+ DEPRECATED_PROFILE_FILE)
+ if not os.access(deprecated_profile_file, os.R_OK):
+ return False
+ dcontent = codecs.open(_unicode_encode(deprecated_profile_file,
+ encoding=_encodings['fs'], errors='strict'),
+ mode='r', encoding=_encodings['content'], errors='replace').readlines()
+ writemsg(colorize("BAD", _("\n!!! Your current profile is "
+ "deprecated and not supported anymore.")) + "\n", noiselevel=-1)
+ writemsg(colorize("BAD", _("!!! Use eselect profile to update your "
+ "profile.")) + "\n", noiselevel=-1)
+ if not dcontent:
+ writemsg(colorize("BAD", _("!!! Please refer to the "
+ "Gentoo Upgrading Guide.")) + "\n", noiselevel=-1)
+ return True
+ newprofile = dcontent[0]
+ writemsg(colorize("BAD", _("!!! Please upgrade to the "
+ "following profile if possible:")) + "\n", noiselevel=-1)
+ writemsg(8*" " + colorize("GOOD", newprofile) + "\n", noiselevel=-1)
+ if len(dcontent) > 1:
+ writemsg(_("To upgrade do the following steps:\n"), noiselevel=-1)
+ for myline in dcontent[1:]:
+ writemsg(myline, noiselevel=-1)
+ writemsg("\n\n", noiselevel=-1)
+ return True