summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-06 04:52:15 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-06 04:52:15 +0000
commit2c9a7a40f4f416200b6a00d0df6c7f1a8a117882 (patch)
tree01a2c7fe2be751dcf856cbdd14adb77f92953be6 /bin/ebuild.sh
parentif user has FEATURES=noauto then dont check lame .installed file (diff)
downloadportage-multirepo-2c9a7a40f4f416200b6a00d0df6c7f1a8a117882.tar.gz
portage-multirepo-2c9a7a40f4f416200b6a00d0df6c7f1a8a117882.tar.bz2
portage-multirepo-2c9a7a40f4f416200b6a00d0df6c7f1a8a117882.zip
make .compiled warning the same helpful format as .installed
svn path=/main/trunk/; revision=4412
Diffstat (limited to 'bin/ebuild.sh')
-rwxr-xr-xbin/ebuild.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index d2a40c35..abfc898c 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -915,9 +915,9 @@ dyn_compile() {
fi
cp "${EBUILD}" "build-info/${PF}.ebuild"
- if [ "${PORTAGE_BUILDDIR}/.compiled" -nt "${WORKDIR}" ]; then
- vecho ">>> It appears that ${PN} is already compiled; skipping."
- vecho ">>> (clean to force compilation)"
+ if [[ ${PORTAGE_BUILDDIR}/.compiled -nt ${WORKDIR} ]] ; then
+ vecho ">>> It appears that '${PF}' is already compiled; skipping."
+ vecho ">>> Remove '${PORTAGE_BUILDDIR}/.compiled' to force install."
trap SIGINT SIGQUIT
[ "$(type -t post_src_compile)" == "function" ] && post_src_compile
return