summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-01-12 08:09:20 +0000
committerZac Medico <zmedico@gentoo.org>2009-01-12 08:09:20 +0000
commit0b75f0cfbdab366055a1be368f9db46397e44dd3 (patch)
tree5969d86970dc5bae966dbdf8a746fc9822a4034e /bin/repoman
parentSpecify that metadata variable values should only contain ASCII as per GLEP 31. (diff)
downloadportage-multirepo-0b75f0cfbdab366055a1be368f9db46397e44dd3.tar.gz
portage-multirepo-0b75f0cfbdab366055a1be368f9db46397e44dd3.tar.bz2
portage-multirepo-0b75f0cfbdab366055a1be368f9db46397e44dd3.zip
Handle tree conflicts in svn status output, new in subversion 1.6. Thanks to
Arfrever Frehtes Taifersar Arahesis for reporting. (trunk r12368) svn path=/main/branches/2.1.6/; revision=12439
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman3
1 files changed, 3 insertions, 0 deletions
diff --git a/bin/repoman b/bin/repoman
index 1e1bc229..6e8b3848 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -910,6 +910,9 @@ for x in scanlist:
if vcs == "svn":
if l[:1] == "?":
continue
+ if l[:7] == ' >':
+ # tree conflict, new in subversion 1.6
+ continue
l = l.split()[-1]
if l[-7:] == ".ebuild":
eadded.append(os.path.basename(l[:-7]))