summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-03-27 04:25:35 +0000
committerZac Medico <zmedico@gentoo.org>2009-03-27 04:25:35 +0000
commit269e5f3bc8e548a41294bfc2ec4c995eebf2f995 (patch)
treeff8b125a6af6ac6966b6b672a77375de62e941e8 /bin
parentIf a package is masked by EAPI then don't show any other masking reasons. (diff)
downloadportage-multirepo-269e5f3bc8e548a41294bfc2ec4c995eebf2f995.tar.gz
portage-multirepo-269e5f3bc8e548a41294bfc2ec4c995eebf2f995.tar.bz2
portage-multirepo-269e5f3bc8e548a41294bfc2ec4c995eebf2f995.zip
Add support for FEATURES=parse-eapi-glep-55. This feature is only intended for
experimental purposes and should not be enabled under normal circumstances. (trunk r13175) svn path=/main/branches/2.1.6/; revision=13205
Diffstat (limited to 'bin')
-rwxr-xr-xbin/ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/bin/ebuild b/bin/ebuild
index 55736dd3..8e1d4432 100755
--- a/bin/ebuild
+++ b/bin/ebuild
@@ -83,7 +83,14 @@ if portage.settings["NOCOLOR"] in ("yes","true") or not sys.stdout.isatty():
ebuild = pargs.pop(0)
-if not ebuild.endswith(".ebuild"):
+pf = None
+if 'parse-eapi-glep-55' in portage.settings.features:
+ pf, eapi = portage._split_ebuild_name_glep55(
+ os.path.basename(ebuild))
+elif ebuild.endswith(".ebuild"):
+ pf = os.path.basename(ebuild)[:-7]
+
+if pf is None:
portage.writemsg("'%s' does not end with '.ebuild'.\n" % \
(ebuild,), noiselevel=-1)
sys.exit(1)
@@ -120,8 +127,7 @@ if not os.path.exists(ebuild):
sys.exit(1)
ebuild_split = ebuild.split("/")
-del ebuild_split[-2]
-cpv = "/".join(ebuild_split[-2:])[:-7]
+cpv = "%s/%s" % (ebuild_split[-3], pf)
if not portage.catpkgsplit(cpv):
print "!!! %s does not follow correct package syntax." % (cpv)
@@ -158,8 +164,6 @@ def discard_digests(myebuild, mysettings, mydbapi):
portage._doebuild_manifest_exempt_depend += 1
pkgdir = os.path.dirname(myebuild)
fetchlist_dict = portage.FetchlistDict(pkgdir, mysettings, mydbapi)
- cat, pkg = pkgdir.split(os.sep)[-2:]
- cpv = cat + "/" + os.path.basename(myebuild)[:-7]
from portage.manifest import Manifest
mf = Manifest(pkgdir, mysettings["DISTDIR"],
fetchlist_dict=fetchlist_dict, manifest1_compat=False)