summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--man/ebuild.5285
-rw-r--r--man/make.conf.572
2 files changed, 184 insertions, 173 deletions
diff --git a/man/ebuild.5 b/man/ebuild.5
index 0ef77365..f61fed69 100644
--- a/man/ebuild.5
+++ b/man/ebuild.5
@@ -1,4 +1,4 @@
-.TH "EBUILD" "5" "Mar 2006" "Portage 2.1" "portage"
+.TH "EBUILD" "5" "Jan 2007" "Portage 2.1.2" "Portage"
.SH "NAME"
ebuild \- the internal format, variables, and functions in an ebuild script
.SH "DESCRIPTION"
@@ -8,14 +8,14 @@ program accepts a single ebuild script as an argument. This script
contains variables and commands that specify how to download, unpack,
patch, compile, install and merge a particular software package from
its original sources. In addition to all of this, the ebuild script
-can also contain pre/post install/remove commands, as required. All
+can also contain pre/post install/remove commands, as required. All
ebuild scripts are written in bash.
.SH "EXAMPLES"
Here's a simple example ebuild:
.DS
.nf
-# Copyright 1999\-2006 Gentoo Foundation
+# Copyright 1999\-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -52,42 +52,42 @@ src_install() {
.SH "VARIABLES"
.TP
.B MISC USAGE NOTES
-- All variables defined in \fBmake.conf\fR(5) are available for use in
+\- All variables defined in \fBmake.conf\fR(5) are available for use in
ebuilds (such as the PORTAGE* and PORTDIR* variables)
.br
-- When assigning values to variables in ebuilds, you \fBcannot have a
+\- When assigning values to variables in ebuilds, you \fBcannot have a
space\fR between the variable name and the equal sign.
.TP
.B P
This variable contains the package name without the ebuild revision.
This variable must NEVER be modified.
.br
-\fBxfree-4.2.1-r2.ebuild\fR --> \fB$P\fR=='\fIxfree-4.2.1\fR'
+\fBxfree\-4.2.1\-r2.ebuild\fR \-\-> \fB$P\fR=='\fIxfree\-4.2.1\fR'
.TP
.B PN
Contains the name of the script without the version number.
.br
-\fBxfree-4.2.1-r2.ebuild\fR --> \fB$PN\fR=='\fIxfree\fR'
+\fBxfree\-4.2.1\-r2.ebuild\fR \-\-> \fB$PN\fR=='\fIxfree\fR'
.TP
.B PV
Contains the version number without the revision.
.br
-\fBxfree-4.2.1-r2.ebuild\fR --> \fB$PV\fR=='\fI4.2.1\fR'
+\fBxfree\-4.2.1\-r2.ebuild\fR \-\-> \fB$PV\fR=='\fI4.2.1\fR'
.TP
.B PR
Contains the revision number or 'r0' if no revision number exists.
.br
-\fBxfree-4.2.1-r2.ebuild\fR --> \fB$PR\fR=='\fIr2\fR'
+\fBxfree\-4.2.1\-r2.ebuild\fR \-\-> \fB$PR\fR=='\fIr2\fR'
.TP
.B PVR
Contains the version number with the revision.
.br
-\fBxfree-4.2.1-r2.ebuild\fR --> \fB$PVR\fR=='\fI4.2.1-r2\fR'
+\fBxfree\-4.2.1\-r2.ebuild\fR \-\-> \fB$PVR\fR=='\fI4.2.1\-r2\fR'
.TP
.B PF
Contains the full package name \fI[PN]\-[PVR]\fR
.br
-\fBxfree-4.2.1-r2.ebuild\fR --> \fB$PF\fR=='\fIxfree-4.2.1-r2\fR'
+\fBxfree\-4.2.1\-r2.ebuild\fR \-\-> \fB$PF\fR=='\fIxfree\-4.2.1\-r2\fR'
.TP
.B CATEGORY
Contains the package category name.
@@ -96,7 +96,7 @@ Contains the package category name.
Contains all source files required for the package. This variable must
not be defined. It is autogenerated from the \fISRC_URI\fR variable.
.TP
-\fBWORKDIR\fR = \fI"${PORTAGE_TMPDIR}/portage/${PF}/work"\fR
+\fBWORKDIR\fR = \fI"${PORTAGE_TMPDIR}/portage/${CATEGORY}/${PF}/work"\fR
Contains the path to the package build root. Do not modify this variable.
.TP
\fBFILESDIR\fR = \fI"${PORTDIR}/${CATEGORY}/${PN}/files"\fR
@@ -109,18 +109,22 @@ is used by the functions \fIsrc_compile\fR and \fIsrc_install\fR. Both
are executed with \fIS\fR as the current directory. This variable may
be modified to match the extraction directory of a tarball for the package.
.TP
-\fBT\fR = \fI"${PORTAGE_TMPDIR}/portage/${PF}/temp"\fR
+\fBT\fR = \fI"${PORTAGE_TMPDIR}/portage/${CATEGORY}/${PF}/temp"\fR
Contains the path to a \fItemporary directory\fR. You may use this for
whatever you like.
.TP
-\fBD\fR = \fI"${PORTAGE_TMPDIR}/portage/${PF}/image"\fR
-Contains the path to the temporary \fIinstall directory\fR. Every write
-operation that does not involve the helper tools and functions (found below)
+\fBD\fR = \fI"${PORTAGE_TMPDIR}/portage/${CATEGORY}/${PF}/image"\fR
+Contains the path to the temporary \fIinstall directory\fR. Every write
+operation that does not involve the helper tools and functions (found below)
should be prefixed with ${D}. Do not modify this variable.
.TP
+.B PORTAGE_LOG_FILE
+Contains the path of the build log. If \fBPORT_LOGDIR\fR variable is unset then
+\fBPORTAGE_LOG_FILE\fR=\fB"${T}/build.log"\fR.
+.TP
\fBROOT\fR = \fI"/"\fR
-Contains the path that portage should use as the root of the live filesystem.
-When packages wish to make changes to the live filesystem, it should do so in
+Contains the path that portage should use as the root of the live filesystem.
+When packages wish to make changes to the live filesystem, they should do so in
the tree prefixed by ${ROOT}. Do not modify this variable.
.TP
\fBDESCRIPTION\fR = \fI"A happy little package"\fR
@@ -128,14 +132,14 @@ Should contain a short description of the package.
.TP
\fBSRC_URI\fR = \fI"http://happy.com/little/${P}.tar.gz"\fR
Contains a list of URI's for the required source files. It can contain
-multiple URI's for a single source file. The list is processed in order
+multiple URI's for a single source file. The list is processed in order
if the file was not found on any of the \fIGENTOO_MIRRORS\fR.
.TP
\fBHOMEPAGE\fR = \fI"http://happy.com/"\fR
Should contain a list of URL's for the sources main sites and other further
package dependent information.
.TP
-\fBKEYWORDS\fR = \fI[-~][x86,ppc,sparc,mips,alpha,arm,hppa]\fR
+\fBKEYWORDS\fR = \fI[\-~][x86,ppc,sparc,mips,alpha,arm,hppa]\fR
Should contain appropriate list of arches that the ebuild is know to
work/not work. By default if you do not know if an ebuild runs under
a particular arch simply omit that KEYWORD. If the ebuild will not
@@ -147,9 +151,9 @@ line, or in \fBmake.conf\fR(5)) For an authoritative list please review
/usr/portage/profiles/arch.list. Please keep this list in alphabetical order.
.TP
\fBSLOT\fR
-This sets the SLOT for packages that may need to have multiple versions
-co\-exist. By default you should set \fBSLOT\fR="0". If you are unsure, then
-do not fiddle with this until you seek some guidance from some guru. This
+This sets the SLOT for packages that may need to have multiple versions
+co\-exist. By default you should set \fBSLOT\fR="0". If you are unsure, then
+do not fiddle with this until you seek some guidance from some guru. This
value should \fINEVER\fR be left undefined.
.TP
\fBLICENSE\fR
@@ -178,9 +182,9 @@ been emerged, then the latest version available is matched.
The base atom is just a full category/packagename. Hence, these are base atoms:
.nf
-.I sys-apps/sed
-.I sys-libs/zlib
-.I net-misc/dhcp
+.I sys\-apps/sed
+.I sys\-libs/zlib
+.I net\-misc/dhcp
.fi
.TP
.B Atom Versions
@@ -189,16 +193,16 @@ acceptable. Note that versions must be combined with a prefix (see below). Hen
you may add a version number as a postfix to the base:
.nf
-sys-apps/sed\fI-4.0.5\fR
-sys-libs/zlib\fI-1.1.4-r1\fR
-net-misc/dhcp\fI-3.0_p2\fR
+sys\-apps/sed\fI\-4.0.5\fR
+sys\-libs/zlib\fI\-1.1.4\-r1\fR
+net\-misc/dhcp\fI\-3.0_p2\fR
.fi
-Versions are normally made up of two or three numbers separated by periods, such
-as 1.2 or 4.5.2. This string may be followed by a character such as 1.2a or 4.5.2z.
-Note that this letter is \fBnot\fR meant to indicate alpha, beta, etc... status.
-For that, use the optional suffix; either _alpha, _beta, _pre (pre-release), _rc
-(release candidate), or _p (patch). This means for the 3rd pre-release of a package,
+Versions are normally made up of two or three numbers separated by periods, such
+as 1.2 or 4.5.2. This string may be followed by a character such as 1.2a or 4.5.2z.
+Note that this letter is \fBnot\fR meant to indicate alpha, beta, etc... status.
+For that, use the optional suffix; either _alpha, _beta, _pre (pre\-release), _rc
+(release candidate), or _p (patch). This means for the 3rd pre\-release of a package,
you would use something like 1.2_pre3.
.TP
.B Atom Prefix Operators [> >= = <= <]
@@ -206,11 +210,11 @@ Sometimes you want to be able to depend on general versions rather than specifyi
exact versions all the time. Hence we provide standard boolean operators:
.nf
-\fI>\fRmedia-libs/libgd-1.6
-\fI>=\fRmedia-libs/libgd-1.6
-\fI=\fRmedia-libs/libgd-1.6
-\fI<=\fRmedia-libs/libgd-1.6
-\fI<\fRmedia-libs/libgd-1.6
+\fI>\fRmedia\-libs/libgd\-1.6
+\fI>=\fRmedia\-libs/libgd\-1.6
+\fI=\fRmedia\-libs/libgd\-1.6
+\fI<=\fRmedia\-libs/libgd\-1.6
+\fI<\fRmedia\-libs/libgd\-1.6
.fi
.TP
.B Extended Atom Prefixes [!~] and Postfixes [*]
@@ -220,20 +224,20 @@ be combined in any way with the atom classes defined above. Here are some commo
examples you may find in the portage tree:
.nf
-\fI!\fRapp-text/dos2unix
-=dev-libs/glib-2\fI*\fR
-\fI!\fR=net-fs/samba-2\fI*\fR
-\fI~\fRnet-libs/libnet-1.0.2a
+\fI!\fRapp\-text/dos2unix
+=dev\-libs/glib\-2\fI*\fR
+\fI!\fR=net\-fs/samba\-2\fI*\fR
+\fI~\fRnet\-libs/libnet\-1.0.2a
.fi
\fI!\fR means block packages from being installed at the same time.
.br
-\fI*\fR means match any version of the package so long as the specified base
-is matched. So with a version of '2*', we can match '2.1', '2.2', '2.2.1',
+\fI*\fR means match any version of the package so long as the specified base
+is matched. So with a version of '2*', we can match '2.1', '2.2', '2.2.1',
etc... and not match version '1.0', '3.0', '4.1', etc...
.br
-\fI~\fR means match any revision of the base version specified. So in the
-above example, we would match versions '1.0.2a', '1.0.2a-r1', '1.0.2a-r2',
+\fI~\fR means match any revision of the base version specified. So in the
+above example, we would match versions '1.0.2a', '1.0.2a\-r1', '1.0.2a\-r2',
etc...
.RE
.TP
@@ -249,13 +253,13 @@ multiple Atoms and be nested to an infinite depth.
To include the jpeg library when the user has jpeg in \fBUSE\fR, simply use the
following syntax:
.br
-.B jpeg? ( media-libs/jpeg )
+.B jpeg? ( media\-libs/jpeg )
.TP
.B !usevar? ( Atom )
If you want to include a package only if the user does not have a certain option
in their \fBUSE\fR variable, then use the following syntax:
.br
-.B !nophysfs? ( dev-games/physfs )
+.B !nophysfs? ( dev\-games/physfs )
.br
This is often useful for those times when you want to want to add optional support
for a feature and have it enabled by default.
@@ -265,37 +269,37 @@ For functionality like the tertiary operator found in C you must use
two statements, one normal and one inverted. If a package uses
GTK2 or GTK1, but not both, then you can handle that like this:
.br
-.B gtk2? ( =x11-libs/gtk+-2* ) !gtk2? ( =x11-libs/gtk+-1* )
+.B gtk2? ( =x11\-libs/gtk+\-2* ) !gtk2? ( =x11\-libs/gtk+\-1* )
.br
That way the default is the superior GTK2 library.
.TP
.B || ( Atom Atom ... )
-When a package can work with a few different packages but a virtual is not
+When a package can work with a few different packages but a virtual is not
appropriate, this syntax can easily be used.
.nf
.B || (
-.B app-games/unreal-tournament
-.B app-games/unreal-tournament-goty
+.B app\-games/unreal\-tournament
+.B app\-games/unreal\-tournament\-goty
.B )
.fi
-Here we see that unreal-tournament has a normal version and it has a goty version.
-Since they provide the same base set of files, another package can use either.
+Here we see that unreal\-tournament has a normal version and it has a goty version.
+Since they provide the same base set of files, another package can use either.
Adding a virtual is inappropriate due to the small scope of it.
.br
Another good example is when a package can be built with multiple video
interfaces, but it can only ever have just one.
.nf
.B || (
-.B sdl? ( media-libs/libsdl )
-.B svga? ( media-libs/svgalib )
+.B sdl? ( media\-libs/libsdl )
+.B svga? ( media\-libs/svgalib )
.B opengl? ( virtual/opengl )
-.B ggi? ( media-libs/libggi )
+.B ggi? ( media\-libs/libggi )
.B virtual/x11
.B )
.fi
-Here only one of the packages will be chosen, and the order of preference is
-determined by the order in which they appear. So sdl has the best chance of being
-chosen, followed by svga, then opengl, then ggi, with a default of X if the user
+Here only one of the packages will be chosen, and the order of preference is
+determined by the order in which they appear. So sdl has the best chance of being
+chosen, followed by svga, then opengl, then ggi, with a default of X if the user
does not specify any of the previous choices.
.RE
@@ -321,7 +325,7 @@ This should be a space delimited list of portage features to restrict.
.TP
.I binchecks
Disable all QA checks for binaries. This should ONLY be used in packages
-for which binary checks make no sense (linux-headers and kernel-sources, for
+for which binary checks make no sense (linux\-headers and kernel\-sources, for
example, can safely be skipped since they have no binaries). If the binary
checks need to be skipped for other reasons (such as proprietary binaries),
see the \fBQA CONTROL VARIABLES\fR section for more specific exemptions.
@@ -351,7 +355,7 @@ Disables userpriv for specific packages.
.TP
\fBPROVIDE\fR = \fI"virtual/TARGET"\fR
This variable should only be used when a package provides a virtual target.
-For example, blackdown-jdk and sun-jdk provide \fIvirtual/jdk\fR. This
+For example, blackdown\-jdk and sun\-jdk provide \fIvirtual/jdk\fR. This
allows for packages to depend on \fIvirtual/jdk\fR rather than on blackdown
or sun specifically.
.SH "QA CONTROL VARIABLES"
@@ -361,7 +365,7 @@ Several QA variables are provided which allow an ebuild to manipulate some
of the QA checks performed by portage. Use of these variables in ebuilds
should be kept to an absolute minimum otherwise they defeat the purpose
of the QA checks, and their use is subject to agreement of the QA team.
-They are primarily intended for use by ebuilds that install closed-source
+They are primarily intended for use by ebuilds that install closed\-source
binary objects that cannot be altered.
.br
Note that objects that violate these rules may fail on some architectures.
@@ -371,7 +375,7 @@ This variable can be set to a list of file paths, relative to the image
directory, of files that contain text relocations that cannot be eliminated.
The paths may contain regular expressions.
.br
-This variable is intended to be used on closed-source binary objects that
+This variable is intended to be used on closed\-source binary objects that
cannot be altered.
.TP
\fBQA_EXECSTACK\fR
@@ -389,21 +393,21 @@ The paths may contain regular expressions.
.SH "PORTAGE DECLARATIONS"
.TP
.B inherit
-Inherit is portage's maintainance of extra classes of functions that are
-external to ebuilds and provided as inheritable capabilities and data. They
-define functions and set data types as drop-in replacements, expanded, and
-simplified routines for extremely common tasks to streamline the build
-process. Inherit may only be called once in an ebuild and it may \fBnever be
-wrapped within any conditionals\fR of any kind. Specification of the eclasses
-contains only their name and not the \fI.eclass\fR extention. Also note that
+Inherit is portage's maintenance of extra classes of functions that are
+external to ebuilds and provided as inheritable capabilities and data. They
+define functions and set data types as drop\-in replacements, expanded, and
+simplified routines for extremely common tasks to streamline the build
+process. Inherit may only be called once in an ebuild and it may \fBnever be
+wrapped within any conditionals\fR of any kind. Specification of the eclasses
+contains only their name and not the \fI.eclass\fR extension. Also note that
the inherit statement must come before other variable declarations.
.SH "FUNCTIONS"
.TP
.B pkg_nofetch
If you turn on \fIfetch\fR in \fBRESTRICT\fR, then this function will be
run when the files in \fBSRC_URI\fR cannot be found. Useful for
-displaying information to the user on *how* to obtain said files. All
-you have to do is output a message and let the function return. Do not
+displaying information to the user on *how* to obtain said files. All
+you have to do is output a message and let the function return. Do not
end the function with a call to \fBdie\fR.
.TP
.B pkg_setup
@@ -425,7 +429,7 @@ All necessary steps for configuration and compilation should be done in here.
Initial working directory of $S.
.TP
.B src_test
-Run all package specific test cases. The default is to run 'make check'
+Run all package specific test cases. The default is to run 'make check'
followed 'make test'.
.br
Initial working directory of $S.
@@ -459,20 +463,20 @@ Causes the current emerge process to be aborted. The final display will
include \fIreason\fR.
.TP
\fBuse\fR \fI<USE item>\fR
-If \fIUSE item\fR is in the \fBUSE\fR variable, the function will silently
-return 0 (aka shell true). If \fIUSE item\fR is not in the \fBUSE\fR
-variable, the function will silently return 1 (aka shell false). \fBusev\fR
+If \fIUSE item\fR is in the \fBUSE\fR variable, the function will silently
+return 0 (aka shell true). If \fIUSE item\fR is not in the \fBUSE\fR
+variable, the function will silently return 1 (aka shell false). \fBusev\fR
is a verbose version of \fBuse\fR.
.RS
.TP
.I Example:
.nf
if use gnome ; then
- guiconf="--enable-gui=gnome --with-x"
+ guiconf="\-\-enable\-gui=gnome \-\-with\-x"
elif use gtk ; then
- guiconf="--enable-gui=gtk --with-x"
+ guiconf="\-\-enable\-gui=gtk \-\-with\-x"
elif use X ; then
- guiconf="--enable-gui=athena --with-x"
+ guiconf="\-\-enable\-gui=athena \-\-with\-x"
else
# No gui version will be built
guiconf=""
@@ -481,13 +485,13 @@ fi
.RE
.TP
\fBuse_with\fR \fI<USE item>\fR \fI[configure name]\fR \fI[configure opt]\fR
-Useful for creating custom options to pass to a configure script. If \fIUSE
-item\fR is in the \fBUSE\fR variable and a \fIconfigure opt\fR is specified,
-then the string \fI--with-[configure name]=[configure opt]\fR will be echoed.
-If \fIconfigure opt\fR is not specified, then just \fI--with-[configure
-name]\fR will be echoed. If \fIUSE item\fR is not in the \fBUSE\fR variable,
-then the string \fI--without-[configure name]\fR will be echoed. If
-\fIconfigure name\fR is not specified, then \fIUSE item\fR will be used in
+Useful for creating custom options to pass to a configure script. If \fIUSE
+item\fR is in the \fBUSE\fR variable and a \fIconfigure opt\fR is specified,
+then the string \fI\-\-with\-[configure name]=[configure opt]\fR will be echoed.
+If \fIconfigure opt\fR is not specified, then just \fI\-\-with\-[configure
+name]\fR will be echoed. If \fIUSE item\fR is not in the \fBUSE\fR variable,
+then the string \fI\-\-without\-[configure name]\fR will be echoed. If
+\fIconfigure name\fR is not specified, then \fIUSE item\fR will be used in
its place.
.RS
.TP
@@ -495,40 +499,40 @@ its place.
.nf
USE="opengl"
myconf=$(use_with opengl)
-(myconf now has the value "--with-opengl")
+(myconf now has the value "\-\-with\-opengl")
USE="jpeg"
myconf=$(use_with jpeg libjpeg)
-(myconf now has the value "--with-libjpeg")
+(myconf now has the value "\-\-with\-libjpeg")
USE=""
myconf=$(use_with jpeg libjpeg)
-(myconf now has the value "--without-libjpeg")
+(myconf now has the value "\-\-without\-libjpeg")
USE="sdl"
-myconf=$(use_with sdl SDL all-plugins)
-(myconf now has the value "--with-SDL=all-plugins")
+myconf=$(use_with sdl SDL all\-plugins)
+(myconf now has the value "\-\-with\-SDL=all\-plugins")
.fi
.RE
.TP
\fBuse_enable\fR \fI<USE item>\fR \fI[configure name]\fR \fI[configure opt]\fR
-Same as \fBuse_with\fR above, except that the configure options are
-\fI--enable-\fR instead of \fI--with-\fR and \fI--disable-\fR instead of
-\fI--without-\fR.
+Same as \fBuse_with\fR above, except that the configure options are
+\fI\-\-enable\-\fR instead of \fI\-\-with\-\fR and \fI\-\-disable\-\fR instead of
+\fI\-\-without\-\fR.
.TP
\fBhas\fR \fI<item>\fR \fI<item list>\fR
If \fIitem\fR is in \fIitem list\fR, then \fIitem\fR is echoed and \fBhas\fR
returns 0. Otherwise, nothing is echoed and 1 is returned. As indicated with
-use, there is a non-echoing version \fBhasq\fR. Please use \fBhasq\fR in all
+use, there is a non\-echoing version \fBhasq\fR. Please use \fBhasq\fR in all
places where output is to be disregarded. Never use the output for calculation.
.br
The \fIitem list\fR is delimited by the \fIIFS\fR variable. This variable
has a default value of ' ', or a space. It is a \fBbash\fR(1) setting.
.TP
-\fBhas_version\fR \fI<category/package-version>\fR
-Check to see if \fIcategory/package-version\fR is installed on the system.
+\fBhas_version\fR \fI<category/package\-version>\fR
+Check to see if \fIcategory/package\-version\fR is installed on the system.
The parameter accepts all values that are acceptable in the \fBDEPEND\fR
-variable. The function returns 0 if \fIcategory/package-version\fR is
+variable. The function returns 0 if \fIcategory/package\-version\fR is
installed, 1 otherwise.
.TP
\fBbest_version\fR \fI<package name>\fR
@@ -538,9 +542,9 @@ currently installed.
.RS
.TP
.I Example:
-VERINS="$(best_version net-ftp/glftpd)"
+VERINS="$(best_version net\-ftp/glftpd)"
.br
-(VERINS now has the value "net-ftp/glftpd-1.27" if glftpd-1.27 is installed)
+(VERINS now has the value "net\-ftp/glftpd\-1.27" if glftpd\-1.27 is installed)
.RE
.SH "HELPER FUNCTIONS: OUTPUT"
.TP
@@ -549,8 +553,8 @@ Same as \fBelog\fR, but should be used when the message isn't important to the
user (like progress or status messages during the build process).
.TP
\fBelog\fR \fI"informative message"\fR
-If you need to display an message that you wish the user to read and take
-notice of, then use \fBelog\fR. It works just like \fBecho\fR(1), but
+If you need to display a message that you wish the user to read and take
+notice of, then use \fBelog\fR. It works just like \fBecho\fR(1), but
adds a little more to the output so as to catch the user's eye. The message
will also be logged by portage for later review.
.TP
@@ -561,13 +565,13 @@ Same as \fBeinfo\fR, but should be used when showing a warning to the user.
Same as \fBeinfo\fR, but should be used when showing an error to the user.
.TP
\fBebegin\fR \fI"helpful message"\fR
-Like \fBeinfo\fR, we output a \fIhelpful message\fR and then hint that the
-following operation may take some time to complete. Once the task is
+Like \fBeinfo\fR, we output a \fIhelpful message\fR and then hint that the
+following operation may take some time to complete. Once the task is
finished, you need to call \fBeend\fR.
.TP
\fBeend\fR \fI<status>\fR \fI["error message"]\fR
-Followup the \fBebegin\fR message with an appropriate "OK" or "!!" (for
-errors) marker. If \fIstatus\fR is non-zero, then the additional \fIerror
+Followup the \fBebegin\fR message with an appropriate "OK" or "!!" (for
+errors) marker. If \fIstatus\fR is non\-zero, then the additional \fIerror
message\fR is displayed.
.SH "HELPER FUNCTIONS: UNPACK"
.TP
@@ -580,31 +584,31 @@ directory. The function will append \fIsource\fR to the \fBDISTDIR\fR variable.
This is used as a replacement for configure. Performs:
.nf
configure \\
- --prefix=/usr \\
- --host=${CHOST} \\
- --mandir=/usr/share/man \\
- --infodir=/usr/share/info \\
- --datadir=/usr/share \\
- --sysconfdir=/etc \\
- --localstatedir=/var/lib \\
+ \-\-prefix=/usr \\
+ \-\-host=${CHOST} \\
+ \-\-mandir=/usr/share/man \\
+ \-\-infodir=/usr/share/info \\
+ \-\-datadir=/usr/share \\
+ \-\-sysconfdir=/etc \\
+ \-\-localstatedir=/var/lib \\
\fI${EXTRA_ECONF}\fR \\
\fIconfigure options\fR
.fi
-Note that the \fIEXTRA_ECONF\fR is for users only, not for ebuild
-writers. If you wish to pass more options to configure, just pass the
+Note that the \fIEXTRA_ECONF\fR is for users only, not for ebuild
+writers. If you wish to pass more options to configure, just pass the
extra arguements to \fBeconf\fR.
.TP
\fBemake\fR \fI[make options]\fR
-This is used as a replacement for make. Performs 'make ${MAKEOPTS}
+This is used as a replacement for make. Performs 'make ${MAKEOPTS}
\fImake options\fR' (as set in /etc/make.globals), default is MAKEOPTS="\-j2".
\fB***warning***\fR
.br
if you are going to use \fBemake\fR, make sure your build is happy with
parallel makes (make \-j2). It should be tested thoroughly as parallel
-makes are notorious for failing _sometimes_ but not always. If you determine
-that your package fails to build in parallel, and you are unable to resolve
-the issue, then you should run '\fBemake\fR -j1' instead of 'make'.
+makes are notorious for failing _sometimes_ but not always. If you determine
+that your package fails to build in parallel, and you are unable to resolve
+the issue, then you should run '\fBemake\fR \-j1' instead of 'make'.
.SH "HELPER FUNCTIONS: INSTALL"
.TP
\fBeinstall\fR \fI[make options]\fR
@@ -621,8 +625,8 @@ make \\
\fImake options\fR \\
install
.fi
-Please do \fBnot\fR use this in place of 'emake install DESTDIR=${D}'.
-That is the preferred way of installing make-based packages. Also, do
+Please do \fBnot\fR use this in place of 'emake install DESTDIR=${D}'.
+That is the preferred way of installing make\-based packages. Also, do
not utilize the \fIEXTRA_EINSTALL\fR variable since it is for users.
.PD 0
@@ -693,19 +697,19 @@ multiple directories.
\fBdosed\fR \fI"s:orig:change:g" <filename>\fR
Performs sed (including cp/mv \fIfilename\fR) on \fIfilename\fR.
.br
-.BR 'dosed\ "s:/usr/local:/usr:g"\ /usr/bin/some-script'
-runs sed on ${D}/usr/bin/some-script
+.BR 'dosed\ "s:/usr/local:/usr:g"\ /usr/bin/some\-script'
+runs sed on ${D}/usr/bin/some\-script
.TP
\fBdodir\fR \fI<path>\fR
Creates a directory inside of ${D}.
.br
.BR 'dodir\ /usr/lib/apache'
-creates ${D}/usr/lib/apache. Note that the do* functions will run
+creates ${D}/usr/lib/apache. Note that the do* functions will run
\fBdodir\fR for you.
.TP
\fBdiropts\fR \fI[options for install(1)]\fR
Can be used to define options for the install function used in
-\fBdodir\fR. The default is \fI-m0755\fR.
+\fBdodir\fR. The default is \fI\-m0755\fR.
.TP
\fBinto\fR \fI<path>\fR
Sets the root (\fIDESTTREE\fR) for other functions like \fBdobin\fR,
@@ -726,18 +730,18 @@ Installs a \fIbinary\fR or a list of binaries into \fIDESTTREE\fR/sbin.
Creates all necessary dirs.
.TP
\fBdoinitd\fR \fI<init.d script> [list of more init.d scripts]\fR
-Install Gentoo \fIinit.d scripts\fR. They will be installed into the
-correct location for Gentoo init.d scripts (/etc/init.d/). Creates all
+Install Gentoo \fIinit.d scripts\fR. They will be installed into the
+correct location for Gentoo init.d scripts (/etc/init.d/). Creates all
necessary dirs.
.TP
\fBdoconfd\fR \fI<conf.d file> [list of more conf.d file]\fR
-Install Gentoo \fIconf.d files\fR. They will be installed into the
-correct location for Gentoo conf.d files (/etc/conf.d/). Creates all
+Install Gentoo \fIconf.d files\fR. They will be installed into the
+correct location for Gentoo conf.d files (/etc/conf.d/). Creates all
necessary dirs.
.TP
\fBdoenvd\fR \fI<env.d entry> [list of more env.d entries]\fR
-Install Gentoo \fIenv.d entries\fR. They will be installed into the
-correct location for Gentoo env.d entries (/etc/env.d/). Creates all
+Install Gentoo \fIenv.d entries\fR. They will be installed into the
+correct location for Gentoo env.d entries (/etc/env.d/). Creates all
necessary dirs.
.PD 0
@@ -753,13 +757,13 @@ Creates all necessary dirs.
.TP
\fBlibopts\fR \fI[options for install(1)]\fR
Can be used to define options for the install function used in
-the \fBdolib\fR functions. The default is \fI-m0644\fR.
+the \fBdolib\fR functions. The default is \fI\-m0644\fR.
.TP
-\fBdoman\fR \fI[\-i18n=<locale>]\fR \fI<man-page> [list of more man\-pages]\fR
+\fBdoman\fR \fI[\-i18n=<locale>]\fR \fI<man\-page> [list of more man\-pages]\fR
Installs manual\-pages into /usr/share/man/man[0\-9n] depending on the
-manual file ending. The files are compressed if they are not already. You
-can specify locale-specific manpages with the \fI\-i18n\fR option. Then the
-man-page will be installed into /usr/share/man/\fI<locale>\fR/man[0\-9n].
+manual file ending. The files are compressed if they are not already. You
+can specify locale\-specific manpages with the \fI\-i18n\fR option. Then the
+man\-page will be installed into /usr/share/man/\fI<locale>\fR/man[0\-9n].
.PD 0
.TP
\fBdohard\fR \fI<filename> <linkname>\fR
@@ -775,11 +779,11 @@ or .css. Setting \fI\-a\fR limits what types of files will be included,
\fI\-A\fR appends to the default list, setting \fI\-x\fR sets which dirs to
exclude (CVS excluded by default), \fI\-r\fR sets recursive.
.TP
-\fBdoinfo\fR \fI<info-file> [list of more info\-files]\fR
+\fBdoinfo\fR \fI<info\-file> [list of more info\-files]\fR
Installs info\-pages into \fIDESTDIR\fR/info. Files are automatically
gzipped. Creates all necessary dirs.
.TP
-\fBdomo\fR \fI<locale-file> [list of more locale\-files] \fR
+\fBdomo\fR \fI<locale\-file> [list of more locale\-files] \fR
Installs locale\-files into \fIDESTDIR\fR/usr/share/locale/[LANG]
depending on local\-file's ending. Creates all necessary dirs.
@@ -863,6 +867,7 @@ Achim Gottinger <achim@gentoo.org>
Mark Guertin <gerk@gentoo.org>
Nicholas Jones <carpaski@gentoo.org>
Mike Frysinger <vapier@gentoo.org>
+Arfrever Frehtes Taifersar Arahesis <FFTA@WP.PL>
.fi
.SH "FILES"
.TP
diff --git a/man/make.conf.5 b/man/make.conf.5
index bbffed42..571c374d 100644
--- a/man/make.conf.5
+++ b/man/make.conf.5
@@ -1,4 +1,4 @@
-.TH "MAKE.CONF" "5" "Dec 2005" "Portage 2.1" "portage"
+.TH "MAKE.CONF" "5" "Jan 2007" "Portage 2.1.2" "Portage"
.SH "NAME"
make.conf \- custom settings for Portage
.SH "SYNOPSIS"
@@ -66,10 +66,12 @@ step as \fI\-\-host=${CHOST}\fR. This way you can force the build\-host.
For more information:
.br
-http://gcc.gnu.org/onlinedocs/gcc\-3.2/gcc/Submodel\-Options.html
+http://gcc.gnu.org/onlinedocs/gcc\-4.1.1/gcc/Submodel\-Options.html
.br
http://gcc.gnu.org/onlinedocs/gcc\-3.3/gcc/Submodel\-Options.html
.br
+http://gcc.gnu.org/onlinedocs/gcc\-3.2/gcc/Submodel\-Options.html
+.br
http://gcc.gnu.org/onlinedocs/gcc\-2.95.3/gcc_2.html
.TP
\fBCLEAN_DELAY\fR = \fIinteger\fR
@@ -104,7 +106,7 @@ informational messages. This variable is unset by default.
.TP
.B EMERGE_DEFAULT_OPTS
Options to append to the end of the \fBemerge\fR(1) command line on every invocation.
-These options will not be appended to the command line if --ignore-default-opts
+These options will not be appended to the command line if \-\-ignore\-default\-opts
is specified.
.TP
.B EPAUSE_IGNORE
@@ -119,7 +121,7 @@ part of \fBFEATURES\fR and should not be disabled by default. This is
an incremental variable.
.RS
.TP
-.B assume-digests
+.B assume\-digests
When commiting work to cvs with \fBrepoman\fR(1), assume that all existing
SRC_URI digests are correct. This feature also affects digest generation via
\fBebuild\fR(1) and \fBemerge\fR(1) (emerge generates digests only when the
@@ -147,7 +149,7 @@ feature.
.TP
.B digest
Autogenerate digests for packages when running the \fBemerge\fR(1) command. If
-the \fIassume-digests\fR feature is also enabled then existing SRC_URI digests
+the \fIassume\-digests\fR feature is also enabled then existing SRC_URI digests
will be reused whenever they are available.
.TP
.B distcc
@@ -183,8 +185,8 @@ Do not delete the ${T} directory after the merge process.
.B keepwork
Do not delete the ${WORKDIR} directory after the merge process.
.TP
-.B metadata-transfer
-Automatically perform a metadata transfer when `emerge --sync` is run.
+.B metadata\-transfer
+Automatically perform a metadata transfer when `emerge \-\-sync` is run.
.TP
.B mirror
This will cause \fBFETCHCOMMAND\fR to always be run even if
@@ -211,7 +213,7 @@ Prevents the stripping of binaries that are merged to the live filesystem.
.B notitles
Disables xterm titlebar updates (which contains status info).
.TP
-.B parallel-fetch
+.B parallel\-fetch
Fetch in the background while compiling.
.TP
.B sandbox
@@ -253,7 +255,8 @@ bits from any file that is not listed in \fI/etc/portage/suidctl.conf\fR.
.B test
Run package\-specific tests during each merge to help make sure
the package compiled properly. See \fItest\fR in \fBebuild\fR(1)
-and \fIsrc_test()\fR in \fBebuild\fR(5).
+and \fIsrc_test()\fR in \fBebuild\fR(5). This feature implies the "test"
+\fBUSE\fR flag.
.TP
.B userfetch
When portage is run as root, drop privileges to portage:portage during the
@@ -270,7 +273,7 @@ Enable the sandbox in the compile phase, when running without root privs (\fIuse
.B FETCHCOMMAND
This variable contains the command used for fetching package sources from
the internet. It must contain the full path to the executable as well as the
-place-holders \\${DISTDIR} and \\${URI}.
+place\-holders \\${DISTDIR} and \\${URI}.
.TP
\fBGENTOO_MIRRORS\fR = \fI[URLs]\fR
Insert your space\-seperated list of local mirrors here. These
@@ -321,39 +324,42 @@ the host that creates the binary packages and not to the root of the \fBPKGDIR\f
This variable contains the command used to compress documentation during the
install phase.
.TP
-\fBPORTAGE_COMPRESS_FLAGS\fR = \fI"-9"\fR
+\fBPORTAGE_COMPRESS_FLAGS\fR = \fI"\-9"\fR
This variable contains flags for the \fBPORTAGE_COMPRESS\fR command.
.TP
-\fBPORTAGE_NICENESS\fR = \fI[number]\fR
-The value of this variable will be added to the current nice level that
-emerge is running at. In other words, this will not set the nice level,
-it will increment it. For more information about nice levels and what
-are acceptable ranges, see \fBnice\fR(1).
-.TP
-\fBPORTAGE_ELOG_CLASSES\fR
+.B PORTAGE_ELOG_CLASSES
.TP
-\fBPORTAGE_ELOG_SYSTEM\fR
+.B PORTAGE_ELOG_SYSTEM
.TP
-\fBPORTAGE_ELOG_COMMAND\fR
+.B PORTAGE_ELOG_COMMAND
.TP
-\fBPORTAGE_ELOG_MAILURI\fR
+.B PORTAGE_ELOG_MAILURI
.TP
-\fBPORTAGE_ELOG_MAILFROM\fR
+.B PORTAGE_ELOG_MAILFROM
.TP
-\fBPORTAGE_ELOG_MAILSUBJECT\fR
+.B PORTAGE_ELOG_MAILSUBJECT
Please see /etc/make.conf.example for elog documentation.
.TP
+\fBPORTAGE_NICENESS\fR = \fI[number]\fR
+The value of this variable will be added to the current nice level that
+emerge is running at. In other words, this will not set the nice level,
+it will increment it. For more information about nice levels and what
+are acceptable ranges, see \fBnice\fR(1).
+.TP
\fBPORTAGE_RSYNC_EXTRA_OPTS\fR = \fI[rsync options string]\fR
-Additional rsync options to be used by \fBemerge --sync\fR.
+Additional rsync options to be used by \fBemerge \-\-sync\fR.
.br
Defaults to no value.
.TP
\fBPORTAGE_RSYNC_OPTS\fR = \fI[rsync options string]\fR
-Default rsync options to be used by \fBemerge --sync\fR.
+Default rsync options to be used by \fBemerge \-\-sync\fR.
.br
\fBDon't change this unless you know exactly what you're doing!\fR
.br
-Defaults to "--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
+Defaults to "\-\-recursive \-\-links \-\-safe\-links \-\-perms \-\-times
+\-\-compress \-\-force \-\-whole\-file \-\-delete \-\-delete\-after \-\-stats
+\-\-timeout=180 \-\-exclude='/distfiles' \-\-exclude='/local'
+\-\-exclude='/packages'"
.TP
\fBPORTAGE_RSYNC_RETRIES\fR = \fI[NUMBER]\fR
The number of times rsync should retry on failed connections before
@@ -378,11 +384,6 @@ directories.
.br
Defaults to no value.
.TP
-.B RESUMECOMMAND
-This variable contains the command used for resuming package sources that
-have been partially downloaded. It should be defined using the same format
-as \fBFETCHCOMMAND\fR.
-.TP
\fBQA_STRICT_EXECSTACK = \fI"set"\fR
Set this to cause portage to ignore any \fIQA_EXECSTACK\fR override
settings from ebuilds. See also \fBebuild\fR(5).
@@ -395,6 +396,11 @@ settings from ebuilds. See also \fBebuild\fR(5).
Set this to cause portage to ignore any \fIQA_TEXTREL\fR override
settings from ebuilds. See also \fBebuild\fR(5).
.TP
+.B RESUMECOMMAND
+This variable contains the command used for resuming package sources that
+have been partially downloaded. It should be defined using the same format
+as \fBFETCHCOMMAND\fR.
+.TP
\fBROOT\fR = \fI[path]\fR
Use \fBROOT\fR to specify the target root filesystem to be used for merging
packages or ebuilds. All \fBRDEPEND\fR and \fBPDEPEND\fR will be installed
@@ -430,7 +436,7 @@ Determines the precedence of layers in the incremental stacking of the USE
variable. Precedence decreases from left to right such that env overrides
pkg, pkg overrides conf, and so forth.
-\fB***warning***\fR
+.B ***warning***
.br
Do not modify this value unless you're a developer and you know what
you're doing. If you change this and something breaks, we will not help
@@ -442,7 +448,7 @@ you fix it.
USE from the current USE environment variable if it exists
.TP
.B pkg
-Per-package USE from \fB/etc/portage/package.use\fR (see \fBportage\fR(5))
+Per\-package USE from \fB/etc/portage/package.use\fR (see \fBportage\fR(5))
.TP
.B conf
USE from make.conf