aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-04-06 01:54:19 +0000
committerMike Frysinger <vapier@gentoo.org>2009-04-06 01:54:19 +0000
commit979566c74b151ccb9c06084f583c07ec4074bbbd (patch)
tree772c0cebb23b81598abef76883c6b1c0864ea3af /Makefile
parentdon't define strcasestr static, that conflicts with gnulib's definition (diff)
downloadportage-utils-979566c74b151ccb9c06084f583c07ec4074bbbd.tar.gz
portage-utils-979566c74b151ccb9c06084f583c07ec4074bbbd.tar.bz2
portage-utils-979566c74b151ccb9c06084f583c07ec4074bbbd.zip
use [ rather than [[ for shell code
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index f918ea83..5e831e2d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2005-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.64 2009/03/24 20:53:24 grobian Exp $
+# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.65 2009/04/06 01:54:19 vapier Exp $
####################################################################
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
@@ -104,7 +104,7 @@ testclean:
install: all
-$(MKDIR) $(PREFIX)/bin/
$(CP) q $(PREFIX)/bin/
- if [[ ! -d CVS ]] ; then \
+ if [ ! -d CVS ] ; then \
$(MKDIR) $(PREFIX)/share/man/man1/ ; \
for mpage in $(wildcard man/*.1) ; do \
[ -e $$mpage ] \
@@ -117,7 +117,7 @@ install: all
fi
(cd $(PREFIX)/bin/ ; \
for applet in $(APPLETS); do \
- [[ ! -e $$applet ]] && ln -s q $${applet} ; \
+ [ ! -e "$$applet" ] && ln -s q $${applet} ; \
done \
)