aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-09 17:07:24 -0400
committerMike Frysinger <vapier@gentoo.org>2014-03-09 17:07:24 -0400
commita235b67877128a5ab23388cabb0a31bf3502094e (patch)
tree63fd012072cddb35c948a5de96425f97d262adbd /Makefile
parentbuild: convert all cvs references to git (diff)
downloadportage-utils-a235b67877128a5ab23388cabb0a31bf3502094e.tar.gz
portage-utils-a235b67877128a5ab23388cabb0a31bf3502094e.tar.bz2
portage-utils-a235b67877128a5ab23388cabb0a31bf3502094e.zip
use localized number formats
NLS becomes a proper compile time option and we use that to print numbers in a more natural format. If people want raw format for scripts, you can set LC_ALL=C. URL: https://bugs.gentoo.org/503646
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 2889fe2..d202f54 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,7 @@
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
then echo "$(1)"; else echo "$(2)"; fi)
+istrue = $(if $(filter 1 yes true on,$(strip $1)),1,0)
####################################################
WFLAGS := -Wall -Wunused -Wimplicit -Wshadow -Wformat=2 \
@@ -18,6 +19,7 @@ WFLAGS := -Wall -Wunused -Wimplicit -Wshadow -Wformat=2 \
CFLAGS ?= -O2 -g -pipe
CFLAGS += -std=gnu99
CPPFLAGS ?=
+CPPFLAGS += -DENABLE_NLS=$(call istrue,$(NLS))
#CFLAGS += -DEBUG -g
#CFLAGS += -Os -DOPTIMIZE_FOR_SIZE=2 -falign-functions=2 -falign-jumps=2 -falign-labels=2 -falign-loops=2
#LDFLAGS := -pie