aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2007-05-14 16:25:30 +0000
committerNed Ludd <solar@gentoo.org>2007-05-14 16:25:30 +0000
commitc7b37810ff81ece3f6d42e6237f01d7bdbc7e15d (patch)
tree7d65e0204761a9f192c99fc3cdd649a04ad5476f /Makefile
parent- small bug fix for qcheck bug 173753 (diff)
downloadportage-utils-c7b37810ff81ece3f6d42e6237f01d7bdbc7e15d.tar.gz
portage-utils-c7b37810ff81ece3f6d42e6237f01d7bdbc7e15d.tar.bz2
portage-utils-c7b37810ff81ece3f6d42e6237f01d7bdbc7e15d.zip
- we have no dlopen on the bsd arches and dlfunc is defined when including dlcfn.h there. This commit might not work for osx
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 7656e975..8f597564 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2005-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.58 2007/05/12 02:40:06 solar Exp $
+# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.59 2007/05/14 16:25:30 solar Exp $
####################################################################
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
@@ -27,7 +27,7 @@ MKDIR := mkdir -p
CP := cp
ifndef STATIC
-LDFLAGS += -ldl -Wl,--export-dynamic
+LDFLAGS += -Wl,--export-dynamic $(shell echo | $(CC) -dM -E - | grep -q ' __linux__' && echo '-ldl')
else
CFLAGS += -DSTATIC
endif