aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xconfigure36
-rw-r--r--configure.ac1
-rw-r--r--libq/atom.c1
-rw-r--r--libq/prelink.c1
-rw-r--r--libq/safe_io.c1
-rw-r--r--libq/xchdir.c1
-rw-r--r--libq/xmkdir.c2
-rw-r--r--main.c1
-rw-r--r--qmerge.c2
9 files changed, 46 insertions, 0 deletions
diff --git a/configure b/configure
index ad96730..ce1fbde 100755
--- a/configure
+++ b/configure
@@ -35001,6 +35001,42 @@ else
fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -Wno-expansion-to-defined" >&5
+$as_echo_n "checking whether C compiler accepts -Wno-expansion-to-defined... " >&6; }
+if ${ax_cv_check_cflags___Wno_expansion_to_defined+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+
+ ax_check_save_flags=$CFLAGS
+ CFLAGS="$CFLAGS -Wno-expansion-to-defined"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+int
+main ()
+{
+
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_compile "$LINENO"; then :
+ ax_cv_check_cflags___Wno_expansion_to_defined=yes
+else
+ ax_cv_check_cflags___Wno_expansion_to_defined=no
+fi
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+ CFLAGS=$ax_check_save_flags
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___Wno_expansion_to_defined" >&5
+$as_echo "$ax_cv_check_cflags___Wno_expansion_to_defined" >&6; }
+if test "x$ax_cv_check_cflags___Wno_expansion_to_defined" = xyes; then :
+ as_fn_append CFLAGS " -Wno-expansion-to-defined"
+else
+ :
+fi
+
+
ac_config_files="$ac_config_files Makefile libq/Makefile autotools/gnulib/Makefile tests/atom_explode/Makefile tests/copy_file/Makefile tests/mkdir/Makefile tests/rmspace/Makefile"
diff --git a/configure.ac b/configure.ac
index 870a059..55346a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,7 @@ m4_foreach_w([flag], [
-Wsequence-point
-Wold-style-definition
-Wextra
+ -Wno-expansion-to-defined
], [
AX_CHECK_COMPILE_FLAG(flag, AS_VAR_APPEND([CFLAGS], " flag"))
])
diff --git a/libq/atom.c b/libq/atom.c
index e5c3dc1..60a37ce 100644
--- a/libq/atom.c
+++ b/libq/atom.c
@@ -11,6 +11,7 @@
#include "atom.h"
#include <unistd.h>
+#include <stdlib.h>
#include <string.h>
#include <ctype.h>
#include <xalloc.h>
diff --git a/libq/prelink.c b/libq/prelink.c
index 0d1ce83..0cda2c5 100644
--- a/libq/prelink.c
+++ b/libq/prelink.c
@@ -11,6 +11,7 @@
#include <sys/wait.h>
#include <sys/stat.h>
#include <fcntl.h>
+#include <stdlib.h>
#include "xasprintf.h"
#include "prelink.h"
diff --git a/libq/safe_io.c b/libq/safe_io.c
index e209c87..a1c7687 100644
--- a/libq/safe_io.c
+++ b/libq/safe_io.c
@@ -8,6 +8,7 @@
#include "main.h"
#include <stdio.h>
+#include <stdlib.h>
#include <errno.h>
#define _IN_SAFE_IO 1
diff --git a/libq/xchdir.c b/libq/xchdir.c
index 2d649ad..a208fbc 100644
--- a/libq/xchdir.c
+++ b/libq/xchdir.c
@@ -8,6 +8,7 @@
#include "main.h"
#include <unistd.h>
+#include <stdlib.h>
#include "xchdir.h"
diff --git a/libq/xmkdir.c b/libq/xmkdir.c
index 2e60b08..8a5aab9 100644
--- a/libq/xmkdir.c
+++ b/libq/xmkdir.c
@@ -8,6 +8,8 @@
#include "main.h"
+#include <stdlib.h>
+#include <unistd.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <dirent.h>
diff --git a/main.c b/main.c
index 1749114..6b4153a 100644
--- a/main.c
+++ b/main.c
@@ -36,6 +36,7 @@
#include <assert.h>
#include <ctype.h>
#include <sys/time.h>
+#include <limits.h>
#if defined(__sun) && defined(__SVR4)
/* workaround non-const defined name in option struct, such that we
diff --git a/qmerge.c b/qmerge.c
index 3388ed3..5ebb55e 100644
--- a/qmerge.c
+++ b/qmerge.c
@@ -10,6 +10,8 @@
#ifdef APPLET_qmerge
#include <fnmatch.h>
+#include <sys/types.h>
+#include <sys/wait.h>
#include "stat-time.h"
#ifndef GLOB_BRACE