aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-03-16 16:49:00 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-03-16 17:48:49 -0700
commit4d245737cdf3482809a564fe80a9555012636821 (patch)
treed0169cd7df2b4f90300a631ba6478f3547e83fe7
parentdepgraph: fix missed atom_not_selected initialization (bug 612846) (diff)
downloadportage-4d245737cdf3482809a564fe80a9555012636821.tar.gz
portage-4d245737cdf3482809a564fe80a9555012636821.tar.bz2
portage-4d245737cdf3482809a564fe80a9555012636821.zip
Updates for a releaseportage-2.3.5
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
-rw-r--r--NEWS7
-rw-r--r--RELEASE-NOTES18
-rwxr-xr-xsetup.py2
3 files changed, 26 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index 98f444d10..052da5e64 100644
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,12 @@
News (mainly features/major bug fixes)
+portage-2.3.5
+-----------------
+* Numerous patches updating checksums code and python module imports for them
+ including new checksum methods
+* New linux in kernel movefile support via a new "C" extension module
+
+
portage-2.3.3
-----------------
* Reverted commits:
diff --git a/RELEASE-NOTES b/RELEASE-NOTES
index 574441f9c..2c1cf4058 100644
--- a/RELEASE-NOTES
+++ b/RELEASE-NOTES
@@ -1,6 +1,24 @@
Release Notes; upgrade information mainly.
Features/major bugfixes are listed in NEWS
+portage-2.3.5
+==================================
+* Bug Fixes:
+ - Bug 598444 auto-enable --with-bdeps if --usepkg is not enabled
+ - Bug 611838 use_reduce: reserve missing_white_space_check for invalid tokens
+ - Bug 612042 depgraph: fix backtracking for slot operator rebuilds
+ - Bug 612094 depgraph: fix runtime package mask interaction with slot
+ operator rebuilds
+ - Bug 611896 config.setcpv: fix handling of IUSE changes
+ - Bug 597736 Support STREEBOG{256,512} hash function
+ - Bug 607868 movefile: support in-kernel file copying on Linux
+ - Bug 612772 depgraph: fix slot operator rebuild for llvm:0 to llvm:4 upgrade
+ - Bug 612846 depgraph: fix missed atom_not_selected initialization
+* Numerous patches updating checksums code and python module imports for them
+ including new checksum methods
+* New linux in kernel movefile support via a new "C" extension module
+
+
portage-2.3.4
==================================
* Bug Fixes:
diff --git a/setup.py b/setup.py
index b62476758..e99317792 100755
--- a/setup.py
+++ b/setup.py
@@ -655,7 +655,7 @@ class build_ext(_build_ext):
setup(
name = 'portage',
- version = '2.3.4',
+ version = '2.3.5',
url = 'https://wiki.gentoo.org/wiki/Project:Portage',
author = 'Gentoo Portage Development Team',
author_email = 'dev-portage@gentoo.org',