summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-server/files/postgresql-8.1-server.patch')
-rw-r--r--dev-db/postgresql-server/files/postgresql-8.1-server.patch107
1 files changed, 60 insertions, 47 deletions
diff --git a/dev-db/postgresql-server/files/postgresql-8.1-server.patch b/dev-db/postgresql-server/files/postgresql-8.1-server.patch
index 9ec3869..c68fcff 100644
--- a/dev-db/postgresql-server/files/postgresql-8.1-server.patch
+++ b/dev-db/postgresql-server/files/postgresql-8.1-server.patch
@@ -1,8 +1,8 @@
-diff --git a/GNUmakefile.in b/GNUmakefile.in
-index 0216527..7ed3520 100644
---- a/GNUmakefile.in
-+++ b/GNUmakefile.in
-@@ -11,19 +11,16 @@ include $(top_builddir)/src/Makefile.global
+=== GNUmakefile.in
+==================================================================
+--- GNUmakefile.in (revision 14)
++++ GNUmakefile.in (local)
+@@ -11,19 +11,16 @@
all:
$(MAKE) -C doc all
$(MAKE) -C src all
@@ -22,11 +22,11 @@ index 0216527..7ed3520 100644
# clean, distclean, etc should apply to contrib too, even though
# it's not built by default
-diff --git a/contrib/Makefile b/contrib/Makefile
-index 7367163..2740bb9 100644
---- a/contrib/Makefile
-+++ b/contrib/Makefile
-@@ -19,10 +19,8 @@ WANTED_DIRS = \
+=== contrib/Makefile
+==================================================================
+--- contrib/Makefile (revision 14)
++++ contrib/Makefile (local)
+@@ -19,10 +19,8 @@
isbn_issn \
lo \
ltree \
@@ -37,7 +37,7 @@ index 7367163..2740bb9 100644
pgcrypto \
pgstattuple \
seg \
-@@ -30,8 +28,7 @@ WANTED_DIRS = \
+@@ -30,8 +28,7 @@
tablefunc \
tips \
tsearch2 \
@@ -47,11 +47,11 @@ index 7367163..2740bb9 100644
# Missing:
# adddepend \ (does not have a makefile)
-diff --git a/src/Makefile b/src/Makefile
-index 0963f88..5a7bb45 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -18,14 +18,10 @@ all install installdirs uninstall dep depend distprep:
+=== src/Makefile
+==================================================================
+--- src/Makefile (revision 14)
++++ src/Makefile (local)
+@@ -18,14 +18,10 @@
$(MAKE) -C timezone $@
$(MAKE) -C backend $@
$(MAKE) -C backend/utils/mb/conversion_procs $@
@@ -67,11 +67,11 @@ index 0963f88..5a7bb45 100644
install-local: installdirs-local
$(INSTALL_DATA) Makefile.global $(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.global
-diff --git a/src/Makefile.global.in b/src/Makefile.global.in
-index 20d7a1d..12533a2 100644
---- a/src/Makefile.global.in
-+++ b/src/Makefile.global.in
-@@ -360,10 +360,10 @@ endif
+=== src/Makefile.global.in
+==================================================================
+--- src/Makefile.global.in (revision 14)
++++ src/Makefile.global.in (local)
+@@ -360,10 +360,10 @@
submake-libpq:
@@ -84,11 +84,11 @@ index 20d7a1d..12533a2 100644
.PHONY: submake-libpq submake-libpgport
-diff --git a/src/bin/Makefile b/src/bin/Makefile
-index 8309db1..0d620d0 100644
---- a/src/bin/Makefile
-+++ b/src/bin/Makefile
-@@ -13,8 +13,8 @@ subdir = src/bin
+=== src/bin/Makefile
+==================================================================
+--- src/bin/Makefile (revision 14)
++++ src/bin/Makefile (local)
+@@ -13,8 +13,8 @@
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
@@ -99,11 +99,24 @@ index 8309db1..0d620d0 100644
ifeq ($(PORTNAME), win32)
DIRS+=pgevent
endif
-diff --git a/src/port/Makefile b/src/port/Makefile
-index 8ca565e..dad5bb3 100644
---- a/src/port/Makefile
-+++ b/src/port/Makefile
-@@ -29,11 +29,10 @@ LIBS += $(PTHREAD_LIBS)
+=== src/include/pg_config_manual.h
+==================================================================
+--- src/include/pg_config_manual.h (revision 14)
++++ src/include/pg_config_manual.h (local)
+@@ -175,7 +175,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
+=== src/port/Makefile
+==================================================================
+--- src/port/Makefile (revision 14)
++++ src/port/Makefile (local)
+@@ -29,11 +29,10 @@
# Replace all object files so they use FRONTEND define
LIBOBJS_SRV := $(LIBOBJS:%.o=%_srv.o)
@@ -117,11 +130,11 @@ index 8ca565e..dad5bb3 100644
uninstall:
$(RM) $(DESTDIR)$(libdir)/libpgport.a
-diff --git a/src/test/regress/GNUmakefile b/src/test/regress/GNUmakefile
-index a384254..22f69f1 100644
---- a/src/test/regress/GNUmakefile
-+++ b/src/test/regress/GNUmakefile
-@@ -137,7 +137,7 @@ all-spi:
+=== src/test/regress/GNUmakefile
+==================================================================
+--- src/test/regress/GNUmakefile (revision 14)
++++ src/test/regress/GNUmakefile (local)
+@@ -137,7 +137,7 @@
check: all
-rm -rf ./testtablespace
mkdir ./testtablespace
@@ -130,11 +143,11 @@ index a384254..22f69f1 100644
installcheck: all
-rm -rf ./testtablespace
-diff --git a/src/test/regress/pg_regress.sh b/src/test/regress/pg_regress.sh
-index 5bb31f7..0223328 100644
---- a/src/test/regress/pg_regress.sh
-+++ b/src/test/regress/pg_regress.sh
-@@ -91,6 +91,8 @@ host_platform='@host_tuple@'
+=== src/test/regress/pg_regress.sh
+==================================================================
+--- src/test/regress/pg_regress.sh (revision 14)
++++ src/test/regress/pg_regress.sh (local)
+@@ -91,6 +91,8 @@
enable_shared='@enable_shared@'
GCC=@GCC@
@@ -143,7 +156,7 @@ index 5bb31f7..0223328 100644
if [ "$GCC" = yes ]; then
compiler=gcc
else
-@@ -441,7 +443,7 @@ then
+@@ -441,7 +443,7 @@
# wait forever, however.
i=0
max=60
@@ -152,7 +165,7 @@ index 5bb31f7..0223328 100644
do
i=`expr $i + 1`
if [ $i -ge $max ]
-@@ -498,7 +500,7 @@ else # not temp-install
+@@ -498,7 +500,7 @@
fi
message "dropping database \"$dbname\""
@@ -161,7 +174,7 @@ index 5bb31f7..0223328 100644
# errors can be ignored
fi
-@@ -507,7 +509,7 @@ fi
+@@ -507,7 +509,7 @@
# Set up SQL shell for the test.
# ----------
@@ -170,7 +183,7 @@ index 5bb31f7..0223328 100644
# ----------
-@@ -538,13 +540,13 @@ fi
+@@ -538,13 +540,13 @@
# ----------
message "creating database \"$dbname\""
@@ -186,7 +199,7 @@ index 5bb31f7..0223328 100644
alter database \"$dbname\" set lc_messages to 'C';
alter database \"$dbname\" set lc_monetary to 'C';
alter database \"$dbname\" set lc_numeric to 'C';
-@@ -560,7 +562,7 @@ fi
+@@ -560,7 +562,7 @@
# ----------
message "dropping regression test user accounts"
@@ -195,7 +208,7 @@ index 5bb31f7..0223328 100644
if [ $? -eq 2 ]; then
echo "$me: could not drop user accounts"
(exit 2); exit
-@@ -575,7 +577,7 @@ if [ "$enable_shared" = yes ]; then
+@@ -575,7 +577,7 @@
for lang in xyzzy $load_langs ; do
if [ "$lang" != "xyzzy" ]; then
message "installing $lang"