aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-09-18 14:21:27 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2011-09-18 14:21:27 -0400
commitbd42c87b0bf18957a35ada6f999d436cb5de3b26 (patch)
treebee0e3260219e84c6b0b7b36594fe0a83adf622d
parentUpdated for 9.1.0. (diff)
downloadpatches-bd42c87b0bf18957a35ada6f999d436cb5de3b26.tar.gz
patches-bd42c87b0bf18957a35ada6f999d436cb5de3b26.tar.bz2
patches-bd42c87b0bf18957a35ada6f999d436cb5de3b26.zip
Updated for 9.1.0
-rw-r--r--server.patch55
1 files changed, 29 insertions, 26 deletions
diff --git a/server.patch b/server.patch
index 4e50514..2cbec0b 100644
--- a/server.patch
+++ b/server.patch
@@ -1,6 +1,6 @@
diff -Naur a/contrib/adminpack/Makefile b/contrib/adminpack/Makefile
---- a/contrib/adminpack/Makefile 2011-08-18 17:23:13.000000000 -0400
-+++ b/contrib/adminpack/Makefile 2011-08-27 17:43:07.864849241 -0400
+--- a/contrib/adminpack/Makefile 2011-09-08 17:13:27.000000000 -0400
++++ b/contrib/adminpack/Makefile 2011-09-17 11:42:03.576618001 -0400
@@ -2,7 +2,7 @@
MODULE_big = adminpack
@@ -11,8 +11,8 @@ diff -Naur a/contrib/adminpack/Makefile b/contrib/adminpack/Makefile
EXTENSION = adminpack
DATA = adminpack--1.0.sql
diff -Naur a/contrib/dblink/Makefile b/contrib/dblink/Makefile
---- a/contrib/dblink/Makefile 2011-08-18 17:23:13.000000000 -0400
-+++ b/contrib/dblink/Makefile 2011-08-27 17:43:48.350768066 -0400
+--- a/contrib/dblink/Makefile 2011-09-08 17:13:27.000000000 -0400
++++ b/contrib/dblink/Makefile 2011-09-17 11:42:44.500618001 -0400
@@ -2,7 +2,7 @@
MODULE_big = dblink
@@ -23,8 +23,8 @@ diff -Naur a/contrib/dblink/Makefile b/contrib/dblink/Makefile
SHLIB_PREREQS = submake-libpq
diff -Naur a/contrib/Makefile b/contrib/Makefile
---- a/contrib/Makefile 2011-08-18 17:23:13.000000000 -0400
-+++ b/contrib/Makefile 2011-08-27 17:41:23.565363128 -0400
+--- a/contrib/Makefile 2011-09-08 17:13:27.000000000 -0400
++++ b/contrib/Makefile 2011-09-17 11:44:08.068618001 -0400
@@ -26,7 +26,6 @@
isn \
lo \
@@ -52,8 +52,8 @@ diff -Naur a/contrib/Makefile b/contrib/Makefile
ifeq ($(with_openssl),yes)
SUBDIRS += sslinfo
diff -Naur a/contrib/uuid-ossp/Makefile b/contrib/uuid-ossp/Makefile
---- a/contrib/uuid-ossp/Makefile 2011-08-18 17:23:13.000000000 -0400
-+++ b/contrib/uuid-ossp/Makefile 2011-08-27 17:45:43.166793814 -0400
+--- a/contrib/uuid-ossp/Makefile 2011-09-08 17:13:27.000000000 -0400
++++ b/contrib/uuid-ossp/Makefile 2011-09-17 11:45:18.240618001 -0400
@@ -1,12 +1,13 @@
# contrib/uuid-ossp/Makefile
@@ -70,21 +70,21 @@ diff -Naur a/contrib/uuid-ossp/Makefile b/contrib/uuid-ossp/Makefile
ifdef USE_PGXS
PG_CONFIG = pg_config
diff -Naur a/contrib/xml2/Makefile b/contrib/xml2/Makefile
---- a/contrib/xml2/Makefile 2011-08-18 17:23:13.000000000 -0400
-+++ b/contrib/xml2/Makefile 2011-08-27 17:47:07.078335070 -0400
+--- a/contrib/xml2/Makefile 2011-09-08 17:13:27.000000000 -0400
++++ b/contrib/xml2/Makefile 2011-09-17 11:46:25.216618000 -0400
@@ -8,7 +8,8 @@
REGRESS = xml2
--SHLIB_LINK += $(filter -lxslt, $(LIBS)) $(filter -lxml2, $(LIBS))
+-SHLIB_LINK += $(filter -lxslt, $(LIBS)) -lxml2
+PG_CPPFLAGS = $(shell xml2-config --cflags)
+SHLIB_LINK += $(shell xml2-config --libs) $(shell xslt-config --libs)
ifdef USE_PGXS
PG_CONFIG = pg_config
diff -Naur a/GNUmakefile.in b/GNUmakefile.in
---- a/GNUmakefile.in 2011-08-18 17:23:13.000000000 -0400
-+++ b/GNUmakefile.in 2011-08-27 17:40:13.102466128 -0400
+--- a/GNUmakefile.in 2011-09-08 17:13:27.000000000 -0400
++++ b/GNUmakefile.in 2011-09-17 11:48:36.620618001 -0400
@@ -8,7 +8,7 @@
top_builddir = .
include $(top_builddir)/src/Makefile.global
@@ -103,7 +103,7 @@ diff -Naur a/GNUmakefile.in b/GNUmakefile.in
world:
+@echo "PostgreSQL, contrib, and documentation successfully made. Ready to install."
-@@ -29,11 +29,11 @@
+@@ -32,14 +32,14 @@
install-docs:
$(MAKE) -C doc install
@@ -112,14 +112,17 @@ diff -Naur a/GNUmakefile.in b/GNUmakefile.in
install-world:
+@echo "PostgreSQL, contrib, and documentation installation complete."
+ # build src/ before contrib/
+ install-world-contrib-recurse: install-world-src-recurse
+
-$(call recurse,installdirs uninstall coverage,doc src config)
+$(call recurse,installdirs uninstall coverage,doc src)
$(call recurse,distprep,doc src config contrib)
diff -Naur a/src/bin/initdb/Makefile b/src/bin/initdb/Makefile
---- a/src/bin/initdb/Makefile 2011-08-18 17:23:13.000000000 -0400
-+++ b/src/bin/initdb/Makefile 2011-08-27 17:51:46.200198057 -0400
+--- a/src/bin/initdb/Makefile 2011-09-08 17:13:27.000000000 -0400
++++ b/src/bin/initdb/Makefile 2011-09-17 11:50:16.832618001 -0400
@@ -16,7 +16,7 @@
top_builddir = ../../..
include $(top_builddir)/src/Makefile.global
@@ -130,8 +133,8 @@ diff -Naur a/src/bin/initdb/Makefile b/src/bin/initdb/Makefile
OBJS= initdb.o encnames.o pqsignal.o $(WIN32RES)
diff -Naur a/src/bin/Makefile b/src/bin/Makefile
---- a/src/bin/Makefile 2011-08-18 17:23:13.000000000 -0400
-+++ b/src/bin/Makefile 2011-08-27 17:50:31.507727467 -0400
+--- a/src/bin/Makefile 2011-09-08 17:13:27.000000000 -0400
++++ b/src/bin/Makefile 2011-09-17 11:51:14.628618001 -0400
@@ -13,8 +13,7 @@
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
@@ -143,8 +146,8 @@ diff -Naur a/src/bin/Makefile b/src/bin/Makefile
ifeq ($(PORTNAME), win32)
SUBDIRS += pgevent
diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
---- a/src/include/pg_config_manual.h 2011-08-18 17:23:13.000000000 -0400
-+++ b/src/include/pg_config_manual.h 2011-08-27 17:53:01.442613210 -0400
+--- a/src/include/pg_config_manual.h 2011-09-08 17:13:27.000000000 -0400
++++ b/src/include/pg_config_manual.h 2011-09-17 11:52:23.292618001 -0400
@@ -141,7 +141,7 @@
* here's where to twiddle it. You can also override this at runtime
* with the postmaster's -k switch.
@@ -155,8 +158,8 @@ diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
/*
* The random() function is expected to yield values between 0 and
diff -Naur a/src/Makefile b/src/Makefile
---- a/src/Makefile 2011-08-18 17:23:13.000000000 -0400
-+++ b/src/Makefile 2011-08-27 17:48:06.462348836 -0400
+--- a/src/Makefile 2011-09-08 17:13:27.000000000 -0400
++++ b/src/Makefile 2011-09-17 12:12:29.580618000 -0400
@@ -18,12 +18,9 @@
backend \
backend/utils/mb/conversion_procs \
@@ -180,8 +183,8 @@ diff -Naur a/src/Makefile b/src/Makefile
install-local: installdirs-local
$(INSTALL_DATA) Makefile.global '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.global'
diff -Naur a/src/Makefile.global.in b/src/Makefile.global.in
---- a/src/Makefile.global.in 2011-08-18 17:23:13.000000000 -0400
-+++ b/src/Makefile.global.in 2011-08-27 17:49:15.185421175 -0400
+--- a/src/Makefile.global.in 2011-09-08 17:13:27.000000000 -0400
++++ b/src/Makefile.global.in 2011-09-17 12:14:57.972618000 -0400
@@ -482,6 +482,7 @@
LDFLAGS += $(PROFILE)
endif
@@ -191,8 +194,8 @@ diff -Naur a/src/Makefile.global.in b/src/Makefile.global.in
##########################################################################
#
diff -Naur a/src/port/Makefile b/src/port/Makefile
---- a/src/port/Makefile 2011-08-18 17:23:13.000000000 -0400
-+++ b/src/port/Makefile 2011-08-27 17:54:10.765625070 -0400
+--- a/src/port/Makefile 2011-09-08 17:13:27.000000000 -0400
++++ b/src/port/Makefile 2011-09-17 12:15:46.196618001 -0400
@@ -37,11 +37,10 @@
# foo_srv.o and foo.o are both built from foo.c, but only foo.o has -DFRONTEND
OBJS_SRV = $(OBJS:%.o=%_srv.o)