aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-05-02 19:05:52 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2011-05-02 19:05:52 -0400
commitf15bfd5e94ee08640ffe900a5eb4fe793abec673 (patch)
tree4852dd96191c216e84350c7043d4a9fa4ec7ef10
parentUpdated for 9.1alpha5 (diff)
downloadpatches-f15bfd5e94ee08640ffe900a5eb4fe793abec673.tar.gz
patches-f15bfd5e94ee08640ffe900a5eb4fe793abec673.tar.bz2
patches-f15bfd5e94ee08640ffe900a5eb4fe793abec673.zip
Update for PostgreSQL 9.1beta1
-rw-r--r--autoconf.patch6
-rw-r--r--base.patch22
-rw-r--r--regress.patch16
-rw-r--r--server.patch62
4 files changed, 53 insertions, 53 deletions
diff --git a/autoconf.patch b/autoconf.patch
index a2027a7..2a82580 100644
--- a/autoconf.patch
+++ b/autoconf.patch
@@ -1,9 +1,9 @@
diff -Naur a/configure.in b/configure.in
---- a/configure.in 2010-07-08 22:43:12.000000000 -0400
-+++ b/configure.in 2010-07-12 00:13:37.585527031 -0400
+--- a/configure.in 2011-04-27 17:17:22.000000000 -0400
++++ b/configure.in 2011-05-02 18:02:31.471665153 -0400
@@ -19,10 +19,6 @@
- AC_INIT([PostgreSQL], [9.1alpha4], [pgsql-bugs@postgresql.org])
+ AC_INIT([PostgreSQL], [9.1beta1], [pgsql-bugs@postgresql.org])
-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.63], [], [m4_fatal([Autoconf version 2.63 is required.
-Untested combinations of 'autoconf' and PostgreSQL versions are not
diff --git a/base.patch b/base.patch
index c55bb77..9c53e1b 100644
--- a/base.patch
+++ b/base.patch
@@ -1,6 +1,6 @@
diff -Naur a/contrib/Makefile b/contrib/Makefile
---- a/contrib/Makefile 2011-03-28 09:42:09.000000000 -0400
-+++ b/contrib/Makefile 2011-03-29 20:18:08.394999851 -0400
+--- a/contrib/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/contrib/Makefile 2011-05-02 18:13:25.185010280 -0400
@@ -5,54 +5,10 @@
include $(top_builddir)/src/Makefile.global
@@ -57,8 +57,8 @@ diff -Naur a/contrib/Makefile b/contrib/Makefile
ifeq ($(with_ossp_uuid),yes)
SUBDIRS += uuid-ossp
diff -Naur a/src/Makefile b/src/Makefile
---- a/src/Makefile 2011-03-28 09:42:09.000000000 -0400
-+++ b/src/Makefile 2011-03-29 20:19:45.356494851 -0400
+--- a/src/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/src/Makefile 2011-05-02 18:14:24.435313471 -0400
@@ -14,17 +14,11 @@
SUBDIRS = \
@@ -79,8 +79,8 @@ diff -Naur a/src/Makefile b/src/Makefile
# There are too many interdependencies between the subdirectories, so
# don't attempt parallel make here.
diff -Naur a/src/backend/Makefile b/src/backend/Makefile
---- a/src/backend/Makefile 2011-03-28 09:42:09.000000000 -0400
-+++ b/src/backend/Makefile 2011-03-29 20:24:25.836184851 -0400
+--- a/src/backend/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/src/backend/Makefile 2011-05-02 18:19:06.946759115 -0400
@@ -45,7 +45,7 @@
##########################################################################
@@ -125,21 +125,21 @@ diff -Naur a/src/backend/Makefile b/src/backend/Makefile
install-bin: postgres $(POSTGRES_IMP) installdirs
$(INSTALL_PROGRAM) postgres$(X) '$(DESTDIR)$(bindir)/postgres$(X)'
diff -Naur a/src/bin/Makefile b/src/bin/Makefile
---- a/src/bin/Makefile 2011-03-28 09:42:09.000000000 -0400
-+++ b/src/bin/Makefile 2011-03-29 20:25:34.162004851 -0400
+--- a/src/bin/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/src/bin/Makefile 2011-05-02 18:20:49.697284900 -0400
@@ -13,8 +13,7 @@
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
-SUBDIRS = initdb pg_ctl pg_dump \
- psql scripts pg_config pg_controldata pg_resetxlog pg_basebackup
-+SUBDIRS = pg_dump psql scripts pg_config
++SUBDIRS = psql scripts pg_config
ifeq ($(PORTNAME), win32)
SUBDIRS+=pgevent
endif
diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
---- a/src/include/pg_config_manual.h 2011-03-28 09:42:09.000000000 -0400
-+++ b/src/include/pg_config_manual.h 2011-03-29 20:26:50.973579851 -0400
+--- a/src/include/pg_config_manual.h 2011-04-27 17:17:22.000000000 -0400
++++ b/src/include/pg_config_manual.h 2011-05-02 18:21:59.197640542 -0400
@@ -141,7 +141,7 @@
* here's where to twiddle it. You can also override this at runtime
* with the postmaster's -k switch.
diff --git a/regress.patch b/regress.patch
index a42ed7e..cf706a6 100644
--- a/regress.patch
+++ b/regress.patch
@@ -1,7 +1,7 @@
diff -Naur a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
---- a/src/test/regress/pg_regress.c 2011-03-09 09:19:24.000000000 -0500
-+++ b/src/test/regress/pg_regress.c 2011-03-18 22:07:11.104847001 -0400
-@@ -803,7 +803,7 @@
+--- a/src/test/regress/pg_regress.c 2011-04-27 17:17:22.000000000 -0400
++++ b/src/test/regress/pg_regress.c 2011-05-02 19:01:20.470763739 -0400
+@@ -806,7 +806,7 @@
datadir = tmp;
/* psql will be installed into temp-install bindir */
@@ -10,7 +10,7 @@ diff -Naur a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
/*
* Set up shared library paths to include the temp install.
-@@ -901,7 +901,7 @@
+@@ -906,7 +906,7 @@
/* And now we can build and execute the shell command */
snprintf(psql_cmd, sizeof(psql_cmd),
@@ -19,7 +19,7 @@ diff -Naur a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
psqldir ? psqldir : "",
psqldir ? "/" : "",
query_escaped,
-@@ -2178,8 +2178,8 @@
+@@ -2207,8 +2207,8 @@
* Check if there is a postmaster running already.
*/
snprintf(buf2, sizeof(buf2),
@@ -30,7 +30,7 @@ diff -Naur a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
for (i = 0; i < 16; i++)
{
-@@ -2210,7 +2210,7 @@
+@@ -2239,7 +2239,7 @@
*/
header(_("starting postmaster"));
snprintf(buf, sizeof(buf),
@@ -40,8 +40,8 @@ diff -Naur a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
debug ? " -d 5" : "",
hostname ? hostname : "",
diff -Naur a/src/test/regress/pg_regress_main.c b/src/test/regress/pg_regress_main.c
---- a/src/test/regress/pg_regress_main.c 2011-03-09 09:19:24.000000000 -0500
-+++ b/src/test/regress/pg_regress_main.c 2011-03-18 22:10:05.263089001 -0400
+--- a/src/test/regress/pg_regress_main.c 2011-04-27 17:17:22.000000000 -0400
++++ b/src/test/regress/pg_regress_main.c 2011-05-02 19:02:23.571086780 -0400
@@ -64,7 +64,7 @@
"%s ", launcher);
diff --git a/server.patch b/server.patch
index d2703f1..f3bc148 100644
--- a/server.patch
+++ b/server.patch
@@ -1,6 +1,6 @@
diff -Naur a/GNUmakefile.in b/GNUmakefile.in
---- a/GNUmakefile.in 2011-03-09 09:19:24.000000000 -0500
-+++ b/GNUmakefile.in 2011-03-18 19:17:04.815898001 -0400
+--- a/GNUmakefile.in 2011-04-27 17:17:22.000000000 -0400
++++ b/GNUmakefile.in 2011-05-02 18:32:41.400926770 -0400
@@ -8,7 +8,7 @@
top_builddir = .
include $(top_builddir)/src/Makefile.global
@@ -34,8 +34,8 @@ diff -Naur a/GNUmakefile.in b/GNUmakefile.in
$(call recurse,distprep,doc src config contrib)
diff -Naur a/contrib/Makefile b/contrib/Makefile
---- a/contrib/Makefile 2011-03-09 09:19:24.000000000 -0500
-+++ b/contrib/Makefile 2011-03-18 19:10:24.415898001 -0400
+--- a/contrib/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/contrib/Makefile 2011-05-02 18:34:03.901348935 -0400
@@ -26,7 +26,6 @@
isn \
lo \
@@ -63,8 +63,8 @@ diff -Naur a/contrib/Makefile b/contrib/Makefile
ifeq ($(with_openssl),yes)
SUBDIRS += sslinfo
diff -Naur a/contrib/adminpack/Makefile b/contrib/adminpack/Makefile
---- a/contrib/adminpack/Makefile 2011-03-09 09:19:24.000000000 -0500
-+++ b/contrib/adminpack/Makefile 2011-03-18 19:08:19.375898001 -0400
+--- a/contrib/adminpack/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/contrib/adminpack/Makefile 2011-05-02 18:35:24.991763884 -0400
@@ -2,7 +2,7 @@
MODULE_big = adminpack
@@ -75,8 +75,8 @@ diff -Naur a/contrib/adminpack/Makefile b/contrib/adminpack/Makefile
EXTENSION = adminpack
DATA = adminpack--1.0.sql
diff -Naur a/contrib/dblink/Makefile b/contrib/dblink/Makefile
---- a/contrib/dblink/Makefile 2011-03-09 09:19:24.000000000 -0500
-+++ b/contrib/dblink/Makefile 2011-03-18 19:09:04.655898001 -0400
+--- a/contrib/dblink/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/contrib/dblink/Makefile 2011-05-02 18:36:02.701956851 -0400
@@ -2,7 +2,7 @@
MODULE_big = dblink
@@ -87,13 +87,12 @@ diff -Naur a/contrib/dblink/Makefile b/contrib/dblink/Makefile
SHLIB_PREREQS = submake-libpq
diff -Naur a/contrib/uuid-ossp/Makefile b/contrib/uuid-ossp/Makefile
---- a/contrib/uuid-ossp/Makefile 2011-03-09 09:19:24.000000000 -0500
-+++ b/contrib/uuid-ossp/Makefile 2011-03-18 19:11:40.055898001 -0400
-@@ -1,12 +1,14 @@
+--- a/contrib/uuid-ossp/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/contrib/uuid-ossp/Makefile 2011-05-02 18:38:24.893721477 -0400
+@@ -1,12 +1,12 @@
# contrib/uuid-ossp/Makefile
-
+-
+PG_CPPFLAGS += "-DHAVE_OSSP_UUID_H"
-+
MODULE_big = uuid-ossp
OBJS = uuid-ossp.o
@@ -106,21 +105,22 @@ diff -Naur a/contrib/uuid-ossp/Makefile b/contrib/uuid-ossp/Makefile
ifdef USE_PGXS
PG_CONFIG = pg_config
diff -Naur a/contrib/xml2/Makefile b/contrib/xml2/Makefile
---- a/contrib/xml2/Makefile 2011-03-09 09:19:24.000000000 -0500
-+++ b/contrib/xml2/Makefile 2011-03-18 19:13:29.625898001 -0400
-@@ -8,7 +8,8 @@
+--- a/contrib/xml2/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/contrib/xml2/Makefile 2011-05-02 18:41:30.824673350 -0400
+@@ -7,8 +7,8 @@
+ DATA = xml2--1.0.sql xml2--unpackaged--1.0.sql
REGRESS = xml2
-
+-
-SHLIB_LINK += $(filter -lxslt, $(LIBS)) $(filter -lxml2, $(LIBS))
-+PG_CPPFLAGS = $(shell xml2-config --cflags)
++PG_CPPFLAGS = $(shell xml2-config --cflags)
+SHLIB_LINK += $(shell xml2-config --libs) $(shell xslt-config --libs)
ifdef USE_PGXS
PG_CONFIG = pg_config
diff -Naur a/src/Makefile b/src/Makefile
---- a/src/Makefile 2011-03-09 09:19:24.000000000 -0500
-+++ b/src/Makefile 2011-03-18 19:43:49.633641001 -0400
+--- a/src/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/src/Makefile 2011-05-02 18:43:02.395142144 -0400
@@ -18,12 +18,9 @@
backend \
backend/utils/mb/conversion_procs \
@@ -144,9 +144,9 @@ diff -Naur a/src/Makefile b/src/Makefile
install-local: installdirs-local
$(INSTALL_DATA) Makefile.global '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.global'
diff -Naur a/src/Makefile.global.in b/src/Makefile.global.in
---- a/src/Makefile.global.in 2011-03-09 09:19:24.000000000 -0500
-+++ b/src/Makefile.global.in 2011-03-18 19:59:53.876991001 -0400
-@@ -474,6 +474,7 @@
+--- a/src/Makefile.global.in 2011-04-27 17:17:22.000000000 -0400
++++ b/src/Makefile.global.in 2011-05-02 18:45:16.765830055 -0400
+@@ -480,6 +480,7 @@
LDFLAGS += $(PROFILE)
endif
@@ -155,8 +155,8 @@ diff -Naur a/src/Makefile.global.in b/src/Makefile.global.in
##########################################################################
#
diff -Naur a/src/bin/Makefile b/src/bin/Makefile
---- a/src/bin/Makefile 2011-03-09 09:19:24.000000000 -0500
-+++ b/src/bin/Makefile 2011-03-18 19:29:28.872631001 -0400
+--- a/src/bin/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/src/bin/Makefile 2011-05-02 18:47:05.106384704 -0400
@@ -13,8 +13,7 @@
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
@@ -168,8 +168,8 @@ diff -Naur a/src/bin/Makefile b/src/bin/Makefile
SUBDIRS+=pgevent
endif
diff -Naur a/src/bin/initdb/Makefile b/src/bin/initdb/Makefile
---- a/src/bin/initdb/Makefile 2011-03-09 09:19:24.000000000 -0500
-+++ b/src/bin/initdb/Makefile 2011-03-18 19:27:46.042631001 -0400
+--- a/src/bin/initdb/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/src/bin/initdb/Makefile 2011-05-02 18:48:35.636848175 -0400
@@ -16,7 +16,7 @@
top_builddir = ../../..
include $(top_builddir)/src/Makefile.global
@@ -180,8 +180,8 @@ diff -Naur a/src/bin/initdb/Makefile b/src/bin/initdb/Makefile
OBJS= initdb.o encnames.o pqsignal.o $(WIN32RES)
diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
---- a/src/include/pg_config_manual.h 2011-03-09 09:19:24.000000000 -0500
-+++ b/src/include/pg_config_manual.h 2011-03-18 19:30:57.712631001 -0400
+--- a/src/include/pg_config_manual.h 2011-04-27 17:17:22.000000000 -0400
++++ b/src/include/pg_config_manual.h 2011-05-02 18:49:38.277168861 -0400
@@ -141,7 +141,7 @@
* here's where to twiddle it. You can also override this at runtime
* with the postmaster's -k switch.
@@ -192,8 +192,8 @@ diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
/*
* The random() function is expected to yield values between 0 and
diff -Naur a/src/port/Makefile b/src/port/Makefile
---- a/src/port/Makefile 2011-03-09 09:19:24.000000000 -0500
-+++ b/src/port/Makefile 2011-03-18 20:01:10.986991001 -0400
+--- a/src/port/Makefile 2011-04-27 17:17:22.000000000 -0400
++++ b/src/port/Makefile 2011-05-02 18:50:27.707421919 -0400
@@ -37,11 +37,10 @@
# foo_srv.o and foo.o are both built from foo.c, but only foo.o has -DFRONTEND
OBJS_SRV = $(OBJS:%.o=%_srv.o)