aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'postgresql-9.1alpha4-server.patch')
-rw-r--r--postgresql-9.1alpha4-server.patch210
1 files changed, 210 insertions, 0 deletions
diff --git a/postgresql-9.1alpha4-server.patch b/postgresql-9.1alpha4-server.patch
new file mode 100644
index 0000000..d2703f1
--- /dev/null
+++ b/postgresql-9.1alpha4-server.patch
@@ -0,0 +1,210 @@
+diff -Naur a/GNUmakefile.in b/GNUmakefile.in
+--- a/GNUmakefile.in 2011-03-09 09:19:24.000000000 -0500
++++ b/GNUmakefile.in 2011-03-18 19:17:04.815898001 -0400
+@@ -8,7 +8,7 @@
+ top_builddir = .
+ include $(top_builddir)/src/Makefile.global
+
+-$(call recurse,all install,src config)
++$(call recurse,all install,src)
+
+ all:
+ +@echo "All of PostgreSQL successfully made. Ready to install."
+@@ -16,7 +16,7 @@
+ docs:
+ $(MAKE) -C doc all
+
+-$(call recurse,world,doc src config contrib,all)
++$(call recurse,world,doc src contrib,all)
+ world:
+ +@echo "PostgreSQL, contrib, and documentation successfully made. Ready to install."
+
+@@ -29,11 +29,11 @@
+ install-docs:
+ $(MAKE) -C doc install
+
+-$(call recurse,install-world,doc src config contrib,install)
++$(call recurse,install-world,doc src contrib,install)
+ install-world:
+ +@echo "PostgreSQL, contrib, and documentation installation complete."
+
+-$(call recurse,installdirs uninstall coverage,doc src config)
++$(call recurse,installdirs uninstall coverage,doc src)
+
+ $(call recurse,distprep,doc src config contrib)
+
+diff -Naur a/contrib/Makefile b/contrib/Makefile
+--- a/contrib/Makefile 2011-03-09 09:19:24.000000000 -0500
++++ b/contrib/Makefile 2011-03-18 19:10:24.415898001 -0400
+@@ -26,7 +26,6 @@
+ isn \
+ lo \
+ ltree \
+- oid2name \
+ pageinspect \
+ passwordcheck \
+ pg_archivecleanup \
+@@ -38,7 +37,6 @@
+ pg_trgm \
+ pg_upgrade \
+ pg_upgrade_support \
+- pgbench \
+ pgcrypto \
+ pgrowlocks \
+ pgstattuple \
+@@ -47,8 +45,7 @@
+ tablefunc \
+ test_parser \
+ tsearch2 \
+- unaccent \
+- vacuumlo
++ unaccent
+
+ ifeq ($(with_openssl),yes)
+ SUBDIRS += sslinfo
+diff -Naur a/contrib/adminpack/Makefile b/contrib/adminpack/Makefile
+--- a/contrib/adminpack/Makefile 2011-03-09 09:19:24.000000000 -0500
++++ b/contrib/adminpack/Makefile 2011-03-18 19:08:19.375898001 -0400
+@@ -2,7 +2,7 @@
+
+ MODULE_big = adminpack
+ OBJS = adminpack.o
+-PG_CPPFLAGS = -I$(libpq_srcdir)
++PG_CPPFLAGS = -I$(libpq_srcdir) -I../../src/include/
+
+ EXTENSION = adminpack
+ DATA = adminpack--1.0.sql
+diff -Naur a/contrib/dblink/Makefile b/contrib/dblink/Makefile
+--- a/contrib/dblink/Makefile 2011-03-09 09:19:24.000000000 -0500
++++ b/contrib/dblink/Makefile 2011-03-18 19:09:04.655898001 -0400
+@@ -2,7 +2,7 @@
+
+ MODULE_big = dblink
+ OBJS = dblink.o
+-PG_CPPFLAGS = -I$(libpq_srcdir)
++PG_CPPFLAGS = -I$(libpq_srcdir) -I../../src/include/
+ SHLIB_LINK = $(libpq)
+ SHLIB_PREREQS = submake-libpq
+
+diff -Naur a/contrib/uuid-ossp/Makefile b/contrib/uuid-ossp/Makefile
+--- a/contrib/uuid-ossp/Makefile 2011-03-09 09:19:24.000000000 -0500
++++ b/contrib/uuid-ossp/Makefile 2011-03-18 19:11:40.055898001 -0400
+@@ -1,12 +1,14 @@
+ # contrib/uuid-ossp/Makefile
+
++PG_CPPFLAGS += "-DHAVE_OSSP_UUID_H"
++
+ MODULE_big = uuid-ossp
+ OBJS = uuid-ossp.o
+
+ EXTENSION = uuid-ossp
+ DATA = uuid-ossp--1.0.sql uuid-ossp--unpackaged--1.0.sql
+
+-SHLIB_LINK += $(OSSP_UUID_LIBS)
++SHLIB_LINK += -lossp-uuid
+
+ ifdef USE_PGXS
+ PG_CONFIG = pg_config
+diff -Naur a/contrib/xml2/Makefile b/contrib/xml2/Makefile
+--- a/contrib/xml2/Makefile 2011-03-09 09:19:24.000000000 -0500
++++ b/contrib/xml2/Makefile 2011-03-18 19:13:29.625898001 -0400
+@@ -8,7 +8,8 @@
+
+ REGRESS = xml2
+
+-SHLIB_LINK += $(filter -lxslt, $(LIBS)) $(filter -lxml2, $(LIBS))
++PG_CPPFLAGS = $(shell xml2-config --cflags)
++SHLIB_LINK += $(shell xml2-config --libs) $(shell xslt-config --libs)
+
+ ifdef USE_PGXS
+ PG_CONFIG = pg_config
+diff -Naur a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2011-03-09 09:19:24.000000000 -0500
++++ b/src/Makefile 2011-03-18 19:43:49.633641001 -0400
+@@ -18,12 +18,9 @@
+ backend \
+ backend/utils/mb/conversion_procs \
+ backend/snowball \
+- include \
+- interfaces \
+ backend/replication/libpqwalreceiver \
+ bin \
+ pl \
+- makefiles \
+ test/regress
+
+ # There are too many interdependencies between the subdirectories, so
+@@ -32,7 +29,7 @@
+
+ $(recurse)
+
+-install: install-local
++install:
+
+ install-local: installdirs-local
+ $(INSTALL_DATA) Makefile.global '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.global'
+diff -Naur a/src/Makefile.global.in b/src/Makefile.global.in
+--- a/src/Makefile.global.in 2011-03-09 09:19:24.000000000 -0500
++++ b/src/Makefile.global.in 2011-03-18 19:59:53.876991001 -0400
+@@ -474,6 +474,7 @@
+ LDFLAGS += $(PROFILE)
+ endif
+
++CFLAGS += -I$(top_srcdir)/src/include
+
+ ##########################################################################
+ #
+diff -Naur a/src/bin/Makefile b/src/bin/Makefile
+--- a/src/bin/Makefile 2011-03-09 09:19:24.000000000 -0500
++++ b/src/bin/Makefile 2011-03-18 19:29:28.872631001 -0400
+@@ -13,8 +13,7 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+
+-SUBDIRS = initdb pg_ctl pg_dump \
+- psql scripts pg_config pg_controldata pg_resetxlog pg_basebackup
++SUBDIRS = initdb pg_ctl pg_controldata pg_resetxlog pg_basebackup
+ ifeq ($(PORTNAME), win32)
+ SUBDIRS+=pgevent
+ endif
+diff -Naur a/src/bin/initdb/Makefile b/src/bin/initdb/Makefile
+--- a/src/bin/initdb/Makefile 2011-03-09 09:19:24.000000000 -0500
++++ b/src/bin/initdb/Makefile 2011-03-18 19:27:46.042631001 -0400
+@@ -16,7 +16,7 @@
+ top_builddir = ../../..
+ include $(top_builddir)/src/Makefile.global
+
+-override CPPFLAGS := -DFRONTEND -I$(libpq_srcdir) $(CPPFLAGS)
++override CPPFLAGS := -DFRONTEND -I$(top_srcdir)/src/interfaces/libpq $(CPPFLAGS)
+
+ OBJS= initdb.o encnames.o pqsignal.o $(WIN32RES)
+
+diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
+--- a/src/include/pg_config_manual.h 2011-03-09 09:19:24.000000000 -0500
++++ b/src/include/pg_config_manual.h 2011-03-18 19:30:57.712631001 -0400
+@@ -141,7 +141,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "@GENTOO_PORTAGE_EPREFIX@/var/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
+diff -Naur a/src/port/Makefile b/src/port/Makefile
+--- a/src/port/Makefile 2011-03-09 09:19:24.000000000 -0500
++++ b/src/port/Makefile 2011-03-18 20:01:10.986991001 -0400
+@@ -37,11 +37,10 @@
+ # foo_srv.o and foo.o are both built from foo.c, but only foo.o has -DFRONTEND
+ OBJS_SRV = $(OBJS:%.o=%_srv.o)
+
+-all: libpgport.a libpgport_srv.a
++all: libpgport_srv.a
+
+ # libpgport is needed by some contrib
+-install: all installdirs
+- $(INSTALL_STLIB) libpgport.a '$(DESTDIR)$(libdir)/libpgport.a'
++install:
+
+ installdirs:
+ $(MKDIR_P) '$(DESTDIR)$(libdir)'