summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-7.3.19.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-7.3.19.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-db/postgresql/postgresql-7.3.19.ebuild b/dev-db/postgresql/postgresql-7.3.19.ebuild
index 68b8d69..7e46c54 100644
--- a/dev-db/postgresql/postgresql-7.3.19.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.19.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.19.ebuild,v 1.8 2007/06/24 21:20:59 vapier Exp $
-inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs versionator
+inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs versionator autotools
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 s390 sh sparc x86"
@@ -64,6 +64,7 @@ src_unpack() {
sed -i -e '/^\W\+psql scripts pg_config pg_controldata/ s/pg_config //' src/bin/Makefile
epatch "${FILESDIR}/${P}-cubeparse.patch"
+ epatch "${FILESDIR}/${P}-autoconf.patch"
# Prepare package for future tests
if use test ; then
@@ -74,6 +75,7 @@ src_unpack() {
chown portage "${S}/src/test/regress/tmp_check"
einfo "Tests will be run as user portage."
fi
+ eautoconf
}
src_compile() {
@@ -84,13 +86,7 @@ src_compile() {
CFLAGS="${CFLAGS} $(pkg-config --cflags libxml-2.0)"
LIBS="${LIBS} $(pkg-config --libs libxml-2.0)"
fi
-
- # Detect mips systems properly
- gnuconfig_update
-
- cd "${S}"
-
- ./configure --prefix=/usr \
+ econf --prefix=/usr \
--includedir=/usr/include/postgresql/pgsql \
--sysconfdir=/etc/postgresql \
--mandir=/usr/share/man \