summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libpqxx/libpqxx-2.6.7.ebuild')
-rw-r--r--dev-libs/libpqxx/libpqxx-2.6.7.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-libs/libpqxx/libpqxx-2.6.7.ebuild b/dev-libs/libpqxx/libpqxx-2.6.7.ebuild
index 1673681..5f0421c 100644
--- a/dev-libs/libpqxx/libpqxx-2.6.7.ebuild
+++ b/dev-libs/libpqxx/libpqxx-2.6.7.ebuild
@@ -4,31 +4,36 @@
inherit eutils
+KEYWORDS="~alpha ~amd64 ~hppa ia64 ~ppc ~ppc64 ~sparc ~x86"
+
DESCRIPTION="C++ client API for PostgreSQL. The standard front-end for writing C++ programs that use PostgreSQL. Supersedes older libpq++ interface."
SRC_URI="ftp://thaiopensource.org/software/${PN}/${P}.tar.gz"
HOMEPAGE="http://thaiopensource.org/development/libpqxx/"
-
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86"
IUSE=""
DEPEND="dev-db/libpq"
RDEPEND="${DEPEND}"
src_compile() {
+ cd "${S}"
+
econf --enable-shared || die "econf failed"
emake || die "emake failed"
}
src_install () {
+ cd "${S}"
+
emake DESTDIR="${D}" install || die "emake install failed"
+
dodoc AUTHORS ChangeLog NEWS README* TODO
dohtml -r doc/html/*
}
src_test() {
- ewarn "The tests need a running postgresl server and an existing database!"
+ ewarn "The tests need a running PostgreSQL server and an existing database!"
ewarn "You can set the following environment variables to change the connection parameters:"
ewarn "PGDATABASE (default: username, probably root)"
ewarn "PGHOST (default: localhost)"