summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-09-22 12:41:05 -0400
committerMike Gilbert <floppym@gentoo.org>2014-09-22 12:41:05 -0400
commitde019a7b17464bdba06fc7968bc361b06bc757f9 (patch)
treea52375240dd886aa4c36e25ac2844fd63b5225ff
parentUpdates for 2.7.7, thanks to Arfrever. (diff)
downloadpython-gentoo-patches-2.7.8.tar.gz
python-gentoo-patches-2.7.8.tar.bz2
python-gentoo-patches-2.7.8.zip
Updates from Arfrever's 2.7-20140921 patchset.2.7.8-02.7.8
-rw-r--r--patches/01_all_static_library_location.patch4
-rw-r--r--patches/02_all_disable_modules_and_ssl.patch8
-rw-r--r--patches/03_all_libdir.patch53
-rw-r--r--patches/04_all_non-zero_exit_status_on_failure.patch2
-rw-r--r--patches/05_all_loadable_sqlite_extensions.patch4
-rw-r--r--patches/06_all_regenerate_platform-specific_modules.patch8
-rw-r--r--patches/21_all_distutils_c++.patch8
-rw-r--r--patches/24_all_tests_environment.patch10
-rw-r--r--patches/61_all_process_data.patch6
9 files changed, 77 insertions, 26 deletions
diff --git a/patches/01_all_static_library_location.patch b/patches/01_all_static_library_location.patch
index ed5757e..378c6dd 100644
--- a/patches/01_all_static_library_location.patch
+++ b/patches/01_all_static_library_location.patch
@@ -4,7 +4,7 @@ http://bugs.python.org/issue6103
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -892,6 +892,19 @@
+@@ -902,6 +902,19 @@
fi; \
else true; \
fi
@@ -24,7 +24,7 @@ http://bugs.python.org/issue6103
# Install the versioned manual page
altmaninstall:
-@@ -1088,18 +1101,6 @@
+@@ -1098,18 +1111,6 @@
else true; \
fi; \
done
diff --git a/patches/02_all_disable_modules_and_ssl.patch b/patches/02_all_disable_modules_and_ssl.patch
index e8e58e0..c8b0ac8 100644
--- a/patches/02_all_disable_modules_and_ssl.patch
+++ b/patches/02_all_disable_modules_and_ssl.patch
@@ -28,7 +28,7 @@
# Ensure that /usr/local is always used
if not cross_compiling:
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
-@@ -791,7 +803,7 @@
+@@ -793,7 +805,7 @@
ssl_incs = find_file('openssl/ssl.h', inc_dirs,
search_for_ssl_incs_in
)
@@ -37,7 +37,7 @@
krb5_h = find_file('krb5.h', inc_dirs,
['/usr/kerberos/include'])
if krb5_h:
-@@ -802,7 +814,8 @@
+@@ -804,7 +816,8 @@
] )
if (ssl_incs is not None and
@@ -47,7 +47,7 @@
exts.append( Extension('_ssl', ['_ssl.c'],
include_dirs = ssl_incs,
library_dirs = ssl_libs,
-@@ -834,7 +847,7 @@
+@@ -836,7 +849,7 @@
pass
min_openssl_ver = 0x00907000
@@ -56,7 +56,7 @@
have_usable_openssl = (have_any_openssl and
openssl_ver >= min_openssl_ver)
-@@ -850,21 +863,20 @@
+@@ -852,21 +865,20 @@
print ("warning: openssl 0x%08x is too old for _hashlib" %
openssl_ver)
missing.append('_hashlib')
diff --git a/patches/03_all_libdir.patch b/patches/03_all_libdir.patch
index d8209b2..86bd419 100644
--- a/patches/03_all_libdir.patch
+++ b/patches/03_all_libdir.patch
@@ -137,6 +137,15 @@
#
--- setup.py
+++ setup.py
+@@ -450,7 +450,7 @@
+ global disable_ssl
+ # Ensure that /usr/local is always used
+ if not cross_compiling:
+- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
++ add_dir_to_list(self.compiler.library_dirs, '/usr/local/@@GENTOO_LIBDIR@@')
+ add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+ if cross_compiling:
+ self.add_gcc_paths()
@@ -517,8 +517,7 @@
):
add_dir_to_list(inc_dirs, d)
@@ -147,7 +156,7 @@
):
add_dir_to_list(lib_dirs, d)
exts = []
-@@ -770,11 +769,11 @@
+@@ -772,11 +771,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -161,3 +170,45 @@
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
+@@ -1042,8 +1041,7 @@
+
+ # check lib directories parallel to the location of the header
+ db_dirs_to_check = [
+- db_incdir.replace("include", 'lib64'),
+- db_incdir.replace("include", 'lib'),
++ db_incdir.replace("include", '@@GENTOO_LIBDIR@@'),
+ ]
+
+ if host_platform != 'darwin':
+@@ -1156,10 +1154,8 @@
+
+ if sqlite_incdir:
+ sqlite_dirs_to_check = [
+- os.path.join(sqlite_incdir, '..', 'lib64'),
+- os.path.join(sqlite_incdir, '..', 'lib'),
+- os.path.join(sqlite_incdir, '..', '..', 'lib64'),
+- os.path.join(sqlite_incdir, '..', '..', 'lib'),
++ os.path.join(sqlite_incdir, '..', '@@GENTOO_LIBDIR@@'),
++ os.path.join(sqlite_incdir, '..', '..', '@@GENTOO_LIBDIR@@'),
+ ]
+ sqlite_libfile = self.compiler.find_library_file(
+ sqlite_dirs_to_check + lib_dirs, 'sqlite3')
+@@ -1931,15 +1927,14 @@
+ added_lib_dirs.append('/usr/openwin/lib')
+ elif os.path.exists('/usr/X11R6/include'):
+ include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
++ added_lib_dirs.append('/usr/X11R6/@@GENTOO_LIBDIR@@')
+ elif os.path.exists('/usr/X11R5/include'):
+ include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
++ added_lib_dirs.append('/usr/X11R5/@@GENTOO_LIBDIR@@')
+ else:
+ # Assume default location for X11
+ include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
++ added_lib_dirs.append('/usr/X11/@@GENTOO_LIBDIR@@')
+
+ # If Cygwin, then verify that X is installed before proceeding
+ if host_platform == 'cygwin':
diff --git a/patches/04_all_non-zero_exit_status_on_failure.patch b/patches/04_all_non-zero_exit_status_on_failure.patch
index e233c29..88e0f2f 100644
--- a/patches/04_all_non-zero_exit_status_on_failure.patch
+++ b/patches/04_all_non-zero_exit_status_on_failure.patch
@@ -21,7 +21,7 @@ http://bugs.python.org/issue6731
failed = self.failed[:]
print
print "Failed to build these modules:"
-@@ -2241,6 +2245,7 @@
+@@ -2239,6 +2243,7 @@
'Tools/scripts/2to3',
'Lib/smtpd.py']
)
diff --git a/patches/05_all_loadable_sqlite_extensions.patch b/patches/05_all_loadable_sqlite_extensions.patch
index c473f95..b5f0f2b 100644
--- a/patches/05_all_loadable_sqlite_extensions.patch
+++ b/patches/05_all_loadable_sqlite_extensions.patch
@@ -3,7 +3,7 @@ http://bugs.python.org/issue10268
--- configure.ac
+++ configure.ac
-@@ -2310,6 +2310,15 @@
+@@ -2326,6 +2326,15 @@
TCLTK_LIBS="$with_tcltk_libs"
fi
@@ -21,7 +21,7 @@ http://bugs.python.org/issue10268
AC_ARG_WITH(dbmliborder,
--- setup.py
+++ setup.py
-@@ -1184,8 +1184,10 @@
+@@ -1183,8 +1183,10 @@
else:
sqlite_defines.append(('MODULE_NAME', '\\"sqlite3\\"'))
diff --git a/patches/06_all_regenerate_platform-specific_modules.patch b/patches/06_all_regenerate_platform-specific_modules.patch
index cdec0e5..82a5346 100644
--- a/patches/06_all_regenerate_platform-specific_modules.patch
+++ b/patches/06_all_regenerate_platform-specific_modules.patch
@@ -46,7 +46,7 @@ http://bugs.python.org/issue12619
# Compile a binary with gcc profile guided optimization.
profile-opt:
-@@ -463,6 +463,32 @@
+@@ -473,6 +473,32 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -79,7 +79,7 @@ http://bugs.python.org/issue12619
# Build static library
# avoid long command lines, same as LIBRARY_OBJS
$(LIBRARY): $(LIBRARY_OBJS)
-@@ -962,7 +988,7 @@
+@@ -972,7 +998,7 @@
unittest unittest/test \
lib-old \
curses pydoc_data $(MACHDEPS)
@@ -88,7 +88,7 @@ http://bugs.python.org/issue12619
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
if test ! -d $(DESTDIR)$$i; then \
-@@ -1045,23 +1071,6 @@
+@@ -1055,23 +1081,6 @@
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
@@ -112,7 +112,7 @@ http://bugs.python.org/issue12619
python-config: $(srcdir)/Misc/python-config.in
# Substitution happens here, as the completely-expanded BINDIR
# is not available in configure
-@@ -1354,7 +1363,7 @@
+@@ -1365,7 +1374,7 @@
Python/thread.o: @THREADHEADERS@
# Declare targets that aren't real files
diff --git a/patches/21_all_distutils_c++.patch b/patches/21_all_distutils_c++.patch
index c38dc47..5496a5d 100644
--- a/patches/21_all_distutils_c++.patch
+++ b/patches/21_all_distutils_c++.patch
@@ -91,7 +91,7 @@ http://bugs.python.org/issue1222585
--- Lib/distutils/sysconfig.py
+++ Lib/distutils/sysconfig.py
-@@ -170,10 +170,12 @@
+@@ -171,10 +171,12 @@
_osx_support.customize_compiler(_config_vars)
_config_vars['CUSTOMIZED_OSX_COMPILER'] = 'True'
@@ -108,7 +108,7 @@ http://bugs.python.org/issue1222585
if 'CC' in os.environ:
newcc = os.environ['CC']
-@@ -188,19 +190,27 @@
+@@ -189,19 +191,27 @@
cxx = os.environ['CXX']
if 'LDSHARED' in os.environ:
ldshared = os.environ['LDSHARED']
@@ -137,7 +137,7 @@ http://bugs.python.org/issue1222585
if 'AR' in os.environ:
ar = os.environ['AR']
if 'ARFLAGS' in os.environ:
-@@ -209,13 +219,17 @@
+@@ -210,13 +220,17 @@
archiver = ar + ' ' + ar_flags
cc_cmd = cc + ' ' + cflags
@@ -262,7 +262,7 @@ http://bugs.python.org/issue1222585
_INITPRE = '_OSX_SUPPORT_INITIAL_'
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -459,7 +459,7 @@
+@@ -469,7 +469,7 @@
*\ -s*|s*) quiet="-q";; \
*) quiet="";; \
esac; \
diff --git a/patches/24_all_tests_environment.patch b/patches/24_all_tests_environment.patch
index b00853a..63c420e 100644
--- a/patches/24_all_tests_environment.patch
+++ b/patches/24_all_tests_environment.patch
@@ -74,7 +74,7 @@ http://bugs.python.org/issue1674555
def accumulate_result(test, result):
ok, test_time = result
test_times.append((test_time, test))
-@@ -485,19 +529,13 @@
+@@ -489,19 +533,13 @@
print "Multiprocess option requires thread support"
sys.exit(2)
from Queue import Queue
@@ -96,7 +96,7 @@ http://bugs.python.org/issue1674555
def work():
# A worker thread.
try:
-@@ -560,15 +598,15 @@
+@@ -571,15 +609,15 @@
if trace:
# If we're tracing code coverage, then we don't exit with status
# if on a false return value from main.
@@ -115,7 +115,7 @@ http://bugs.python.org/issue1674555
except KeyboardInterrupt:
interrupted = True
break
-@@ -638,7 +676,7 @@
+@@ -649,7 +687,7 @@
sys.stdout.flush()
try:
test_support.verbose = True
@@ -124,7 +124,7 @@ http://bugs.python.org/issue1674555
except KeyboardInterrupt:
# print a newline separate from the ^C
print
-@@ -847,8 +885,9 @@
+@@ -858,8 +896,9 @@
for name, get, restore in self.resource_info():
current = get()
original = saved_values.pop(name)
@@ -158,7 +158,7 @@ http://bugs.python.org/issue1674555
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -794,7 +794,7 @@
+@@ -804,7 +804,7 @@
TESTOPTS= -l $(EXTRATESTOPTS)
TESTPROG= $(srcdir)/Lib/test/regrtest.py
diff --git a/patches/61_all_process_data.patch b/patches/61_all_process_data.patch
index a7865af..11b697c 100644
--- a/patches/61_all_process_data.patch
+++ b/patches/61_all_process_data.patch
@@ -85,7 +85,7 @@ python_generate_wrapper_scripts() to check if Python supports GENTOO_PYTHON_TARG
}
--- Python/sysmodule.c
+++ Python/sysmodule.c
-@@ -1564,6 +1564,10 @@
+@@ -1573,6 +1573,10 @@
makeargvobject(int argc, char **argv)
{
PyObject *av;
@@ -96,7 +96,7 @@ python_generate_wrapper_scripts() to check if Python supports GENTOO_PYTHON_TARG
if (argc <= 0 || argv == NULL) {
/* Ensure at least one (empty) argument is seen */
static char *empty_argv[1] = {""};
-@@ -1588,7 +1592,11 @@
+@@ -1597,7 +1601,11 @@
} else
v = PyString_FromString(argv[i]);
#else
@@ -109,7 +109,7 @@ python_generate_wrapper_scripts() to check if Python supports GENTOO_PYTHON_TARG
#endif
if (v == NULL) {
Py_DECREF(av);
-@@ -1616,7 +1624,15 @@
+@@ -1625,7 +1633,15 @@
if (PySys_SetObject("argv", av) != 0)
Py_FatalError("can't assign sys.argv");
if (updatepath && path != NULL) {