aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-08-09 10:55:39 +0200
committerMichał Górny <mgorny@gentoo.org>2015-08-09 10:55:39 +0200
commitd38b4629fa719079ed08b93cab0ad75aed1cf9f1 (patch)
tree4796e232411a9455b0c6fd10a71a5aa69109d951 /dev-lang
parentdev-lang/python: Import 3.2 along with patches and bump to 3.2.6 (diff)
downloadpython-d38b4629fa719079ed08b93cab0ad75aed1cf9f1.tar.gz
python-d38b4629fa719079ed08b93cab0ad75aed1cf9f1.tar.bz2
python-d38b4629fa719079ed08b93cab0ad75aed1cf9f1.zip
dev-lang/python:3.2: some more cleanup
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.2.6.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-lang/python/python-3.2.6.ebuild b/dev-lang/python/python-3.2.6.ebuild
index cf91e29..456ac47 100644
--- a/dev-lang/python/python-3.2.6.ebuild
+++ b/dev-lang/python/python-3.2.6.ebuild
@@ -9,7 +9,6 @@ WANT_LIBTOOL="none"
inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs multiprocessing
MY_P="Python-${PV}"
-PATCHSET_REVISION="1"
DESCRIPTION="An interpreted, interactive, object-oriented programming language"
HOMEPAGE="http://www.python.org/"
@@ -65,7 +64,7 @@ src_prepare() {
fi
EPATCH_EXCLUDE="${excluded_patches}" EPATCH_SUFFIX="patch" \
- epatch "${FILESDIR}/3.2"
+ epatch "${FILESDIR}/${SLOT}"
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \
@@ -135,7 +134,7 @@ src_configure() {
if tc-is-cross-compiler; then
(
- multijob_child_init
+ multijob_child_init
cd "${WORKDIR}"/${CBUILD} >/dev/null || die
OPT="-O1" CFLAGS="" CPPFLAGS="" LDFLAGS="" CC="" \
"${S}"/configure \
@@ -165,7 +164,7 @@ src_configure() {
dbmliborder+="${dbmliborder:+:}gdbm"
fi
- cd "${WORKDIR}"/${CHOST}
+ cd "${WORKDIR}"/${CHOST} || die
ECONF_SOURCE=${S} OPT="" \
econf \
--with-fpectl \
@@ -281,9 +280,6 @@ src_install() {
-e "s/\(PY_LDFLAGS=\).*/\1/" \
-i "${libdir}/config-${SLOT}/Makefile" || die "sed failed"
- # Backwards compat with Gentoo divergence.
- dosym python${SLOT}-config /usr/bin/python-config-${SLOT}
-
# Fix collisions between different slots of Python.
rm "${ED}usr/$(get_libdir)/libpython3.so" || die