aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-12 14:29:14 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-12 14:29:14 +0100
commit82f5d6171796773d32ccca98365228433e8a8bca (patch)
tree2234562b9f01de82dd94f09730824d9477621c65 /Makefile.gpyutils
parentBump pkgcheck2html (diff)
downloadqa-scripts-82f5d6171796773d32ccca98365228433e8a8bca.tar.gz
qa-scripts-82f5d6171796773d32ccca98365228433e8a8bca.tar.bz2
qa-scripts-82f5d6171796773d32ccca98365228433e8a8bca.zip
gpyutils: Add py3.7 to 3.8 reports
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'Makefile.gpyutils')
-rw-r--r--Makefile.gpyutils12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
index 15a4a12..30e6ce5 100644
--- a/Makefile.gpyutils
+++ b/Makefile.gpyutils
@@ -6,7 +6,7 @@ timestamp = $(PORTDIR)/metadata/timestamp.commit
outdir = /dev/null
# upgrades for stable impls
-upgr_base = $(outdir)/35-to-36.txt $(outdir)/36-to-37.txt
+upgr_base = $(outdir)/35-to-36.txt $(outdir)/36-to-37.txt $(outdir)/37-to-38.txt
# related stabilizations
upgr_streq = $(patsubst %.txt,%-stablereq.txt,$(upgr_base))
# all upgrade stuff
@@ -59,6 +59,16 @@ $(outdir)/36-to-37-stablereq.txt: $(timestamp)
gpy-upgrade-impl -s python3_6 python3_7 > $@.new
mv $@.new $@
+$(outdir)/37-to-38.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl python3_7 python3_8 > $@.new
+ mv $@.new $@
+
+$(outdir)/37-to-38-stablereq.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -s python3_7 python3_8 > $@.new
+ mv $@.new $@
+
$(outdir)/pypy3-to-36.txt: $(timestamp)
mkdir -p $(outdir)
gpy-upgrade-impl pypy3 python3_6 > $@.new