aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuiz Capitulino <lcapitulino@redhat.com>2009-08-28 15:27:29 -0300
committerAnthony Liguori <aliguori@us.ibm.com>2009-09-04 09:37:33 -0500
commit33837ba6c5aa53c4ae4c0d2ffc66475b92d0da46 (patch)
tree5fdedad5f55cf86b11641ad6ba04dcdd55a3a27a
parentAdd check support (diff)
downloadqemu-kvm-33837ba6c5aa53c4ae4c0d2ffc66475b92d0da46.tar.gz
qemu-kvm-33837ba6c5aa53c4ae4c0d2ffc66475b92d0da46.tar.bz2
qemu-kvm-33837ba6c5aa53c4ae4c0d2ffc66475b92d0da46.zip
Introduce QInt unit-tests
This suite contains tests to assure that QInt API works as expected. To execute it you should have check installed and build QEMU with check support enabled (--enable-check-utests) and then run: $ ./check-qint Signed-off-by: Luiz Capitulino <lcapitulino@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
-rw-r--r--Makefile2
-rw-r--r--check-qint.c110
-rwxr-xr-xconfigure2
3 files changed, 113 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 983fe39a9..d08df6c52 100644
--- a/Makefile
+++ b/Makefile
@@ -181,6 +181,8 @@ qemu-io$(EXESUF): qemu-io.o qemu-tool.o cmd.o $(block-obj-y)
qemu-img-cmds.h: $(SRC_PATH)/qemu-img-cmds.hx
$(call quiet-command,sh $(SRC_PATH)/hxtool -h < $< > $@," GEN $@")
+check-qint: check-qint.o qint.o qemu-malloc.o
+
clean:
# avoid old build problems by removing potentially incorrect old files
rm -f config.mak config.h op-i386.h opc-i386.h gen-op-i386.h op-arm.h opc-arm.h gen-op-arm.h
diff --git a/check-qint.c b/check-qint.c
new file mode 100644
index 000000000..ae5d22f7e
--- /dev/null
+++ b/check-qint.c
@@ -0,0 +1,110 @@
+/*
+ * QInt unit-tests.
+ *
+ * Copyright (C) 2009 Red Hat Inc.
+ *
+ * Authors:
+ * Luiz Capitulino <lcapitulino@redhat.com>
+ */
+#include <check.h>
+
+#include "qint.h"
+#include "qemu-common.h"
+
+/*
+ * Public Interface test-cases
+ *
+ * (with some violations to access 'private' data)
+ */
+
+START_TEST(qint_from_int_test)
+{
+ QInt *qi;
+ const int value = -42;
+
+ qi = qint_from_int(value);
+ fail_unless(qi != NULL);
+ fail_unless(qi->value == value);
+ fail_unless(qi->base.refcnt == 1);
+ fail_unless(qobject_type(QOBJECT(qi)) == QTYPE_QINT);
+
+ // destroy doesn't exit yet
+ qemu_free(qi);
+}
+END_TEST
+
+START_TEST(qint_destroy_test)
+{
+ QInt *qi = qint_from_int(0);
+ QDECREF(qi);
+}
+END_TEST
+
+START_TEST(qint_from_int64_test)
+{
+ QInt *qi;
+ const int64_t value = 0xffffffffffffffff;
+
+ qi = qint_from_int(value);
+ fail_unless(qi->value == value);
+
+ QDECREF(qi);
+}
+END_TEST
+
+START_TEST(qint_get_int_test)
+{
+ QInt *qi;
+ const int value = 123456;
+
+ qi = qint_from_int(value);
+ fail_unless(qint_get_int(qi) == value);
+
+ QDECREF(qi);
+}
+END_TEST
+
+START_TEST(qobject_to_qint_test)
+{
+ QInt *qi;
+
+ qi = qint_from_int(0);
+ fail_unless(qobject_to_qint(QOBJECT(qi)) == qi);
+
+ QDECREF(qi);
+}
+END_TEST
+
+static Suite *qint_suite(void)
+{
+ Suite *s;
+ TCase *qint_public_tcase;
+
+ s = suite_create("QInt test-suite");
+
+ qint_public_tcase = tcase_create("Public Interface");
+ suite_add_tcase(s, qint_public_tcase);
+ tcase_add_test(qint_public_tcase, qint_from_int_test);
+ tcase_add_test(qint_public_tcase, qint_destroy_test);
+ tcase_add_test(qint_public_tcase, qint_from_int64_test);
+ tcase_add_test(qint_public_tcase, qint_get_int_test);
+ tcase_add_test(qint_public_tcase, qobject_to_qint_test);
+
+ return s;
+}
+
+int main(void)
+{
+ int nf;
+ Suite *s;
+ SRunner *sr;
+
+ s = qint_suite();
+ sr = srunner_create(s);
+
+ srunner_run_all(sr, CK_NORMAL);
+ nf = srunner_ntests_failed(sr);
+ srunner_free(sr);
+
+ return (nf == 0) ? EXIT_SUCCESS : EXIT_FAILURE;
+}
diff --git a/configure b/configure
index 92d29c9d3..248cc0b7c 100755
--- a/configure
+++ b/configure
@@ -1927,7 +1927,7 @@ if test `expr "$target_list" : ".*softmmu.*"` != 0 ; then
if [ "$linux" = "yes" ] ; then
tools="qemu-nbd\$(EXESUF) qemu-io\$(EXESUF) $tools"
if [ "$check_utests" = "yes" ]; then
- tools="$tools"
+ tools="check-qint $tools"
fi
fi
fi