aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCorentin Chary <corentincj@iksaif.net>2010-07-07 20:57:58 +0200
committerAnthony Liguori <aliguori@us.ibm.com>2010-07-26 17:36:14 -0500
commit5136a0526989fdfd8799ae4e29ff43d5b80ee37e (patch)
treedb123aaff5757a8155c4a1808c0558c8eb7fc9c1 /Makefile.objs
parentvnc: tight: specific zlib level and filters for each compression level (diff)
downloadqemu-kvm-5136a0526989fdfd8799ae4e29ff43d5b80ee37e.tar.gz
qemu-kvm-5136a0526989fdfd8799ae4e29ff43d5b80ee37e.tar.bz2
qemu-kvm-5136a0526989fdfd8799ae4e29ff43d5b80ee37e.zip
vnc: tight: stop using qdict for palette stuff
Profiling with callgrind seems to show that a lot of time is spent in the palette code (mostly due to memory allocation and qdict to int conversion). This patch adds a VncPalette implementation. The palette is stored in a hash table, like qdict, but which does way less memory allocations, and doesn't suffer from the QObject overhead. Signed-off-by: Corentin Chary <corentincj@iksaif.net> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile.objs')
-rw-r--r--Makefile.objs2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.objs b/Makefile.objs
index a0b820043..bb9806c75 100644
--- a/Makefile.objs
+++ b/Makefile.objs
@@ -107,7 +107,7 @@ ui-obj-$(CONFIG_SDL) += sdl.o sdl_zoom.o x_keymap.o
ui-obj-$(CONFIG_CURSES) += curses.o
ui-obj-y += vnc.o d3des.o
ui-obj-y += vnc-enc-zlib.o vnc-enc-hextile.o
-ui-obj-y += vnc-enc-tight.o
+ui-obj-y += vnc-enc-tight.o vnc-palette.o
ui-obj-$(CONFIG_VNC_TLS) += vnc-tls.o vnc-auth-vencrypt.o
ui-obj-$(CONFIG_VNC_SASL) += vnc-auth-sasl.o
ui-obj-$(CONFIG_COCOA) += cocoa.o