aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael S. Tsirkin <mst@redhat.com>2009-08-10 22:30:24 +0300
committerAnthony Liguori <aliguori@us.ibm.com>2009-08-24 08:46:47 -0500
commit3987e1cf6db2ce530e0b01ae120933b6cca28b90 (patch)
treeba977ed0f8ef0151ca65f40d10378d7d58df67fc /Makefile.target
parentchar: Emit 'CLOSED' events on char device close (diff)
downloadqemu-kvm-3987e1cf6db2ce530e0b01ae120933b6cca28b90.tar.gz
qemu-kvm-3987e1cf6db2ce530e0b01ae120933b6cca28b90.tar.bz2
qemu-kvm-3987e1cf6db2ce530e0b01ae120933b6cca28b90.zip
qemu: move virtio-pci.o to near pci.o
virtio-pci depends, and will always depend, on pci.c so it makes sense to keep it in the same makefile, (unlike the rest of virtio files which should eventually be moved out to Makefile.hw). Signed-off-by: Michael S. Tsirkin <mst@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile.target')
-rw-r--r--Makefile.target2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.target b/Makefile.target
index ed948409d..690f30b25 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -152,7 +152,7 @@ obj-y = vl.o monitor.o pci.o loader.o isa_mmio.o machine.o \
gdbstub.o gdbstub-xml.o msix.o ioport.o qemu-config.o
# virtio has to be here due to weird dependency between PCI and virtio-net.
# need to fix this properly
-obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o
+obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o virtio-pci.o
obj-$(CONFIG_KVM) += kvm.o kvm-all.o
LIBS+=-lz