summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBlue Swirl <blauwirbel@gmail.com>2009-09-25 19:20:00 +0000
committerBlue Swirl <blauwirbel@gmail.com>2009-09-25 19:21:06 +0000
commit3f600fa030cf4b8a7adccd3b3d3e9353e37e0915 (patch)
treece417dba4dcaf02316c551c71237f8e751066140 /Makefile.target
parentfix use after free (diff)
downloadqemu-kvm-3f600fa030cf4b8a7adccd3b3d3e9353e37e0915.tar.gz
qemu-kvm-3f600fa030cf4b8a7adccd3b3d3e9353e37e0915.tar.bz2
qemu-kvm-3f600fa030cf4b8a7adccd3b3d3e9353e37e0915.zip
Revert "This files are compiled in libqemu.a now"
This reverts commit fe6549dfd76c278dbcd788b3c15c5e6e5ed32190. tcg-runtime and host-utils are needed on 32 bit host and they are not part of libqemu.a. Thanks to Stefan Weil for reporting. Signed-off-by: Blue Swirl <blauwirbel@gmail.com>
Diffstat (limited to 'Makefile.target')
-rw-r--r--Makefile.target3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.target b/Makefile.target
index 4c4590746..a807f27e8 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -83,6 +83,7 @@ QEMU_CFLAGS+=-I$(SRC_PATH)/linux-user -I$(SRC_PATH)/linux-user/$(TARGET_ABI_DIR)
obj-y = main.o syscall.o strace.o mmap.o signal.o thunk.o \
elfload.o linuxload.o uaccess.o gdbstub.o gdbstub-xml.o
obj-y += envlist.o path.o
+obj-y += tcg-runtime.o host-utils.o
obj-$(TARGET_HAS_BFLT) += flatload.o
obj-$(TARGET_HAS_ELFLOAD32) += elfload32.o
@@ -117,6 +118,7 @@ LIBS+=-lmx
obj-y = main.o commpage.o machload.o mmap.o signal.o syscall.o thunk.o \
gdbstub.o gdbstub-xml.o
obj-y += envlist.o path.o
+obj-y += tcg-runtime.o host-utils.o
obj-i386-y += ioport-user.o
@@ -135,6 +137,7 @@ QEMU_CFLAGS+=-I$(SRC_PATH)/bsd-user -I$(SRC_PATH)/bsd-user/$(TARGET_ARCH)
obj-y = main.o bsdload.o elfload.o mmap.o signal.o strace.o syscall.o \
gdbstub.o gdbstub-xml.o uaccess.o
obj-y += envlist.o path.o
+obj-y += tcg-runtime.o host-utils.o
obj-i386-y += ioport-user.o