aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuan Quintela <quintela@redhat.com>2009-08-03 14:46:55 +0200
committerAnthony Liguori <aliguori@us.ibm.com>2009-08-10 13:05:45 -0500
commit864de24ad3e76e5415e01bcb0c543460def2f285 (patch)
treed11225aaaa5d2c3dbd33f2bca3a3fe7342ae186f /Makefile.target
parentUse only one KVM_CFLAGS (diff)
downloadqemu-kvm-864de24ad3e76e5415e01bcb0c543460def2f285.tar.gz
qemu-kvm-864de24ad3e76e5415e01bcb0c543460def2f285.tar.bz2
qemu-kvm-864de24ad3e76e5415e01bcb0c543460def2f285.zip
Use one less HELPER_CFLAGS
Signed-off-by: Juan Quintela <quintela@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com> Message-Id:
Diffstat (limited to 'Makefile.target')
-rw-r--r--Makefile.target4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.target b/Makefile.target
index 40d5218d3..2f3a13577 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -83,9 +83,7 @@ tcg/tcg.o: cpu.h
# HELPER_CFLAGS is used for all the code compiled with static register
# variables
-op_helper.o: QEMU_CFLAGS += $(HELPER_CFLAGS)
-
-cpu-exec.o: QEMU_CFLAGS += $(HELPER_CFLAGS)
+op_helper.o cpu-exec.o: QEMU_CFLAGS += $(HELPER_CFLAGS)
# Note: this is a workaround. The real fix is to avoid compiling
# cpu_signal_handler() in cpu-exec.c.