aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBlue Swirl <blauwirbel@gmail.com>2009-09-20 14:58:02 +0000
committerBlue Swirl <blauwirbel@gmail.com>2009-09-20 14:58:02 +0000
commitca20cf32ab3d945155141ef737f5d08ebb373e1d (patch)
tree45515350fdf7b5322658095beec591565a78506d /Makefile.target
parentCompile qemu-config only once (diff)
downloadqemu-kvm-ca20cf32ab3d945155141ef737f5d08ebb373e1d.tar.gz
qemu-kvm-ca20cf32ab3d945155141ef737f5d08ebb373e1d.tar.bz2
qemu-kvm-ca20cf32ab3d945155141ef737f5d08ebb373e1d.zip
Compile loader only once
Callers must pass ELF machine, byte swapping and symbol LSB clearing information to ELF loader. A.out loader needs page size information, pass that too as a parameter. Extract prototypes to a separate file. Move loader.[ch] and elf_ops.h under hw. Adjust callers. Also use target_phys_addr_t instead of target_ulong for addresses: loader addresses aren't virtual. Signed-off-by: Blue Swirl <blauwirbel@gmail.com>
Diffstat (limited to 'Makefile.target')
-rw-r--r--Makefile.target2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.target b/Makefile.target
index d9e98fe3c..bc3998a1d 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -155,7 +155,7 @@ endif
# System emulator target
ifdef CONFIG_SOFTMMU
-obj-y = vl.o monitor.o pci.o loader.o isa_mmio.o machine.o \
+obj-y = vl.o monitor.o pci.o isa_mmio.o machine.o \
gdbstub.o gdbstub-xml.o msix.o ioport.o
# virtio has to be here due to weird dependency between PCI and virtio-net.
# need to fix this properly