aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraliguori <aliguori@c046a42c-6fe2-441c-8c8c-71466251a162>2009-04-22 15:19:15 +0000
committeraliguori <aliguori@c046a42c-6fe2-441c-8c8c-71466251a162>2009-04-22 15:19:15 +0000
commitd94f94862015f5f2416a99f2a56583951eee1453 (patch)
tree34cacfd88a305067abeb16c64b3620e95305d8e8 /Makefile.target
parentxen: groundwork for xen support (Gerd Hoffmann) (diff)
downloadqemu-kvm-d94f94862015f5f2416a99f2a56583951eee1453.tar.gz
qemu-kvm-d94f94862015f5f2416a99f2a56583951eee1453.tar.bz2
qemu-kvm-d94f94862015f5f2416a99f2a56583951eee1453.zip
xen: backend driver core (Gerd Hoffmann)
This patch adds infrastructure for xen backend drivers living in qemu, so drivers don't need to implement common stuff on their own. It's mostly xenbus management stuff: some functions to access xentore, setting up xenstore watches, callbacks on device discovery and state changes, handle event channel, ... Signed-off-by: Gerd Hoffmann <kraxel@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com> git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@7220 c046a42c-6fe2-441c-8c8c-71466251a162
Diffstat (limited to 'Makefile.target')
-rw-r--r--Makefile.target2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.target b/Makefile.target
index ab59af34f..52c8cd2b9 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -561,7 +561,7 @@ LIBS += $(CONFIG_BLUEZ_LIBS)
endif
# xen backend driver support
-XEN_OBJS := xen_machine_pv.o
+XEN_OBJS := xen_machine_pv.o xen_backend.o
ifeq ($(CONFIG_XEN), yes)
OBJS += $(XEN_OBJS)
LIBS += $(XEN_LIBS)