aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraurel32 <aurel32@c046a42c-6fe2-441c-8c8c-71466251a162>2008-12-16 10:43:48 +0000
committeraurel32 <aurel32@c046a42c-6fe2-441c-8c8c-71466251a162>2008-12-16 10:43:48 +0000
commitf652e6af11c670da4bbd738a1bca8b4b31ed97b4 (patch)
tree8bb833e6e9198e80f8ba8507e4ec442d0e2823ec /Makefile.target
parenttarget-ppc: create a helper function to allow more flexible RAM allocation fo... (diff)
downloadqemu-kvm-f652e6af11c670da4bbd738a1bca8b4b31ed97b4.tar.gz
qemu-kvm-f652e6af11c670da4bbd738a1bca8b4b31ed97b4.tar.bz2
qemu-kvm-f652e6af11c670da4bbd738a1bca8b4b31ed97b4.zip
Implement device tree support needed for Bamboo emulation
To implement the -kernel, -initrd, and -append options, 4xx board emulation must load the guest kernel as if firmware had loaded it. Where u-boot would be the firmware, we must load the flat device tree into memory and set key fields such as /chosen/bootargs. This patch introduces a dependency on libfdt for flat device tree support. Signed-off-by: Hollis Blanchard <hollisb@us.ibm.com> Signed-off-by: Aurelien Jarno <aurelien@aurel32.net> git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@6064 c046a42c-6fe2-441c-8c8c-71466251a162
Diffstat (limited to 'Makefile.target')
-rw-r--r--Makefile.target4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.target b/Makefile.target
index 8229b4f42..d80ce2cd3 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -655,6 +655,10 @@ OBJS+= heathrow_pic.o grackle_pci.o ppc_oldworld.o
OBJS+= unin_pci.o ppc_chrp.o
# PowerPC 4xx boards
OBJS+= pflash_cfi02.o ppc4xx_devs.o ppc4xx_pci.o ppc405_uc.o ppc405_boards.o
+ifdef FDT_LIBS
+OBJS+= device_tree.o
+LIBS+= $(FDT_LIBS)
+endif
# virtio support
OBJS+= virtio.o virtio-blk.o virtio-balloon.o
endif