aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Henderson <rth@twiddle.net>2010-05-21 10:37:52 -0700
committerAurelien Jarno <aurelien@aurel32.net>2010-05-28 23:27:19 +0200
commit680c877af48cf5f2fb4586f34c13fd21ce33bfec (patch)
treed9a91ece81718eb21ee799ea6ecbf543b521f3e9 /Makefile.target
parentUse calloc in qemu_mallocz. (diff)
downloadqemu-kvm-680c877af48cf5f2fb4586f34c13fd21ce33bfec.tar.gz
qemu-kvm-680c877af48cf5f2fb4586f34c13fd21ce33bfec.tar.bz2
qemu-kvm-680c877af48cf5f2fb4586f34c13fd21ce33bfec.zip
linux-user: Use qemu-malloc.c.
Since we're no longer setting PAGE_RESERVED, there's no need to implement qemu_malloc via mmap. Signed-off-by: Richard Henderson <rth@twiddle.net> Signed-off-by: Aurelien Jarno <aurelien@aurel32.net>
Diffstat (limited to 'Makefile.target')
-rw-r--r--Makefile.target3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.target b/Makefile.target
index fda5bf3c7..d06c67988 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -85,7 +85,8 @@ $(call set-vpath, $(SRC_PATH)/linux-user:$(SRC_PATH)/linux-user/$(TARGET_ABI_DIR
QEMU_CFLAGS+=-I$(SRC_PATH)/linux-user -I$(SRC_PATH)/linux-user/$(TARGET_ABI_DIR)
obj-y = main.o syscall.o strace.o mmap.o signal.o thunk.o \
- elfload.o linuxload.o uaccess.o gdbstub.o cpu-uname.o
+ elfload.o linuxload.o uaccess.o gdbstub.o cpu-uname.o \
+ qemu-malloc.o
obj-$(TARGET_HAS_BFLT) += flatload.o