summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2009-12-07 11:13:04 +0200
committerAvi Kivity <avi@redhat.com>2009-12-07 11:13:04 +0200
commit25ae2ddd778002a6ea3633beca2ac6f6635af6a3 (patch)
tree96ba2d4b50812ffb507a10c0319817594dadc61e /Makefile
parentMerge commit 'a0fb002c6462d21ceb9eac8c5772e469ec189374' into upstream-merge (diff)
parentmonitor: use qemu_gettimeofday(), not gettimeofday() (diff)
downloadqemu-kvm-25ae2ddd778002a6ea3633beca2ac6f6635af6a3.tar.gz
qemu-kvm-25ae2ddd778002a6ea3633beca2ac6f6635af6a3.tar.bz2
qemu-kvm-25ae2ddd778002a6ea3633beca2ac6f6635af6a3.zip
Merge commit 'd08d6f04d6eeedce5090ff66d0676162d7d8d788' into upstream-merge
* commit 'd08d6f04d6eeedce5090ff66d0676162d7d8d788': (23 commits) monitor: use qemu_gettimeofday(), not gettimeofday() win32: fix variable use before initialization monitor: rename EVENT_* to QEVENT_* to avoid conflict on mingw32 Sparc64: fix compilation with DEBUG_MMU ide: implement stub for audio control/volume read ide: Use some already defined page macros instead of constants eepro100: Improve debug messages Remove rule for config-devices.h eepro100: Allocate a larger buffer for regname() multiboot: Use signed type for negative error numbers posix-aio-compat: Fix error check qemu-img: Fix memory leak Fix compile error when LSI_DEBUG is defined Fix build for mingw32 on windows ($$ expansion) Fix build for mingw32 on windows ($@ in macro) e1000: Fix warning from code review multiboot: Fix module loading and setting of mmap. Make -kernel for linux work with bochsbios Fix recently introduced bugs in -usbdevice host Fix description of size parameter in qemu-img's help text ... Conflicts: monitor.c Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 75c7fc5d4..12638f29e 100644
--- a/Makefile
+++ b/Makefile
@@ -39,7 +39,7 @@ SUBDIR_MAKEFLAGS=$(if $(V),,--no-print-directory)
SUBDIR_DEVICES_MAK=$(patsubst %, %/config-devices.mak, $(TARGET_DIRS))
config-all-devices.mak: $(SUBDIR_DEVICES_MAK)
- $(call quiet-command,cat $(SUBDIR_DEVICES_MAK) | grep "=y$$" | sort -u > $@," GEN $@")
+ $(call quiet-command,cat $(SUBDIR_DEVICES_MAK) | grep =y | sort -u > $@," GEN $@")
%/config-devices.mak: default-configs/%.mak
$(call quiet-command,cat $< > $@.tmp, " GEN $@")