aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbellard <bellard@c046a42c-6fe2-441c-8c8c-71466251a162>2003-09-30 20:54:24 +0000
committerbellard <bellard@c046a42c-6fe2-441c-8c8c-71466251a162>2003-09-30 20:54:24 +0000
commit1e43adfc89d2730ab5b24b7a6b5c8ed373b6e284 (patch)
tree3c564f8f0dd5384035404b05acac6a1f9f9cd523 /Makefile
parentsparc emulation target (thanx to Thomas M. Ogrisegg) (diff)
downloadqemu-kvm-1e43adfc89d2730ab5b24b7a6b5c8ed373b6e284.tar.gz
qemu-kvm-1e43adfc89d2730ab5b24b7a6b5c8ed373b6e284.tar.bz2
qemu-kvm-1e43adfc89d2730ab5b24b7a6b5c8ed373b6e284.zip
new directory structure - changed naming of qemu and vl
git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@387 c046a42c-6fe2-441c-8c8c-71466251a162
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile37
1 files changed, 5 insertions, 32 deletions
diff --git a/Makefile b/Makefile
index 28b08cade..bb5f574c0 100644
--- a/Makefile
+++ b/Makefile
@@ -4,14 +4,14 @@ CFLAGS=-Wall -O2 -g
LDFLAGS=-g
LIBS=
DEFINES+=-D_GNU_SOURCE
-TOOLS=vlmkcow
+TOOLS=qemu-mkcow
all: dyngen $(TOOLS) qemu-doc.html
for d in $(TARGET_DIRS); do \
make -C $$d $@ || exit 1 ; \
done
-vlmkcow: vlmkcow.o
+qemu-mkcow: qemu-mkcow.o
$(HOST_CC) -o $@ $^ $(LIBS)
dyngen: dyngen.o
@@ -52,39 +52,12 @@ TAGS:
qemu-doc.html: qemu-doc.texi
texi2html -monolithic -number $<
-FILES= \
-README README.distrib COPYING COPYING.LIB TODO Changelog VERSION \
-configure Makefile Makefile.target \
-dyngen.c dyngen.h dyngen-exec.h ioctls.h syscall_types.h \
-elf.h elfload.c main.c signal.c qemu.h \
-syscall.c syscall_defs.h vm86.c path.c mmap.c \
-i386.ld ppc.ld alpha.ld s390.ld sparc.ld arm.ld m68k.ld \
-vl.c i386-vl.ld vl.h block.c vlmkcow.c vga.c vga_template.h sdl.c \
-thunk.c cpu-exec.c translate.c cpu-all.h cpu-defs.h thunk.h exec.h\
-exec.c cpu-exec.c gdbstub.c bswap.h \
-cpu-i386.h op-i386.c helper-i386.c helper2-i386.c syscall-i386.h translate-i386.c \
-exec-i386.h ops_template.h ops_template_mem.h opreg_template.h \
-ops_mem.h softmmu_template.h softmmu_header.h \
-cpu-arm.h syscall-arm.h exec-arm.h op-arm.c translate-arm.c op-arm-template.h \
-dis-asm.h disas.c disas.h alpha-dis.c ppc-dis.c i386-dis.c sparc-dis.c \
-arm-dis.c \
-tests/Makefile \
-tests/test-i386.c tests/test-i386-shift.h tests/test-i386.h \
-tests/test-i386-muldiv.h tests/test-i386-code16.S tests/test-i386-vm86.S \
-tests/hello-i386.c tests/hello-i386 \
-tests/hello-arm.c tests/hello-arm \
-tests/sha1.c \
-tests/testsig.c tests/testclone.c tests/testthread.c \
-tests/runcom.c tests/pi_10.com \
-tests/test_path.c \
-qemu-doc.texi qemu-doc.html
-
-FILE=qemu-$(VERSION)
+FILE=qemu-$(shell cat VERSION)
+# tar release (use 'make -k tar' on a checkouted tree)
tar:
rm -rf /tmp/$(FILE)
- mkdir -p /tmp/$(FILE)
- cp --parent $(FILES) /tmp/$(FILE)
+ cp -r . /tmp/$(FILE)
( cd /tmp ; tar zcvf ~/$(FILE).tar.gz $(FILE) )
rm -rf /tmp/$(FILE)