aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAvi Kivity <avi@redhat.com>2009-11-22 12:54:55 +0200
committerAvi Kivity <avi@redhat.com>2009-11-22 12:54:55 +0200
commit2ba022bae5087c7c2e098807ce69771e5b177286 (patch)
tree2864f0d3c859b8f00409558f433a6e3d026e86f0 /Makefile
parentMerge commit '59f2689d9082f2f631253c810f73cd22290144a9' into upstream-merge (diff)
parentpci: s/PCI_ADDRESS_SPACE_/PCI_BASE_ADDRESS_SPACE_/ to match pci_regs.h (diff)
downloadqemu-kvm-2ba022bae5087c7c2e098807ce69771e5b177286.tar.gz
qemu-kvm-2ba022bae5087c7c2e098807ce69771e5b177286.tar.bz2
qemu-kvm-2ba022bae5087c7c2e098807ce69771e5b177286.zip
Merge commit '0392a017ae9b44dd5c29bf7769a96fd6806a3551' into upstream-merge
* commit '0392a017ae9b44dd5c29bf7769a96fd6806a3551': (23 commits) pci: s/PCI_ADDRESS_SPACE_/PCI_BASE_ADDRESS_SPACE_/ to match pci_regs.h pci: clean up pci_init_wmask() pci/bridge: clean up of pci_bridge_initfn() pci: use helper functions to access pci config space. pci: helper functions to access PCIDevice::config pci: define a constant to represent a unmapped bar and use it. pci: use PCI_SLOT() and PCI_FUNC(). pci: introduce constant PCI_NUM_PINS for the number of interrupt pins, 4. pci: fix PCI_DPRINTF() wrt variadic macro. Makefile: make qemu-io dependent on config-host.h scsi: move scsi-disk.h -> scsi.h scsi: move scsi.h -> esp.h Makefile: make qemu-img dependant on config-host.h whitelist host virtio networking features qemu-img: Allow creating zero sized images tap: drain queue in tap_send() virtio-net: split the has_buffers() logic from can_receive() net/queue: queue packets even if sender doesn't supply a callback net: disable receiving if client returns zero tap: disable draining queue in one go ... Conflicts: hw/pci.h Manual fixup for hw/device-assignment.c. Signed-off-by: Avi Kivity <avi@redhat.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c45ee7e61..dfdc0dee9 100644
--- a/Makefile
+++ b/Makefile
@@ -222,12 +222,14 @@ libqemu_common.a: $(obj-y)
######################################################################
-qemu-img.o: qemu-img-cmds.h
+qemu-img.o: config-host.h qemu-img-cmds.h
qemu-img$(EXESUF): qemu-img.o qemu-tool.o $(block-obj-y)
qemu-nbd$(EXESUF): qemu-nbd.o qemu-tool.o $(block-obj-y)
+qemu-io.o: config-host.h
+
qemu-io$(EXESUF): qemu-io.o qemu-tool.o cmd.o $(block-obj-y)
qemu-img-cmds.h: $(SRC_PATH)/qemu-img-cmds.hx