aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbellard <bellard@c046a42c-6fe2-441c-8c8c-71466251a162>2003-08-11 23:01:33 +0000
committerbellard <bellard@c046a42c-6fe2-441c-8c8c-71466251a162>2003-08-11 23:01:33 +0000
commit2d80ae898777a9069e38101b1b53a1347f558838 (patch)
treec54ba5d938816304e40e32910f2f0b25bf954f2d /Makefile
parentgcc 3.x is mandatory now on PowerPC (diff)
downloadqemu-kvm-2d80ae898777a9069e38101b1b53a1347f558838.tar.gz
qemu-kvm-2d80ae898777a9069e38101b1b53a1347f558838.tar.bz2
qemu-kvm-2d80ae898777a9069e38101b1b53a1347f558838.zip
avoid problems if make clean was not made before updating
git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@370 c046a42c-6fe2-441c-8c8c-71466251a162
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 52d6383c8..1ecf99c94 100644
--- a/Makefile
+++ b/Makefile
@@ -21,13 +21,15 @@ dyngen: dyngen.o
$(HOST_CC) $(CFLAGS) $(DEFINES) -c -o $@ $<
clean:
+# avoid old build problems by removing potentially incorrect old files
+ rm -f config.mak config.h op-i386.h opc-i386.h gen-op-i386.h op-arm.h opc-arm.h gen-op-arm.h
rm -f *.o *.a $(TOOLS) dyngen TAGS
for d in $(TARGET_DIRS); do \
make -C $$d $@ || exit 1 ; \
done
distclean: clean
- rm -f config-host.mak config-host.h config.mak config.h
+ rm -f config-host.mak config-host.h
for d in $(TARGET_DIRS); do \
rm -f $$d/config.h $$d/config.mak || exit 1 ; \
done