aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuiz Capitulino <lcapitulino@redhat.com>2009-08-28 15:27:30 -0300
committerAnthony Liguori <aliguori@us.ibm.com>2009-09-04 09:37:34 -0500
commit5de65a07ee5c75c4368ee7c7d8ed62c7688b368a (patch)
tree460f96754f7b26382107ffa1191c8c2cc0ceffda /Makefile
parentIntroduce QInt unit-tests (diff)
downloadqemu-kvm-5de65a07ee5c75c4368ee7c7d8ed62c7688b368a.tar.gz
qemu-kvm-5de65a07ee5c75c4368ee7c7d8ed62c7688b368a.tar.bz2
qemu-kvm-5de65a07ee5c75c4368ee7c7d8ed62c7688b368a.zip
Introduce QString unit-tests
This suite contains tests to assure that QString API works as expected. To execute it you should have check installed and build QEMU with check support enabled (--enable-check-utests) and then run: $ ./check-qstring Signed-off-by: Luiz Capitulino <lcapitulino@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index d08df6c52..6537f772c 100644
--- a/Makefile
+++ b/Makefile
@@ -182,6 +182,7 @@ qemu-img-cmds.h: $(SRC_PATH)/qemu-img-cmds.hx
$(call quiet-command,sh $(SRC_PATH)/hxtool -h < $< > $@," GEN $@")
check-qint: check-qint.o qint.o qemu-malloc.o
+check-qstring: check-qstring.o qstring.o qemu-malloc.o
clean:
# avoid old build problems by removing potentially incorrect old files