aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuiz Capitulino <lcapitulino@redhat.com>2009-08-28 15:27:06 -0300
committerAnthony Liguori <aliguori@us.ibm.com>2009-09-04 09:37:29 -0500
commit66f7048712693a6ff877209c1ff36aa8eadf2eb5 (patch)
treecd499ffb8fcb8082aea9da83cc8911bed884a688 /Makefile
parentIntroduce QInt (diff)
downloadqemu-kvm-66f7048712693a6ff877209c1ff36aa8eadf2eb5.tar.gz
qemu-kvm-66f7048712693a6ff877209c1ff36aa8eadf2eb5.tar.bz2
qemu-kvm-66f7048712693a6ff877209c1ff36aa8eadf2eb5.zip
Introduce QString
QString is a high-level data type that can be used to represent C strings. The following functions are available: - qstring_from_str() Create a new QString - qstring_get_str() Get a pointer to the stored string Note that qstring_get_str() is too low-level for a data type like this, but it's interesting for quick read-only accesses. Signed-off-by: Luiz Capitulino <lcapitulino@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 9bf5fb5bf..d7618bad6 100644
--- a/Makefile
+++ b/Makefile
@@ -91,7 +91,7 @@ obj-y += buffered_file.o migration.o migration-tcp.o net.o qemu-sockets.o
obj-y += qemu-char.o aio.o net-checksum.o savevm.o
obj-y += msmouse.o ps2.o
obj-y += qdev.o qdev-properties.o ssi.o
-obj-y += qint.o
+obj-y += qint.o qstring.o
obj-$(CONFIG_BRLAPI) += baum.o
obj-$(CONFIG_WIN32) += tap-win32.o