aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraliguori <aliguori@c046a42c-6fe2-441c-8c8c-71466251a162>2008-09-24 01:13:40 +0000
committeraliguori <aliguori@c046a42c-6fe2-441c-8c8c-71466251a162>2008-09-24 01:13:40 +0000
commit818220f5e9ef39fc5025b9f2277fac483d99d330 (patch)
treedaaa082af9d8a17ebb04273c2b918e96ec611261 /Makefile
parentFix tcg_gen_concat32_i64 on 64-bit hosts. (diff)
downloadqemu-kvm-818220f5e9ef39fc5025b9f2277fac483d99d330.tar.gz
qemu-kvm-818220f5e9ef39fc5025b9f2277fac483d99d330.tar.bz2
qemu-kvm-818220f5e9ef39fc5025b9f2277fac483d99d330.zip
Add missing dependencies for qemu-doc.* (Stefan Weil)
This patch fixes some items in Makefile: * remove duplicate entries from .PHONY * add missing entries to .PHONY * sort entries in .PHONY alphabetically * add missing dependencies for qemu-doc.* targets Signed-off-by: Stefan Weil <weil@mail.berlios.de> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com> git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@5307 c046a42c-6fe2-441c-8c8c-71466251a162
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index de6393e2f..d1a1adb17 100644
--- a/Makefile
+++ b/Makefile
@@ -2,8 +2,8 @@
include config-host.mak
-.PHONY: all clean distclean dvi info install install-doc tar tarbin \
- speed test html dvi info
+.PHONY: all clean cscope distclean dvi html info install install-doc \
+ recurse-all speed tar tarbin test
VPATH=$(SRC_PATH):$(SRC_PATH)/hw
@@ -32,7 +32,7 @@ ifdef CONFIG_WIN32
LIBS+=-lwinmm -lws2_32 -liphlpapi
endif
-all: $(TOOLS) $(DOCS) recurse-all
+all: $(TOOLS) $(DOCS) recurse-all
SUBDIR_RULES=$(patsubst %,subdir-%, $(TARGET_DIRS))
@@ -288,6 +288,8 @@ dvi: qemu-doc.dvi qemu-tech.dvi
html: qemu-doc.html qemu-tech.html
+qemu-doc.dvi qemu-doc.html qemu-doc.info: qemu-img.texi qemu-nbd.texi
+
VERSION ?= $(shell cat VERSION)
FILE = qemu-$(VERSION)