summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark McLoughlin <markmc@redhat.com>2009-10-22 17:49:10 +0100
committerAnthony Liguori <aliguori@us.ibm.com>2009-10-30 08:39:28 -0500
commit88b3ec02b2b17871cd21be1e7588489636f3bebb (patch)
tree2b5f44c7df2e55b45407cfd767a49ac1454ea3d2 /Makefile
parentnet: move solaris code to net/tap-solaris.c (diff)
downloadqemu-kvm-88b3ec02b2b17871cd21be1e7588489636f3bebb.tar.gz
qemu-kvm-88b3ec02b2b17871cd21be1e7588489636f3bebb.tar.bz2
qemu-kvm-88b3ec02b2b17871cd21be1e7588489636f3bebb.zip
net: move AIX code into net/tap-aix.c
Okay, this makes the tap options available on AIX even though there's no support, but if we want to do it right we should have not compile the tap code at all on AIX using e.g. CONFIG_TAP. Signed-off-by: Mark McLoughlin <markmc@redhat.com> Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 306f8ef2b..25e3868e8 100644
--- a/Makefile
+++ b/Makefile
@@ -92,6 +92,7 @@ net-nested-$(CONFIG_POSIX) += tap.o
net-nested-$(CONFIG_WIN32) += tap-win32.o
net-nested-$(CONFIG_BSD) += tap-bsd.o
net-nested-$(CONFIG_SOLARIS) += tap-solaris.o
+net-nested-$(CONFIG_AIX) += tap-aix.o
net-obj-y += $(addprefix net/, $(net-nested-y))
######################################################################